HCL 10.10.0

From OSx86
Jump to: navigation, search
Mac OS X 10.10.0
Hardware Compatibility

This is a component level hardware compatibility list. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying hardware. Add which parts you have working in the categories listed below, or create a new category. Please keep alphabetical order inside the categories. The categories themselves are ordered by popularity. Please list any caveats or problems as well.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.10.0 builds only.

For how to edit the Wiki, please see this thread. Thank you!

You're looking for an Installation guide? see here

Note: For suggestions about table headings, please join the discussion here.

Contents

[edit] Motherboards

[edit] Abit

Hardware Name Chipset Notes Patches Used Compatible 64bit

[edit] Alienware

Hardware Name Chipset Notes Patches Used Compatible 64bit

[edit] Asrock

Hardware Name Chipset Notes Patches Used Compatible 64bit
Z77 Pro-4 Intel Z77 System Configuration:
  • CPU: Intel Core i5 3550 Ivy bridge with oc @ 4100 Mhz (3300 mhz stock freq.)
  • RAM: 1x4GB Kingston 1333 MHz overklocked @ 1800 mhz
  • VGA: ASUS GeForce® 210 EN210 SILENT/DI/1GD3/V2(LP)
  • ETH: 1x Realtek RTL8111E gigabit lan
  • WIFI: Icidu 150N pci-e card, with atheros ar9285 chip
  • SND: Onboard ALC892

System Status:

  • All of the above components: Tick.png
  • Reboot, Shutdown: Tick.png
  • Sleep: Works: Tick.png
Installation method: Pendrive with Yosemite downloaded from App Store and made bootable with a tool i'm not allowed to mention.
  • Boot flags: ncpi=0x3000 GraphicsEnabler=Yes
  • VT-d disabled, Sata on AHCI mode
  • Graphics - Worked OOB Tick.png
  • Network - Worked OOB Tick.png
  • WIFI - Works when using this kext Tick.png
  • USB - Worked OOB Tick.png
  • USB 3.0 - Worked OOB Tick.png
  • SATA - Worked OOB Tick.png
  • App Store - Worked OOB Tick.png
  • Sound - Works when using VoodooHDA kext Tick.png
  • Kernel - Vanilla Mach_kernel Tick.png
Tick.png
G41M-VS3 R2.0 G41,ICH7 System Configuration:
  • CPU: Intel Quad Core 8300
  • GPU: Asus GeForce 210 1024 MB
  • RAM: 8GB DDR3

Components Status: Shutdown, restart, Mac App Store sleep/wakeup not sure yet because I just left it idle for 30 minutes where setting for computer to sleep is 10 minutes, when I touch the keyboard it just run normal, but still not sure when I write this. Asus GeForce 210 1024 MB Works OOB

Install method:

  • Compiled installer with Macpwn by Niresh.
  • I made 2 GUID partitions on HDD on MacMini, 1 for installer (compilled with Macpawn) and 1 for Yosemite install kexts (audio & ethernet) with kextutility

Kexts used:

  • VoodooHDA Audio
  • AtherosL1cEthernet.kext for LAN downloaded from the link on idurdu.blogspot.com
Tick.png
Z75-Pro3 Intel-Z75 System Configuration:
  • CPU: Intel i5 3330;
  • GPU: Asus GeForce GTX 660 2047MB;
  • RAM: 16GB DDR3 Crucial Ballistix 1600 CL9;
  • HDD: Samsung SSD 840 EVO 250GB;

Components Status:

  • SpeedStep (16,23,26,30) works via custom SSDT "-xcpm"
  • Audio ALC892 works via DSDT + Patched AppleHDA;
  • USB 3.0 works via DSDT;
  • Sleep/wakeup 100%;
  • Asus GeForce GTX 660 2047MB works OOB without injection.
Install method:
  • Retail + Clover v2k;
  • SmBios iMac 13,2.

Kexts used:

  • FakeSMC.kext + HWSensors
  • RTL8111.kext
  • EvoReboot.kext (not necessarily)
  • AppleHDA.kext (patched)

Archive with DSDT, SSDT, Config.plist and AppleHDA.kext: Z75-Pro3

Tick.png
Z87 extreme6/ac Intel Z87 System Configuration:
  • CPU: Intel Core i7 4770K Haswell
  • RAM: 2x8GB G.Skill Ares 2133 MHz
  • VGA: ASUS GeForce® GTX 780 OC
  • ETH: 1 x Giga PHY Intel I217V, 1 x GigaLAN Intel I211AT
  • WIFI: Asus PCE-AC68 a/b/g/n/ac + mini-PCI card BCM4352 a/b/g/n/ac
  • SND: Onboard ALC1150

System Status:

  • All of the above components: Tick.png
  • Reboot, Shutdown: Tick.png
  • Sleep: Works: Tick.png
Installation method: Pendrive with Yosemite downloaded from App Store and made bootable usb
  • Boot flags: GraphicsEnabler=No
  • VT-d disabled, Sata on AHCI mode
  • Graphics - Worked OOB Tick.png
  • Network - Worked OOB Tick.png
  • WIFI - Works OOB for Asus + patched kext for mini-PCI card, see here Tick.png
  • USB - Worked OOB Tick.png
  • USB 3.0 - Worked OOB Tick.png
  • SATA - Worked OOB Tick.png
  • App Store - Worked OOB Tick.png
  • Sound - Works when using HDAEnabler + patched AppleHDA Tick.png
  • Kernel - Vanilla Mach_kernel patched to avoid instant reboot, see here Tick.png
Tick.png

[edit] Asus

Hardware Name Chipset Notes Patches Used Compatible 64bit
Maximus ROG VII Hero Intel Z97 Specifications:
  • CPU: Intel Core i7-4770K 4.0 GHz
  • GPU: Gigabyte GeForce GTX 770 4Gb GDDR5 Windforce
  • RAM: 2 x 8Gb Corsair Dominator XMP 1600MHz DDR3
  • SSD: SAMSUNG EVO 840 240Gb SATA 6Gb/s GPT (Win 8.1)
  • HDD: WD Red 4TB HDD GPT (EFI/MacHD/Other)
  • PSW: Corsair CS760M Gold 80+
  • Display: Iiyama 1ms 27" 1920x1080 & Phillips 17"
  • ODD: Samsung USB External BD-RW
  • Install Media: Sandisk Extreme 32GB USB3

BIOS Settings:

  • SecureKeys: Unloaded
  • SecureBoot: OtherOS
  • VT: enabled
  • CMS: UEFI First,
  • Fastboot: disabled

System Status:

  • Graphics: Tick.png
  • Audio: Tick.png
  • Ethernet: Tick.png
  • USB 3.0: Tick.png
  • Sleep/Shutdown/Reboot/Wake: Tick.png

External kexts used:

  • FakeSMC.kext v6.0.1123
  • AppleHDA/realtekALC.kext v1.0
  • AppleIntelE1000e.kext v3.0.4
  • NullCPUPowerManagement.kext

Bootloader (Clover v2k r3021):

  • boot/kext-dev-mode=1 dart=0
  • devices/audio/Inject=1
  • graphics/InjectNVidia=false

Others:

  • System definitions: iMac14,2
Tick.png
B85-PLUS Intel B85 Specifications:
  • CPU: Intel Core i5-4670K 3.4 GHz
  • GPU: ASUS GeForce GTX 560 Ti 1Gb GDDR5
  • RAM: 4 x 2Gb 1600MHz DDR3
  • HDD: SAMSUNG SP2504C 250Gb SATA II
  • PSW: 660 W
  • Display: 1920x1080

BIOS Settings:

  • SecureBoot: OtherOS

System Status:

  • Graphics: Tick.png
  • Audio: Tick.png
  • Ethernet: Tick.png
  • USB 3.0: Tick.png
  • Sleep/Shutdown/Reboot/Wake: Tick.png

External kexts used:

  • FakeSMC
  • AppleHDA/audio_realtekALC-100.command
  • RealtekRTL8111

Bootloader (Clover v2k r2988):

  • boot/kext-dev-mode=1
  • devices/audio/Inject=2
  • graphics/InjectNVidia=yes

Others:

  • System definitions: iMac14,2
Tick.png
P5KPL-AM/PS Intel G31 Specifications:
  • CPU: Intel Pentium Dual-Core E5400 2.70 GHz
  • GPU: Inno3d GeForce 9500GT 1GB DDR2
  • RAM: 2x2 Dual-channel interleaved Kingston 800 MHz DDR2 RAM
  • HDD: WD Cavier Blue SATA II 500GB
  • PSW: 500 W
  • Display: 1600x900 + 1024x768 (Dual-monitor)

BIOS Settings:

  • ACPI 2.0 enabled
  • Legacy USB support enabled
  • Suspend mode: S3 only

System Status:

  • Graphics: Tick.png
  • Audio: Tick.png
  • Ethernet: Tick.png
  • PS/2: Tick.png
  • Sleep/Shutdown/Reboot/Wake: Tick.png

External kexts used:

  • FakeSMC
  • NullCPUPowerManagement
  • VoodooHDA
  • VoodooPS2Controller
  • EvOreboot
  • RealtekRTL81xx

Bootloader (Clover v2k r2953):

  • Inject graphics for Intel, NVIDIA
  • NVRAM fix (+ RC script fix)
  • USB fix

Others:

  • System definitions: iMac11,1
  • Removing unnecessary kexts with "kextcache --(system-)prelinked-kernel" and "kextcache --system-caches" commands applied after.
Tick.png
P5QL/EPU Intel P43 Specifications:
  • CPU: Intel Core 2 Quad CPU Q9400 2,66GHz
  • GPU: NVIDIA GeForce 9600GT 512MB
  • RAM: 4x2 GB 800 MHz DDR2 RAM
  • HDD: 1xWDC WD5000AAKS-00UU3A0 500GB, 2xSeagateST3500418AS 500GB
  • Display: 1920x1080 + 1680x1050 (Dual-monitor)

BIOS Settings:

  • ACPI enabled

External kexts used:

  • FakeSMC
  • NullCPUPowerManagement

Bootloader (Clover v2k r2999)

Tick.png
P8Z77V-Deluxe Intel Z77 Specifications:
  • CPU: Intel Core i7 2600k @ 4.6 GHz
  • GPU: Asus GTX670 DirectCUII Top Edition @ Uefi Bios
  • RAM: 4x4 GSKILL RIPJAW X 1600Mhz XMP DDR3 RAM
  • HDD: Seagate 750GB SATA 2.0
  • PSW: 750W Tacens
  • Display: Dell Ultrasharp U2312HM 1920x1080

BIOS Settings:

  • CSM Disabled. Fully UEFI bios.
  • HPET 64 bits.
  • Intel HD Graphics enabled.

System Status:

  • Graphics: Tick.png
  • Audio: Tick.png
  • Ethernet: Tick.png
  • USB: Tick.png
  • Shutdown/Reboot: Tick.png

External kexts used:

  • FakeSMC
  • NullCPUPowerManagement
  • VoodooHDA 2.7.3 // Audio RealtekALC-100.command
  • AppleIntel1000e 3.1.0
  • RealtekRTL81xx

Bootloader (Clover v2k r2953) Configurator:

  • Graphics: Select your inject preset. If you have Nvidia 600/700 series, disable all, even Nvidia one.
  • IMPORTANT: Move FakeSMC, NullCPUPowerManagement, Realtek and Intel kexts to \EFI\CLOVER\Kexts\10.10\ folder.
  • ACPI Fixes: FixUSB, AddDTGP, FixHDA, FixSATA, FixLAN, FixShutdown & FixIPIC. Remove SSDT options. Check SuspendOverride & HaltEnabler

Others:

  • System definitions: iMac11,3 (you can select 13,2, but AppStore will tell you to update thunderbolt firmware)
  • Add args: -v dart=0 Darkwake=0 Kext-dev-mode=1 slide=0. Check NeverHibernate.
  • On Devices: Audio Detect.
  • Kernel Patches: AppleRTC & Asus AICPUPM
  • System Parameters: Inject Kexts YES & Check Inject System ID
Tick.png
Sabertooth 990FX (rev.1) AMD 990FX Specifications:
  • CPU: AMD Athlon X II 245 @ 2.9 GHz
  • GPU: Zotac GTX550Ti AMP Edition
  • RAM: 2x4 Patriot 1866Mhz XMP DDR3 RAM
  • HDD: WD 250GB SATA 2.0 (GPT)
  • HDD: Hitachi 1000GB SATA 2.0 (GPT)

BIOS Settings:

  • CPU busratio 14 or 15 (default 14.5) (fix audio)
  • SATA Mode to AHCI

System Status:

  • Graphics: Tick.png
  • Audio: Tick.png
  • Ethernet: Tick.png
  • USB: Tick.png
  • Shutdown/Reboot: Tick.png

External kexts used:

  • NVidia Web driver
  • FakeSMC with HWSensor (only ACPI & GPU sensor)
  • NullCPUPowerManagement
  • EvOreboot
  • VoodooHDA 2.8.4 // Audio Realtek ALC892
  • Patched for AMD kexts (IOPCIFamily, AppleACPIPlatform) (graphics error fix)
  • RealtekRTL81xx (official driver from Realtek RTGNICv2.0.6For10.7, work perfect)

Bootloader (Chimera) Configurator:

  • Graphics: GraphicsEnabler=Yes.
  • IMPORTANT: Move NullCPUPowerManagement to \Extra\Extension folder.

Others:

  • System definitions: MacPro 3,1
  • Add args: -v -f kext-dev-mode=1 ncpi=0x2000.
  • Kernel: 10.10 rev 8N (Tora Chi Yo)
  • System Parameters: EthernetBuiltIn=Yes, UseKernelCache=No, USBLegacyOff=Yes
Tick.png
P5K Intel P35 Specifications:
  • CPU: Intel Core 2 Duo 2.66Ghz
  • GPU: Sapphire ATI Radeon HD 5750
  • RAM: 2x2GB DDR2 800Mhz
  • HDD: 320GB Hitachi rpm 7200

JMicron Controller Settings

  • SATA mode: AHCI (Controller SATA only)

System Status:

  • Graphics: Two 1080p Monitors (DVI) Tick.png
  • Audio: (External USB Interface) Tick.png
  • Ethernet: Tick.png
  • USB: Tick.png
  • Shutdown/Reboot: Tick.png

External kexts used:

  • ATI Radeon HD 5000

Notes:

  • Very slow when ATI kexts not installed (afterwards buttery smooth).
  • Sometimes 1 specific USB port at the back won't work (I had to plug my keyboard to a USB 2.0 hub for it to work all the time).
Tick.png

[edit] Biostar

Hardware Name Chipset Notes Patches Used Compatible 64bit

[edit] EVGA

Hardware Name Chipset Notes Patches Used Compatible 64bit

[edit] Foxconn

Hardware Name Chipset Notes Patches Used Compatible 64bit
G31MXP Intel Chipset ICH7 System Configuration:
  • CPU: Intel Core2Quad @2.66GHz
  • GPU: nVidia GeForce GT220 1024 MB
  • RAM: 2GBx2 1066 MHz DDR2 SDRAM

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep: Haven't tested yet
  • USB 2.0 Tick.png
  • Ethernet: Realtek RTL8111/8168 Tick.png
  • Audio: ALC662 Tick.png

Installation Method:

  • OS X Yosemite Chameleon USB install link
  • Bootloader: OS X Yosemite Chameleon r2430 with DSDT.aml link
  • Audio ALC662 works using kexts: HDAEnabler.kext, ALC662.kext and AppleHDA.kext for Yosemite.
  • Audio ALC662 works if you modify your org.chameleon.Boot.plist: remove <key>npci=0x2000</key> <string>Yes</string> and you must write this <key>Kernel Flags</key> <string>kext-dev-mode=1</string>
  • Install with Kext Wizard: NullCPUPowerManagement.kext, EvOreboot.kext (for shutdown), RealtekR1000SL.kext (for Ethernet: Realtek RTL8111/8168)
Tick.png

[edit] Gigabyte

Hardware Name Chipset Notes Patches Used Compatible 64bit
GA-EP35-DS3P Intel P35 ICH-9R System Configuration:
  • CPU: Intel Core2Duo 2.4 Ghz
  • GPU: NVIDIA GeForce 8800GT 512MB
  • RAM: 8GB (4x2GB) DDR2 800MHz

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Tick.png
  • USB 2.0 Tick.png
  • Ethernet Tick.png : RTL8111B
  • GPU: 8800GT DVI Tick.png
  • Audio: external USB Sound Card ("Music Fairy") Tick.png

Installation Method:

  • Guide: Update OS X Mavericks to OS X Yosemite
  • Bootloader: Chimera v4.0.0 with DSDT.aml
Tick.png
GA-P35-DS3R v1.0 Intel P35 Chipset System Configuration:
  • CPU: Intel Xeon 771 E5450 3.0 Ghz
  • GPU: NVIDIA GeForce GTX 660 2048 MB
  • RAM: 2GBx4

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Tick.png
  • USB 2.0 Tick.png
  • Ethernet Tick.png : PCIe Card Marvell Yukon Gigabit Adapter 88E8053
  • GPU: GTX 660 DVI Tick.png , Dual Display
  • Audio: external USB Sound Card Tick.png

Installation Method:

  • OS X Yosemite Chameleon USB install link
  • Bootloader: Chameleon 2.2svn rev2403 with DSDT.aml
Tick.png
GA-P55m-UD2 v1.0 Intel P55 Chipset System Configuration:
  • BIOS: F11
  • CPU: Intel Core i5 @ 3.29 GHz
  • GPU: Nvidia GeForce GTS 250 1024 MB
  • RAM: Kingston HyperX 16 GB (4x4GB) DDR3 1333 MHz
  • Keyboard: Apple Keyboard, USB

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Cross.png (maybe solution on net)
  • USB 2.0 Tick.png
  • Ethernet Tick.png RTL8111D
  • GPU: GTS 250 Tick.png , Dual Display
  • Audio: Tick.png Realtek ALC888b

Installation Method:

Tick.png
GA-P43-ES3G Intel P43 System Configuration:
  • BIOS: F14
  • CPU: Intel Core 2 Quad 9300 @ 3 GHz
  • GPU: Gainward GTX 470 1280 MB
  • RAM: 2x2GB GEIL DDR2 800 MHz RAM

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Cross.png (maybe solution on net)
  • USB 2.0 Tick.png
  • Ethernet Tick.png RTL8111C
  • GPU: GTX 470 Tick.png
  • Audio: Tick.png Realtek ALC888

Installation Method:

  • Create Boot USB (IMPORTANT: MBR Table or Bios will freeze during POST) with Yosemite from Installation App from App Store. Add Clover EFI Bootloader r2953, without ESP partition and Boot0f option.
  • IMPORTANT: Add to USB and later in POST install, kexts FakeSMC, NullCPUPowerManagement and AppleACPIPlatform to EFI\CLOVER\Kexts\10.10\ folder.
  • Add Args to USB: dart=0 Darkwake=0 Kext-dev-mode=1 -v and Install
  • Once Installed, boot from USB again, Install Clover BUT WITH ESP this time, and every single arg or kext like USB part above.
  • IMPORTANT: If rebooting shows Boot0fa error, reboot from USB once again, open Clover Configurator, and select in BOOT: LegacyBiosDefault. Then reboot to OSX without USB plugged, and then open once again Clover Configurator, and switch back BOOT to PBR. It should do the trick.
Tick.png
GA-X79 UD3 v1.0 Intel X79 Chipset System Configuration:
  • CPU: Intel i7 2011 3820 3.7 Ghz
  • GPU: NVIDIA GeForce GTX 680 4096 MB
  • RAM: 8GBx2

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Tick.png
  • USB 2.0 Tick.png
  • Ethernet Tick.png
  • GPU: GTX 680 DVI Tick.png , Dual Display
  • Audio: external USB Sound Card Tick.png

Installation Method:

  • OS X Yosemite Chameleon USB install link
  • Bootloader: Chameleon 2.2svn rev2403, first boot add -v cpus=1 npci=0x2000 pos installation add ncpi=0x2000 chameleon.boot.plist
Tick.png
Z68AP-D3 uefi BIOS Intel® Z68 Express System Configuration
  • CPU: Intel Core-i3
  • RAM: 8GB DDR3 1333 MHz
  • GPU: nVidia GeForce 210 1024 МБ
  • Network: Onboard RTL8111E
  • Audio: Behringer UCA222 USB

Component Status:

  • GPU Tick.png
  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Tick.png - Wakes up by keyboard hit w\o problem but CPU cooler is working in sleep mode.
  • Ethernet Tick.png
  • Haven't tried built-in sound, using USB sound card
Notes
  • (!) Type "PCIRootUID=0 GraphicsEnabler=YES", otherwise I only could boot if display plugged to built-in HDMI during BIOS messages and POST, and replug display to Nvidia PCI when system has booted.
  • Sound and Ethernet works during Installation
  • User DSDT or DSDT-Free installation (I have no DSDT)
Tick.png
GA-Z87-HD3 Intel Z87 Chipset System Configuration:
  • BIOS: F7
  • CPU: Intel Core i5-4670K @ 4.25 GHz
  • GPU: Nvidia GeForce GTX 660 OC 2048 MB
  • RAM: Crucial Ballistix Sport 16 GB (4x4GB) DDR3 1666 MHz
  • Keyboard: DasKeyboard, USB

Component Status:

  • Shutdown: Tick.png
  • Restart: Tick.png
  • Sleep: Haven't tested yet
  • USB 2.0: Tick.png
  • USB 3.0 :Tick.png (GenericUSBXHCI.kext)
  • Ethernet: Tick.png, using RealtekRTL81xx.kext
  • GPU: GTX 660 Tick.png, Triple Display (DP, HDMI, DVI w/VGA adapter)
  • Onboard Graphics: Not tested yet
  • Audio: Cross.png Realtek ALC892 (can't get it to work)

work for me with http://www.insanelymac.com/forum/files/file/147-applehda-for-realtek-alc892/

Installation Method:

  • Followed instructions here, for the most part
  • Set BIOS to UEFI only
  • Using Clover r2953, UEFI only
  • Boot args: -v GraphicsEnabler=No dart=0 npci=0x3000 kext-dev-mode=1
  • Also disabled C-states and P-states until patched kexts installed
  • Installed kexts as instructed to in the guide
Tick.png
GA-B75M-D3V Intel B75 Chipset System Configuration:
  • CPU: Intel Core i3 @ 3.49 GHz
  • GPU: Nvidia GeForce GTX 650 1024 MB (MSI)
  • RAM: Kingston 8 GB (2x4GB) DDR3 1666 MHz
  • Keyboard/Mouse: Wireless Microsoft Keyboard/Mouse, USB

Component Status:

  • Shutdown: Tick.png OOB
  • Restart: Tick.png OOB
  • Sleep: Tick.png It wakes only with the power button, OOB
  • USB 2.0: Tick.png OOB
  • USB 3.0 :Tick.png OOB
  • Ethernet: Tick.png OOB
  • GPU: GTX 650 Tick.png, Dual Display(HDMI+VGA, Main Screen: HDMI, Boot Screen: VGA -i don't know how to fix this)
  • Onboard Graphics: Not tested yet
  • Audio: Cross.png Realtek ALC887 (Not Tested but not listed on audio devices OOB )

Installation Method:

  • Clean USB Using the basic (known) Method
  • BIOS: UEFI & Legacy (I am using legacy)
  • Using Chameleon r2510
  • Boot args: -f kext-dev-mode=1 darkwake=0 EthernetBuiltIn=Yes UseKernelCache=Yes (optional: Graphics Mode 1920x1080x32)
      • Some of the kexts Didn't edited from me. they was there before! I just added the -f (i had problem booting from my HD without this one) and the graphics mode!
  • No other kexts needed to be installed (Everything worked OOB). Maybe except Internal Sound card (i use external usb card : AKAI EIE PRO)
Tick.png

[edit] Intel

Hardware Name Chipset Notes Patches Used Compatible 64bit
DG31PR Intel G31 System configuration:
  • Intel Core 2 Duo E7400
  • Intel G31 chipset
  • HDD: Hitachi HDS721010CLA332 (1TB)
  • RAM: 2x 2GB Kingston DDR2 800
  • NVIDIA GeForce GT240 1GB GDDR5 (GraphicsEnabler)
  • Audio ALC888
  • RTL8111GR integrated Gigabit Ethernet
  • D-Link DWA-525 wireless NIC
Installation notes:
  • Yosemite 10.10 retail
  • Used Chris1111's Yosemite USB installer package; setup USBs made using the latter tool won't boot properly unless if the org.chameleon.boot.plist startup flags are set to kext-dev-mode=1 dart=0 USBBusFix=Yes PCIRootUID=0. The same flags should also be used once OS X is installed.
    • Installer should also be patched to work on MBR partitions. May work with GUID but this is untested.
  • For some reason neither Chameleon r2404 or the Enoch r2403 bootloader supplied with Chris' installer won't work if installed on the Yosemite HDD; Chameleon r2401 and r2407 should work using the above boot flags.
  • Audio works using Piker-Alpha's AppleHDA8Series.sh scripted method as suggested in the latter thread. Ermac however, suggested on doing away with the HDAEnabler kext, but the HDAEnabler=yes flag doesn't seem to work.
    • Setting the SMBIOS profile to MacPro3,1 via Chameleon Wizard should help with the audio surge/popping problem when the sound card is left idle.
  • Mieze's RTL8111 kext should work fine without any problems

Working:

  • Shutdown/Reboot/Sleep
  • Graphics acceleration (2D/3D)
  • Most applications including Adobe Premiere, Photoshop and the like
  • Peripherals such as printers e.g. Brother DCP-J105

Known issues:

  • Unfortunately no drivers for the DWA-525 are available as of 2014. A wireless range extender can be used as a makeshift Wi-Fi access point to work around the problem though. :)
Tick.png
DG31PR Intel G31 System configuration:
  • Intel Core 2 Duo E7400
  • Intel G31 chipset
  • RAM: 4GB
  • Gigabyte GeForce 9400 GT 1GB
  • Audio ALC888
  • RTL8111GR integrated Gigabit Ethernet
  • Asus N-10 USB Wifi (official driver)
Installation notes:

Working:

  • Shutdown/Reboot/Sleep
  • Graphics acceleration (2D/3D)
Tick.png

[edit] MSI

Hardware Name Chipset Notes Patches Used Compatible 64bit
G33M Intel® G33+ICH9/ICH9R System configuration:
  • CPU: Intel Core 2 Duo 2.33GHz
  • GPU: Ati Radeon HD 4650 512MB
  • RAM: 4GB DDR2 667MHz
  • HDA: Realtek® ALC888

BIOS Settings:

  • Default settings + Execute Disable Bit: On + SATA Control Mode: SATA

Installation method:

  • App Store InstallESD.dmg on USB FLASH
  • Clover on USB FLASH + FakeSMC.kext
  • After install added Graphic Card Device ID (0x94981002) in AMD4600Controller.kext

System Status:

  • Graphics: QE, full 3D acceleration, (HDMI not working - in process) native resolution, Samsungl 24" monitor detected correctly Tick.png
  • Audio Cross.png - in process
  • Ethernet Tick.png w/ kext
  • USB 2.0 Tick.png
  • App Store, iTunes Store Tick.png
  • Sleep, Wakeup Cross.png
  • Poweroff Tick.png
Post-installation:
  • 3rd Party SATA
  • EvOreboot
  • FakeSMC
  • NullCpuPowerManagement
  • Network -> marvel 88E8056 kext
  • Chimera Bootloader
  • System definitions -> MacPro5,1
Tick.png

[edit] PCWARE

Hardware Name Chipset Notes Patches Used Compatible 64bit

[edit] QUO

Hardware Name Chipset Notes Patches Used Compatible 64bit

[edit] Supermicro

Hardware Name Chipset Notes Patches Used Compatible 64bit
X8DTi-F Intel® 5520 (Tylersburg) Chipset System configuration:
  • CPU: Intel Xeon Westmere-EP X5650 6-core 2.67GHz x2
  • GPU: Gainward Nvidia GTX 660 2GB
  • RAM: 24GB - IBM (Micron Technology) 4GB ECC Reg. DDR3 1333MHz x6
  • HDA: No onboard audio - Using ASUS Xonar U7 USB sound card
  • NIC: No drivers for onboard Intel® 82576 Dual-Port GbE - Using Realtek RTL8169 (TP-Link) PCI card
  • HDD: Samsung 840 EVO 500GB
  • IO: PCIe 4-port SATA III card (bootable)
  • IO: Inateck PCIe USB 3.0 card 5-port (rear) + 2-port header (front)
  • IO: Bluetooth 4.0 USB 2.0 dongle (Partlist)

BIOS Settings:

  • Default settings + CPU stepping settings

Installation method:

  • App Store InstallESD.dmg
  • USB Installation - Upgraded from 10.9.4

System Status:

  • Graphics: QE, full 3D acceleration, native resolution, Dell 27" U2711 (DP) monitor detected correctly Tick.png
  • Audio Tick.png - w/ USB audio adapter
  • Ethernet Tick.png w/ addon card
  • USB 2.0 Tick.png
  • USB 3.0 Tick.png w/ add-on card
  • BT 4.0 Tick.png w/ USB dongle
  • Apple Wireless Keyboard, Magic Trackpad, Magic Mouse Tick.png
  • TimeMachine, App Store, iTunes Store Tick.png - w/ Ethernet fix (disable onboard LAN in BIOS)
  • Sleep, Wakeup Cross.png
  • Poweroff Tick.png
Post-installation:
  • 3rd Party SATA
  • EvOreboot
  • FakeSMC
  • NullCpuPowerManagement
  • Network -> AppleRTL8169Ethernet 2.0.6
  • Chimera Bootloader
  • System definitions -> MacPro5,1
Tick.png

[edit] Graphics Cards

Please specify if your card is PCI-E or Integrated.
Also, place chip and board manufacturer in their respective column.

[edit] PCI-E

[edit] AMD/ATI

Model Board-Manufacturer Notes QE/CI Output Dual display Compatible 64bit
Radeon™ HD 4830 Sapphire
  • Using QE_CI Exotic patch
  • Chameleon 2.0 RC5 (or the most recent) or PCEFI 10.6 Lion + Snow or Clover
  • GraphicsEnabler=Yes
Tick.png DVI / DVI Not tested Tick.png
Radeon™ HD 6770 Sapphire
  • Using those methods
  • Chameleon 2.0 RC5 (or the most recent) or PCEFI 10.6 Lion + Snow or Clover
  • GraphicsEnabler => No more need!!!
Tick.png DVI / HDMI / VGA Yes with FB set to Bulrushes Tick.png

[edit] NVIDIA

Model Board-Manufacturer Notes QE/CI Output Dual display Compatible 64bit
GTX 570 1280 MB PNY Tick.png 2DVI + DP + HDMI Not Tested Tick.png
GTX 750 2048MB[1] Gigabyte
  • Boot for install chameleon nv_disable=1[2]
  • Download Nvidia Web Driver[3]
  • Download Pacifist and install the new nVidia driver within the package
  • Open up a terminal window and run the following command: sudo nvram boot-args="nvda_drv=1"
  • Restart nv_disable=1, install full Nvidia web driver package, Restart nv_disable=1 enable nvidia driver in nvidia preference pane, Restart
Tick.png Dual-link DVI-Ix1/DVI-Dx1/HDMIx2 Tick.png Tick.png
GTX 660 OC 2048MB Gigabyte
  • Used GraphicsEnabler=No in boot args
  • Downloaded NVIDIA CUDA driver
Tick.png DP, HDMI, DVI w/VGA adapter Tick.png Tick.png
GTX 660 SC 2048MB EVGA
  • Used GraphicsEnabler=No in boot args
  • Works with both native driver and web driver
  • If encounter "NVDA(OpenGl): Channel timeout!", update motherboard BIOS. Is not a gpu error.
Tick.png DP, HDMI, DVI w/VGA adapter Tick.png Tick.png
GTX660-DC2-2GD5 ASUS
  • OOB no injection (Clover v2k)
  • CUDA driver
  • Nvidia web drivers
Tick.png DP, HDMI, DVI Tick.png Tick.png
GTX 780 3072MB[4] ASUS
  • Used GraphicsEnabler=No in boot args
Tick.png Dual-link DVI-Ix1/DVI-Dx1/HDMIx1/DPx1 Tick.png Tick.png

[edit] Integrated

[edit] INTEL

Model Board-Manufacturer Notes QE/CI Output Dual display Compatible 64bit

[edit] Network Cards

[edit] Wireless

Interface Standard Device Manufacturer Chipset Notes Compatible 64bit

PCIe x1

a/b/g/n

TP-LINK TL-WDN4800

AR9380

No 5GHz, product page here

Tick.png

PCIe x1

a/b/g/n/ac

ASUS PCE-AC68

BCM94360

product page FR here

Tick.png

mini PCIe x1

a/b/g/n/ac + BT 4.0

AzureWave Broadcom BCM94352HMB

BCM94352

Need to patch kexts, follow this thread here

Tick.png

[edit] Wired (Ethernet)

Interface Standard Device Manufacturer Notes Compatible 64bit
USB3 (tested on USB2) 10/100/1000 ethernet JUE130 j5create *Install driver from manufacturer website or included cd Tick.png

[edit] Sound Cards

Interface Hardware Name Manufacturer Notes Compatible 64bit

USB 2.0

U-CONTROL / UCA202

Behringer

works ootb
16 BIT/48 KHZ AUDIO INTERFACE
Stereo Chinch in and out ,
3.5mm headphone-jack,
optical S/PDIF out

Tick.png

[edit] Webcams

Interface Hardware Name Manufacturer Notes Compatible 64bit
USB 2.0 Logitech HD Webcam (C525) Logitech Worked out-of-box Tick.png
USB 2.0 Logitech QuickCam Ultra Vision SE Logitech Worked out-of-box Tick.png
USB 2.0 Microsoft LIFECAM VX 700 Microsoft Works OOB Tick.png
USB 2.0 Microsoft LIFECAM HD 3000 Microsoft Works OOB Tick.png

[edit] Bluetooth

Interface Item Description Manufacturer Chipset Notes Compatible 64bit
USB 2.0 USBBT100 Bluetooth Dongle Linksys Works OOB. Bluetooth networking (PAN) not supported. Tick.png

[edit] USB 3.0 Cards / Adapters

Type of Accessory Item Description Manufacturer Notes Compatible 64bit

[edit] Keyboard & Mouse

[edit] Wireless

Interface Item Description Manufacturer Model No Notes Compatible 64bit

This page was last modified on 28 October 2015, at 18:27.
This page has been accessed 130,238 times.
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers