HCL 10.11.3

From OSx86
Jump to: navigation, search
OS X 10.11.3
Hardware Compatibility

This is a component level hardware compatibility list. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying hardware. Add which parts you have working in the categories listed below, or create a new category. Please keep alphabetical order inside the categories. The categories themselves are ordered by popularity. Please list any caveats or problems as well.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.11.3 builds only.

For how to edit the Wiki, please see this thread. Thank you!

You're looking for an Installation guide? see here

Note: For suggestions about table headings, please join the discussion here.

Contents

[edit] Motherboards

[edit] Abit

Hardware Name Chipset Notes Patches Used

[edit] Alienware

Hardware Name Chipset Notes Patches Used

[edit] Asrock

Hardware Name Chipset Notes Patches Used Compatible 64bit
G41M-VS3 R2.0 G41,ICH7 System Configuration:
  • CPU: IIntel Core 2 quad 9800
  • GPU: nvidia gt610 1gb
  • RAM: 8GB DDR3 1333
  • Keyboard: ok
  • Mouse: ok

Components Status:

  • Shutdown, restart, Updates Through MacAppStore
  • sleep, wakeup Not Tested
  • nvidia gt610 1gb

Install method:

  • Compiled installer with Macpwn by Niresh.
  • bootloader Clover efi 3320
  • Replaced org.chameleon.Boot.plist
Patches:
  • Kexts Audio (1)alc662.kext,AppleHDA.kext,HDAenabler.kext ,(2)VoodooHDA 2.7.2,( AtherosL1cEthernet.kext for LAN)
  • search on google kext audio 10.8.5.ALC662.FULLY.WORKING.ML.by.KemalALKIN
Tick.png
ASRock H81m DGS R2.0 H81m

[edit] ASUS

Hardware Name Chipset Notes Patches Used
P6T6 WS Revolution Intel® X58/ICH10R/NVIDIA NF200 System Configuration:

System Status:

  • Shutdown & RestartTick.png
  • Updates through MacAppStoreTick.png
Installation method:

Installation is Create a bootable installer for OS X. with CloverEFI USB stick boot. Updated 10.11.0 to 10.11.3 via apple software updated.

  • CloverEFI r3346 (The latest version is required.) config.plist
SMBIOS: MacPro5,1
Boot: kext-dev-mode=1, nvda_drv=1
Audio: Inject 7
KextsToPatch: External icons patch, Patching 11d4198b with 11d4989b codec
RtVariables: BooterConfig & CsrActiveConfig Using for SIP status custom configuration.
  • DSDT & SSDT: Generate on Ubuntu, and patched on OSX.
  • Audio: AppleHDAPatcher: Used config.plist, DSDT Patches, aDummyHDA.kext in S/L/E. (Necessary latest CloverEFI & Kext Signing: disabled.)
If you patching AppleHDA, The SIP needs customised configuration.


[edit] Biostar

Hardware Name Chipset Notes Patches Used

[edit] DFI

Hardware Name Chipset Notes Patches Used

[edit] EVGA

Hardware Name Chipset Notes Patches Used

[edit] Foxconn

Hardware Name Chipset Notes Patches Used

[edit] Gigabyte

Hardware Name Chipset Notes Patches Used
GA-Z170XP-SLI Intel Z170 Chipset System Configuration:
  • CPU: Intel Core™ i5-6500 3.2 GHz
  • GPU: ASUS Strix GeForce GTX 970 4GB
  • RAM: 2 x Kingston Fury 8GB DDR4 2133MHz
  • Display: Dell P2416D

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Tick.png
  • USB 2.0 Tick.png
  • USB 3.0 Tick.png
  • USB 3.1 Tick.png
  • Ethernet Tick.png : Intel I219-V
  • GPU: Displayport Tick.png, DVI and HDMI not tested
  • Audio: ALC1150, back and front panels Tick.png

See Skylake Starter Guide (<-- Thanks a lot)
All necessary files

- Run EFI/CLOVER/misc/apple_hda_patch.sh to get ALC1150 working
- To get GTX 970 working install NVidia Web Driver 346.03.05f01
I don't know why but patching on-the-fly doesn't work (config.plist->KextsToPatch), so edit the file
/System/Library/Extensions/AppleGraphicsControl.kext/Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist manually
Find the key Mac-F60DEB81FF30ACF6 and change the value from "Config2" to "none"

Optional:
- Put EFI/CLOVER/misc/SSDT-USB.aml to /EFI/CLOVER/ACPI/patched/ to disable unused USB ports
If you've got any questions, email me. I'm not a geek but I will try to help. (dimmorpheus@gmail.com)

GA-Z170X-UD3 Intel® Z170 Chipset System Configuration:
  • CPU: Intel Skylake i6700
  • Graphic card : ATI HD 7700
  • RAM: 4x8 GB DDR4 @2400Mhz

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • CPU Cstates Tick.png
  • USB 2.0 Tick.png
  • Ethernet Tick.png  : IntelMausiEthernet.kext (Dec '15)
  • Graphic card Tick.png
  • Audio: Onboard ALC1150 Tick.png  : Using patch Script "audio_realtekALC-110_v1.0k.command"
  • Boot Arguments for install : dart=0 PCIRootUID=0 -v kext-dev-mode=1
  • Bootloader: Clover 3346
  • "OsxAptioFixDrv2" in clover.
  • verde.kext
  • USBInjectAll.kext
  • FBName = Futomaki
  • AppleRTC = true, KernelPm=true
  • AppleAPIC.kext patch (thanx pike)
GA-Z97-HD3 Intel® Z97 Express Chipset System Configuration:
  • CPU: Intel® Core™ i7-4790K 4.0 GHz
  • Graphic card : ATI HD 6850 x2
  • RAM: 4x8 GB DDR3 @1600Mhz

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • Sleep Tick.png
  • USB 2.0 Tick.png
  • USB 3.0 Tick.png
  • Ethernet Tick.png
  • Graphic card Tick.png works OOB
  • Audio: Hercules DJ Console 4-Mx Tick.png

Install method:

  • Installed OS X 10.11 using MacPwn El Capitan from Yosemite.
  • Updated to 10.11.3 from APPStore with no problem.
  • Bootloader: Enoch 2795
  • Boot Arguments: none


Patches:

  • RealtekRTL8111.kext for LAN
GA-G31M-ES2L Intel® G31 Chipset System Configuration:
  • CPU: Intel Core 2 Duo E6300
  • Graphic card : NVDIA 9500 GT
  • RAM: 2 x 2GB DDR2 800MHz

Component Status:

  • Shutdown Tick.png
  • Restart Tick.png
  • CPU Cstates : Don't Know
  • USB 2.0 Tick.png
  • Ethernet Tick.png  : RealtekRTL8111.kext (Version 2.0.0)
  • Graphic card Tick.png
  • Audio: Onboard Realtek ALC 883Tick.png  : Using a Kext + AudioEnabler

Installation instruction

[edit] Intel

Hardware Name Chipset Notes Patches Used
Intel® DH77KC Intel® H77 Chipset

System Configuration:

  • CPU: Intel Core i5-3330 @ 3GHZ
  • GPU: Zotac® GeForce® GTX 650TI
  • RAM: 16GB Kingston® DDR3-1333
  • Hard Drive: 2x HD Kingston SSD Now V300 SV300S37A 240GB 2.5"
  • PIONEER DVD-RW DVR-212D
  • Apple Keyboard with Numeric Keypad
  • Magic Mouse 2
  • SMBIOS set to MacPro3,1

Component Status:

  • Graphics Card works Tick.png
  • Audio Realtek® ALC892 works Tick.png
  • Ethernet AppleIntelE1000e works Tick.png
  • USB 2.0 / USB 3.0 works (All) OOB Tick.png
  • Sleep/Shutdown/Reboot Works (All) OOB Tick.png

Install Procedure:

-> Create the USB Install Disk, add Clover Boot Loader to it, with the options:

  • ACPI: FixShutdown
  • BOOT: darkwake, dart=0, nv_disable=1, kext-dev-mode=1
  • Kernel and Kext Patches: AsusAICPUPM , AppleRTC , KernelPM
  • SMBIOS: MacPro3,1
  • DRIVERS UEFI 64BIT: CsmVideoDxe, OsxAptioFix2Drv and VBoxHfs
  • EXTRA DRIVERS: OsxFatBinaryDrv UEFI
  • INSTALLER KEXTS ( to EFI > CLOVER > kexts > 10.11 )
  • 1) Install AppleIntelE1000e.kext
  • 3) Install FakeSMC.kext
  • Install and Reboot, Boot again the USB Install, but choose the newly installed Hard Drive.

Post Install:

-> Install Clover to the Current Hard Drive with the following options:

  • ACPI: FixShutdown
  • BOOT: darkwake, dart=0, nvda_drv=1, kext-dev-mode=1
  • SMBIOS: MacPro3,1
  • DRIVERS UEFI 64BIT: CsmVideoDxe, OsxAptioFix2Drv and VBoxHfs
  • EXTRA DRIVERS: OsxFatBinaryDrv UEFI
  • SYSTEM KEXTS:
  • 1) Install Realtek ALC892 with audio_cloverALC-110_v1.0o10
  • 2) Install AppleIntelE1000e.kext ( to EFI > CLOVER > kexts > 10.11 )
  • 3) Install FakeSMC.kext ( to EFI > CLOVER > kexts > 10.11 )
  • 4) Install NVIDIA® Web Driver for OSX ® 10.11.3
  • 5) TRIM: Open Terminal, “ sudo trimforce enable ”, will ask you to accept, then reboot. In order to check if it is working, after reboot type in the Terminal " system_profiler SPSerialATADataType | grep 'TRIM' "
Tick.png

[edit] MSI

Hardware Model Manufacturer Chipset CPU Socket Notes Patches Used
Z97A Gaming 5 MSi Intel® Z97 LGA 1150 The motherboard works out of the box. No patching was needed
Z97S SLI Krait Edition MSi Intel® Z97 Express LGA 1150 Ethernet needs kext, audio needs patching.


If using Clover, make sure KernelPM is checked (set to True) in your config.plist

RealtekRTL8111.kext for Ethernet. Make sure it's updated!


Toleda's Clover patch-on-the-fly script with realtekALC.kext (the script does everything; just run it)

[edit] PCWARE

Hardware Name Chipset Notes Patches Used

[edit] QUO

Hardware Name Chipset Notes Patches Used

[edit] Supermicro

Hardware Name Chipset Notes Patches Used

[edit] Graphics Cards

Please specify if your card is PCI-E or Integrated.
Also, place chip and board manufacturer in their respective column.

[edit] PCI-E

[edit] AMD/ATI

Model Board-Manufacturer Notes QE/CI Output Dual display
Radeon™ HD 4830 Sapphire
  • Using QE_CI Exotic patch
  • Clover
Tick.png DVI / DVI Not tested
Radeon™ HD 6770 Sapphire
  • Using HD6770_QE_CI_Patch
  • Clover
Tick.png DVI / HDMI / VGA Not tested

[edit] NVIDIA

Model Board-Manufacturer Notes QE/CI Output Dual display
GTX 570 1280 MB PNY Tick.png 2DVI + DP + HDMI Not tested
9500 GT Gainward
  • GraphicsEnabler = Yes
  • 1GB Version successfully tested
Tick.png DVI + VGA+ HDMI Not tested
8600 GTS Leadtek
  • GraphicsEnabler = Yes
  • 640MB Version successfully tested
Tick.png 2DVI Not tested
GTX 650 OC 2GB DDR5 MSi
  • works OOB (either with the default Apple driver or Nvidia driver)
  • requires some edits for the second-stage boot logo to appear
Tick.png DVI + VGA+ HDMI Tested HDMI + VGA, works.

[edit] Integrated

[edit] INTEL

Model Board-Manufacturer Notes QE/CI Output Dual display

[edit] Network Cards

[edit] Wireless

Interface Standard Device Manufacturer Chipset Notes
PCI-E IEEE 802.11n, IEEE 802.11g, IEEE 802.11b, CSMA/CA with ACK TL-WN881ND V1.1 TP-LINK Atheros AR9287 Works with toledaARPT.kext,

IONetworkingFamily.kext and IO80211Family.kext = vanilla

USB 802.11 b/g/n TL-WN725N V2 TP-LINK RTL8188EU WORK with this driver: http://www.tp-link.com/res/down/soft/TL-WN725N_V2_160128.zip

[edit] Wired (Ethernet)

Interface Standard Device Manufacturer Notes

[edit] Sound Cards

Interface Hardware Name Manufacturer Notes
USB 2.0 CSL USB 7.1 Soundcard CSL Needs a few Seconds to Install but then it works without any issue.
  • Tested on 10.9.5 and 10.11.3 Tick.png

[edit] Webcams

Interface Hardware Name Manufacturer Notes
USB C615 Logitech Works OOB. Tick.png

[edit] Bluetooth

Interface Item Description Manufacturer Chipset Notes

[edit] USB 3.0 Cards / Adapters

Type Name Manufacturer Notes

[edit] Keyboard & Mouse

[edit] Wireless

Interface Item Description Manufacturer Model No Notes
USB wireless/cordless keyboard & mouse combo Logitech LX300 Works OOB Tick.png

This page was last modified on 4 April 2016, at 14:49.
This page has been accessed 43,538 times.
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers