HCL 10.4.9

From OSx86
Jump to: navigation, search
Mac OS X 10.4.9
Hardware Compatibility

This is a component level hardware compatibility list. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying hardware. Add which parts you have working in the categories listed below, or create a new category. Please keep alphabetical order inside the categories. The categories themselves are ordered by popularity. Please list any caveats or problems as well.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.4.9 builds only.

For how to edit the Wiki, please see this thread. Thank you!

You're looking for an Installation guide? see here

Contents

[edit] Motherboards

A comprehensive list of possible Intel chipsets

PLEASE INCLUDE THE SOUTH BRIDGE TOO

[edit] AMD


[edit] Abit

NF-M2 nView Nvidia nForce 4300
  • Onboard Ethernet (Realtek RTL8111B) - Does not work
  • Onboard Sound (Realtek ALC883) - Works
  • Onboard GeForce 6150 - Does not work (only VESA, not Natit or Titan)
  • SATA - Not tested
  • PATA - Works
Yes, Uphuck 1.2 and 1.3 with sound driver
LG-95 Intel 945GC + ICH7
  • BIOS version: 14
  • Installation method: uphuck 10.4.9
  • Audio (ALC 883): 2ch only so far. Works with Azalia driver from installer.
  • Video (GMA 950): Not tested, used with Geforce 7600GS
  • IDE and SATA: Works out of the box
  • ACPI: Restart & Shutdown works fine so far.
  • PROs: Very cheap and compatible.
  • CONs: NOT an overclocker motherboard, FSB is locked in the Bios.
Yes, uphuck -


. .

[edit] As-Rock

Hardware Name (socket type) Chipset Notes Fully working without patching
ASROCK Conroe 1333-D667 (socket 775) 945G/ICH7 2.33GHz Core2Duo

Installed JAS 10.4.6, then upgraded to 10.4.10 with Mac.Nub I've Been running this system rock solid at least 6 months with no glitches! Also, I understand that upgrading the BIOS past v1.3 will make it not work. Anyone had any luck with the newest BIOS v1.6? I want to get a wolfdale chip which isn't supported prior to BIOS rev 1.6. Also, I'm using a PNY 7300GT 256MB working full QE/CI/OpenGL with mac.nub's 256MB inject driver on the 10.4.10 disc.

*No. But everything works if you apply Mac.nub's GMA950 and R1000 drivers from the 10.4.10 disc during install, so YES, sort-of.

Am booting with an IDE drive. Haven't gotten SATA working native bootable, but it sees all drives attached.

. . .

[edit] Asus

Hardware Name (socket type) Chipset Notes Fully working without patching
A8N SLI Deluxe socket 939 NForce 4 Installed
  • from Uphuck 10.4.9 v1.3 upgraded to 10.4.10
  • Dethforce
  • sound, network (with patch) work
  • I had to put a line in the boot file to get the keyboard to work
  • I haven't tried the sata much as I heard there were errors
  • Win XP is on sata drive, Mac is on pata
no
. . . . . . . . . . . . . .

[edit] DFI

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] ECS

Hardware Name (socket type) Chipset Notes Fully working without patching
P4M800PRO-M VIA P4M800Pro & VT8237R+ Install JAS 10.4.8 with semthex...then used these instructions to update to 10.4.9 http://forum.insanelymac.com/index.php?showtopic=45283&hl
  • Place holder
Place holder
. . . .

[edit] Foxconn

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] Gigabyte

Hardware Name (socket type) Chipset Notes Fully working without patching
8I865GME Rev 2.0 Everything working fine. usb 2.0 sata II, lan, audio, firewire, video only 1024*764. restart problem solved. little slow than jas 10.4.7. DVD player not working. uphuck 10.4.9

[edit] MSI

Hardware Name (socket type) Chipset Notes Fully working without patching
MSI 915PL Neo-V LGA775 Intel 915PL + ICH6 Everything seems to be working smoothly except for the following:
  • System Preferences show that I have audio input from my headphone but Skype isn't working properly(cannot hear contact speaking, nor can the other side)
  • When dual-booting with XP, Ethernet doesn't work after a Reboot in XP; instead of Reboot, a full shutdown (power off) is required to solve this problem
Yes

[edit] PC Chips

Hardware Name (socket type) Chipset Notes Fully working without patching
P17G Intel 945GC ICH7 All Pro Apps Working fine, minor issues with video card not displaying certain things, iLife, tested
with JaS Tiger 10.4.9 and Kallyway Leo 10.5.1
No Patching Needed
. . .

[edit] Intel


[edit] Abit

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] Albatron

Hardware Name (socket type) Chipset Notes Fully working without patching
PX865 PEPROII Intel 865 PE/ ICH5 Uphuck 10.4.9 1.3i with Intel SSE3 kernel. Everything seems to work.
  • No fully tested yet
No
. . . . . . .

[edit] AsRock

Hardware Name (socket type) Chipset Notes Fully working without patching
4CoreDual-VSTA PT 880 Ultra Chipset Install method : Uphuck 1,4
  • Format & set partition as MBR
  • patch : CPUPowermanagemnt
  • VGA : ViaRhine
  • System : Azalia Out
  • Network : Via Rhine
Fully
Place holder Place holder Place holder
  • Place holder
Place holder
. . . . . . . . . . . . . . . .

[edit] Asus

Hardware Name (socket type) Chipset Notes Fully working without patching
P4C800 Deluxe Intel 875P / ICH5 Using latest BIOS (1021.005) with HDD and DVD on IDE-PATA. Audio works OOB, LAN with additional Card, Firewire not tested. RAID disabled. Using uphuck 10.4.9 v1.4i R2 and setting "Remove CpuPower", "Remove Thermal", "ICH8/6"). No
P4B533-V Intel 845E / ICH4 Everything seems to work smoothly, SATA, except audio (uphuck 10.4.9 v1.4i R3 with SATA support). Yes
P4P800 VM

ASUS Page

Intel 865G GMCH / ICH5 Everything seems to work smoothly, SATA, network and USB. Audio works stereo, but output jack is mic in by default!
  • To fix that (to change it back to the line out) you must modify the file '/System/Library/Extensions/AppleAC97Audio.kext/Contents/PlugIns/AppleAC97CodecAD198x.kext/Contents/Info.plist'
  1. Find the line with <string>ADS75 ADS74 ADS73 ADS72</string>
  2. Change it with <string>ADS75 ADS74 ADS73 ADS72 ADS70</string>
  3. The next step is to load the AppleAC97CodecAD198x.kext
Yes
P4P800 Intel P4 2.8GHz HT Not work (kernel panic with Uphuck 1.3 with Intel SSE2 kernel)
P4P800 Deluxe Intel P4 3.0GHz HT Everything seems to work Yes
P4P800S Intel P4 3.0GHz HT Everything seems to work. Used Uphuck 1.3 with Intel SSE2 kernel. Yes
P5GD2-X Intel 915P, P4 3.0 core solo 65nm Everything works including QE\CI with callisto 0.08 & coverg patch on DELL 2407WFP (VGA), execept system volume control, and DVI out on video card. My hardware: Saphire ATI x800 GTO 256 pci-x (flashed to x800 GT new id: 0x554b old id 0x554f ). Sound work with sudo kextload /System/Library/Extensions/AppleAC97Audio.kext/Contents/PlugIns/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/ Yes
P5LD2-VM Intel 945G, Celeron D 347 3.06 Core Image & Quartz Extreme Supported With Integrated GMA950 Display, SATA Ports & IDE Ports Work. Onboard LAN works, although Network Control Panel claims the cable is disconnected. (JAS 10.4.8 DVD Updated to 10.4.9) Audio does not work out of the box. Required HDA Patcher. Sleep does not work. System reboots and Powers down with no issues. No
. . . .

[edit] Biostar

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] ECS

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] Epox

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] FOXCONN

Hardware Name (socket type) Chipset Notes Fully working without patching
Foxconn 45CMX Socket 775 Intel 945GC Working No
. . .

[edit] Gigabyte

Hardware Name (socket type) Chipset Notes Fully working without patching
GA-945GCM-S2C 945GC Everything works great using the correct install settings on the uphuck installer. LAN, Audio, GMA950 graphics all work. I used the uphuck 10.4.9 v1.4i R3 release. Yes, with the right installer settings.

[edit] Intel

Hardware Name (socket type) Chipset Notes Fully working without patching
D945GNTL Intel® 945G Express Chipset Works: LAN (Intel Pro 10/100, IONetworkingFamily 10.4.7), USB, Audio (SigmaTel 9220, Blue = out, green = in, pink = Mic), SATA and ATA JaS 10.4.8 DVD SSE3 + JaS 10.4.9 Combo Update
D945GTPLKR Intel 945G Express Chipset, Intel GMA950 Graphic Chipset Everything works fine exept: 1) LAN works without fuzz when in Bios "boot to Network" is enabled 2) Sigmatel 9220 with no "line in" function (blue = line out, green = nothing, red = Mic); All Apple Security Updates and Application Updates till 2007-06-11 can be directly applied without further ados 10.4.9 uphuck install dvd 1.2 with: Intel SSE3 Kernel, IOATAFamily Patch, ICH7-R Driver, Azalia Audio Driver
D975XBX Rev 3.02 Intel® 975X/ ICH7R Works: LAN, USB, FireWire, Audio is working by switching to the blue pin instead of the green 1 (with the SigmaTel 9221 AppleHDA Patch), SATA and ATA133 (with the Jas 10.4.8 patched ppf1 dvd), Raid not tested. JaS 10.4.8 DVD With PPF1 Patch and JaS 10.4.9 Combo Update

[edit] Iwill

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] MSI

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] PC Chips

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

[edit] Tyan

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder
.

[edit] Processors

[edit] AMD

Model Notes Recognized as Full Work / No Patch
Opteron 175 works like a charm Opteron 175 @ 2.2 just required AMD kernel
. .

[edit] Intel

Model Notes Recognized as Full Work / No Patch
Intel Core 2 Duo E4500 Allendale 2.2GHz uphuck 10.4.9 v1.4i R3 installer used Recognized as 2.21ghz Core2Duo Yes
Intel® Core™2 Duo E6600 (2.4 GHz) JaS 10.4.8 SSE2/SSE3 + ppf1 and JaS 10.4.9 Combo Update, kernel Semthex 8.9.1 - Both cores working, 100% trouble-free Recognized as a dual core 2.4 Ghz Cpu Yes
Celeron D 325 Used JaS 10.4.8 SSE2 SSE3 reseed w/Semtex 8.8.1 + JaS 10.4.9 SSE3 patch w/Semtex 8.9.1, it didn't worked well right away (choppy sound and slower GUI) but I set the com.apple.info.plist "<key> Kernel Flags </key>" entry with "<string>fsb=133</string>" and everything went smoothly! Intel Core Solo 2.53 Ghz (right speed) Yes / See Notes
Intel® Pentium D 940+ (3.2Ghz) JaS 10.4.8 SSE3 + JaS 10.4.9 Combo Update, kernel Semthex 8.9.1 - cores working Recognized as a 4Ghz Intel Core Duo Yes
Intel® Pentium 4 (2.53Ghz and No SSE3) uphuck 10.4.9 v1.4i R3 Intel Pentium 4 2.53 Ghz Yes
Intel® Pentium 4 (1.8Ghz and No SSE3) JaS 10.4.8 SSE2 SSE3 AMD kernel 8.8.1, updated to 10.4.9 with 8.9.1 kernel Intel Core Solo 1.79Ghz (right speed) Yes
Intel® Pentium 4 530J (3.00 GHz, SSE2 and SSE3) JaS 10.4.8 SSE3 and JaS 10.4.9 Combo Update, kernel 8.9.1, 100% trouble-free 2.99GHz Intel Pentium 4 Yes
. .

[edit] Graphics Cards

Please specify if your card is AGP, PCI or PCI-E.
Also, place chip and board manufacturer in their respective column.

Note: For NVidia users, visit http://www.macvidia.org/ for updated drivers. For NVIDIA CARDS PLEASE SPECIFY IF THE CARD DOES QE/CI. Saying the macvidia drivers work but not specifying QE or CI is a bit misleading. If you are using the new kernel then download the Titan kext from http://omni.starchaser.org/titan/ to get QE/CI support

Note:These instructions may confuse noobs as they are a bit out of date. As far as i know, the MacVidia drivers do NOT support QE/CI AT ALL. You can use the kexts that come with your OSx86, or the ones from the 10.4.8 Intel update with your card. You may need to replace OpenGL.Framework too. Titan and Natit are merely enablers which make OSx86 think your VGA BIOS card is an EFI Firmware one (as on a real intel mac), and should load before the NVNVDA* kexts. An installer for Natit can be found at [1]. Check the forums for more info.

Note: For ATI users, visit http://omni.starchaser.org/ for experimental drivers.

Note: As of right now, all ATI cards with working kexts have severe slowdown issues with nForce3 chipsets. There is no fix for this, save getting editting out your card from the kext or using Quartz Debug to shut off Quartz Extreme. Edit: Just use agpgart to get no slowdowns at all on nForce3. Joblo10

[edit] PCI Express


[edit] ATi

Hardware Name,(VRAM) Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Place Holder Place Holder Place Holder
  1. Place Holder
Place Holder Place Holder Place Holder

[edit] Intel

Hardware Name,(VRAM) Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Intel 82945G 8mb Intel Use native drivers none 1024*768 without quartz extrime
. . . .

[edit] Matrox

Hardware Name,(VRAM) Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Place Holder Place Holder Place Holder
  1. Place Holder
Place Holder Place Holder Place Holder

[edit] NVidia

Hardware Name,(VRAM) Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Geforce 7800GTX 256MB ASUS Used the Natit 1.0 Installer from http://www.necnet.de/krass.man/Installers/NVidia%20(Natit)%20Installer.html Both ALL Yes/Requires NV40 thing or the Natit 1.0 or higher Installer
Geforce 6600XL 128MB Foxconn Worked rightaway Yes/Yes HiDefinition Yes
Geforce 6500 256MB XFX Used the Natit 1.0, works as 128MB Yes/Yes HiDefinition Yes/Natit 1.0 or higher
8800GTS 320MB EVGA used installer from here QE and CI work, there is some problem with full screen mode, something to do with the NF4 chipset all resolutions requires patch
. . . .

[edit] AGP


[edit] ATi

Hardware Name,(VRAM) Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Radeon X800-XT (256MB) Sapphire Works after changing the Device-ID in CallistoHAL.kext and installation of Callisto-06 No / No Any No/No
Radeon X1600 Pro (256MB) Sapphire Works out of the box on an ASUS P4P800-VM MB Yes plus Q2D capable (gives a great speed boost on iWork '06 Pages program) Any Yes
Radeon X1950 Pro (512MB) Sapphire Works on a Gigabyte 8IPE100 MK MB with fresh install and Bronya's (Dmitrik) drivers for Prionace Yes Any Yes
. . .

[edit] NVidia

Hardware Name,(VRAM) Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Geforce 6200 (128MB) XFX Works perfectly after installing Titan, no kexts editing required Yes Any Yes/No
Geforce 7300GT (256MB) PNY Works perfectly after installing mac.nub's 256MB inject on the 10.4.10 disc Yes and OpenGL Any Yes/No
. .

[edit] PCI


Hardware Name,(VRAM) Chip-Manufacturer Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Place Holder Place Holder Place Holder Place Holder
  1. Place Holder
Place Holder Place Holder Place Holder

[edit] Mobile


Hardware Name (VRAM) Chip-Manufacturer/Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Mobile 945GM Express Integrated Graphics Controller (rev 03) Intel Works Natively Yes 1280x1024 Yes - Fully works with Intel GMA950 Driver
. . . . . . . . . . . . .

[edit] Sound Cards

Hardware Name Manufacturer Notes Fully working without patching
AC97 6-channel audio codec S/PDIF out interface(ADI 1980) Realtek Must patch to get the sound on line out instead of mic in:
  • Edit the /System/Library/Extensions/AppleAC97Audio.kext/Contents/PlugIns/AppleAC97CodecAD198x.kext/Contents/info.plist
  1. Find the line with <string>ADS75 ADS74 ADS73 ADS72</string>
  2. Change it with <string>ADS75 ADS74 ADS73 ADS72 ADS71 ADS70</string>
  3. The next step is to load the AppleAC97CodecAD198x.kext
See notes
Hardware Name Manufacturer Notes Fully working without patching
M-Audio Revolution 5.1 M-Audio Does not work at all. Card not even detected. No
.
Hardware Name Manufacturer Notes Fully working without patching
USB 2.0 Soundkarte Virtual 5.1 Exterior Audio Adapter Exterior Hong Kong (eBay) Works without patching, line out and line in
  • Deaktivate your internal audio, then plug the USB Audio Adapter in your USB 2.0 Port
YES!!! OSX 10.4.9 and 10.4.10 - Super Stereo Sound!
. .

[edit] Network Cards

[edit] Wired (Ethernet)

[edit] Wireless

Hardware Name Manufacturer Notes Fully working without patching
DFE-538TX, Device ID 0x1300 D-Link, Vendor ID 0x1186 Works without problems out of the box! Yes
Realtek811B, Device ID 0x8136 Realtek, Vendor ID 0x10EC Needs Drivers [look here] and kext patching [look here] No
Interface Standard Device Manufacturer Notes Fully working without patching
PCI B/G WG311T Netgear Reconized as Airport right out of the box (What version is it?). Speeds up to 108mb/s. If not recognized try using [this method]. Yes
Mini-PCI Card 802.11 b/g 1390 WLAN (rev 01) Broadcom Corporation/Dell uphuck v2 detects this as "Built-in Ethernet" in Network Preferences. No Airport card was shown in Network Preferences even though wireless worked properly. It didn't show the signal strength but webpages were working with no ethernet cable plugged in. This was fixed in v1.3 and v1.4i and the wireless card was displayed properly as "AirPort". YES, only with uphuck 10.4.9 v1.3 and newer. v1.2 has issues.
. . . . . .

[edit] Other Expansion Hardware

Hardware Name Interface Device Manufacturer Notes Fully working without patching
Wireless Traveler SE2 USB Mouse Optical Genius 100% works Yes/Genius Driver
. . . . . .

This page was last modified on 2 July 2011, at 15:30.
This page has been accessed 230,982 times.
Powered by MediaWiki © 2013 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers