HCL 10.4.9/Portables

From OSx86
Jump to: navigation, search
Mac OS X 10.4.9
Hardware Compatibility

This is a hardware compatibility list for portable computers. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying a portable computer. Don't forget to add how you got OSx86 running on your portable x86 computer, and to use proper English. Please see the discussion page for proper instructions on how to input your system specs. Also, please contribute to the HCL 10.4.9 page, which should list a more granular view of compatibility. If your computer isn't listed, you should try it if you have a SSE2 or higher processor. Kernels are available for most configured machines

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.4.9 builds only.

Please list your computers in alphabetical order by manufacturer (Asus, Acer, Dell, HP, etc)

For how to edit the Wiki, please see this thread. Thank you!

Note: Please add whether your device supports QE, Quartz Extreme, graphics. Try playing a movie with Quicktime Player.

Contents

[edit] Acer


[edit] Acer Aspire 5610z (model 5610-2998)


  • CPU: Pentium M T2080 (1.73 Ghz Dual Core, 1MB L2 Cache)
  • MEMORY: 2 GB DDR Memory (1GB x 2)
  • LCD: 15.4" WXGA Acer Crystal Brite
  • DISPLAY: Intel Mobile 945GM Express Integrated Graphics Controller (rev 03)
  • TVOut: SVideo
  • AUDIO: Intel 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
  • ODD: Pioneer DVR-K17RS DVD Super Multi Double Layer
  • BUS Speed: 533Mhz
  • MODEM: 56K
  • Touchpad: Synaptics
  • NIC (ETHERNET): Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
  • WIFI: Broadcom Corporation Dell Wireless 1390 WLAN Mini-PCI Card (rev 01) 802.11 b/g
  • HDD: 120GB HDD ST9120822AS
  • IDE interface: Intel 82801GBM (ICH7-M) LPC Interface Bridge SATA Storage Controller IDE (rev 02)
  • USB: 4 ports (Intel 82801G (ICH7 Family) USB UHCI (rev 02)
  • CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
  • PCMCIA:
  • Bluetooth: N/A - Optional Bluetooth Module Not Bundled With System


  • OS: uphuck 10.4.9 Install DVD v1.2

MD5: uphuck_10.4.9_universal_dvd_v1.2.cdr.iso D22BF4BE7BF6D1548696252DCC032AB6 (1280x1024 works natively, audio requires [ALC883Audio.mpkg.zip patch], nic not working, WiFi incorrectly detected as ethernet card but still works (just no signal strength display), cardbus not working, modem not tested, pcmcia not tested, usb works natively, touchpad works natively except middle button and no double click on pad, Optical drive works but burning not tested, SVideo tvout not tested)

  • OS: uphuck 10.4.9 Install DVD v1.3

MD5: uphuck_10.4.9_universal_dvd_v1.3.iso 87CFB8D2FA761DD0E2BBE00AD105FA44 (1280x1024 works natively, audio requires [ALC883Audio.mpkg.zip patch], nic not working, WiFi works natively, cardbus not working, modem not tested, pcmcia not tested, usb works natively, touchpad works natively except middle button and no double click on pad, Optical drive works but burning not tested, SVideo tvout not tested)

  • OS: uphuck 10.4.9 Install DVD v1.4 intel only R2

MD5: uphuck_10.4.9_v1.4i_r2.iso.zip 9282CF7C406537AB783DDA6681BE0347 (1280x1024 works natively, audio requires [ALC883Audio.mpkg.zip patch], nic not working, WiFi works natively, cardbus not working, modem not tested, pcmcia not tested, usb works natively, touchpad works natively except middle button and no double click on pad, Optical drive works but burning not tested, SVideo tvout not tested)

  • OS: uphuck 10.4.9 Install DVD v1.4 intel only R3

MD5: uphuck_10.4.9_v1.4i_r3.iso 4bb1bc7335773536445a0c7025d475cb (1280x1024 works natively, audio requires [ALC883Audio.mpkg.zip patch], nic works with included IONetworkingfamily patch from 10.4.8, WiFi works natively, cardbus not working, modem not tested, pcmcia not tested, usb works natively, touchpad works natively except middle button and no double click on pad, Optical drive works but burning not tested, SVideo tvout not tested)

  • Notes: OS wouldn't boot from extended partition. Had to install to a Primary Partition. Used Grub for multi boot with Ubuntu & Vista (bundled). After 15 minutes OSX goes into sleep mode and doesn't come out of sleep mode. Had to disable sleep mode in System Preferences. . . . .

[edit] Aspire 5101 ANWLMi AMD Turion 64 MK36

  • OS: Uphuck 1.4a, 10.4.9 AMD (size: about 1Gb)
  • CPU: AMD Turion 64 2.0 Ghz
  • Graphic Card: ATI MOBILITY x1100 128-256 MB, 3D acceleration QE /CI not working; 1280x800 resolution only with x200m drivers (http://forum.insanelymac.com/index.php?showtopic=38842&hl=x200m)
  • Audio: Realtek, works good with ALC883 Audio Driver Package (http://forum.insanelymac.com/index.php?showtopic=36520)
  • Keyboard: works
  • Touchpad: Synaptics TouchPad, it works but not stable, sometimes it crashes and makes the touchpad can't use as well, using keyboard (it appears like a system crash, but effettively it isn't)
  • Toshibas CD/DVD Writer: Works fine, a Data DVD succefully burned
  • PCMCIA:ENE CB1410 Cardbus Controller (unknown)
  • USB: works
  • Ethernet: Realtek, works with patch for IO network cards
  • Wireless: Altheros Wireless working with drivers for wireless adapter and the network patch
  • Analogic modem: AC'97 Modem, not tested
  • Hot Key Launch Manager: not tested (and not supported by mac)
  • 5in1 SD/MMC Soket: Not working (and not supported by mac)
  • Webcam: ACER OrbiCam (bison) not working . . .

[edit] Aspire 3624 WXCi Intel Celeron M

  • OS: Uphuck 1.3, 10.4.9 Intel (Size: about 4.6 GB)
  • CPU: Intel Celeron M 1.6 GHz
  • Graphics Card: Intel GMA900 QE / CI not working; Full resoloution with GMA900 Drivers; Stuck to Desktop Monitor without VGA Port dongle or paper clips ("pins").
  • Audio: Realtek AC97 Audio Works
  • Keyboard: Works
  • TouchPad: Synaptics TouchPad, works natively
  • CD Writer / DVD-ROM: CD Writer works natively. DVD plays with "frozen frames" or sound and no video
  • PCMCIA: (Unknown Status)
  • USB: Works
  • Ethernet: Realtek 8139 works natively
  • Wireless: Atheros 5005G Working with IO80211Family.kext from 10.4.5 ( http://forum.insanelymac.com/index.php?showtopic=33089# )
  • Analog Modem: AC'97 Modem, Not Tested
  • Hot Key Launcher Buttons: Not Supported
  • Standby: (Doesn't Work)

[edit] Asus

[edit] Asus R1F-

Working from 10.4.9 uphuck DVD. Wifi won't work (3945, watch the thread). Onboard ethernet not working. Sound only working via speakers. Bluetooth not functioning.

Video works fine from the box. Digitizer and tablet functions working. Basically, a nice working laptop without the frills. I use a USB wifi card (Linksys WUSB54). I have yet to have an issue with any piece of software.


[edit] Dell


[edit] Dell Inspiron 1525


  • "Intel core 2 duo t5250"
  • "Display" Intel GM965 is working, however, you have to close lid for external to work. I haven't yet tinkered with this yet.
  • "Audio" Sigmatel 9205 (used applehdapatcher v 1.16 and sigmatel_9228_codecdump.txt then replaced applehda.kext then repaired disk permissions.
  • "USB" working out of box
  • "Webcam" working out of box
  • "Media card readers" Untested
  • "Wireless" working out of box
  • "Ethernet" working out of box
  • "Modem" Untested
  • This is pretty much as close as you get to a "REAL MAC". My suggestion just go and buy you one. You know you you want one.

.

[edit] Dell Inspiron 1100


  • "Intel Celeron 2.4ghz"
  • "Audio" working
  • "USB" working
  • "Wireless" Dell Wireless 1350 working
  • "Ethernet" working
  • "Modem" Untested
  • Used the latest xxx10.4.11 disk. .

[edit] HP

HP 530 Installed successfully and everything works perfectly but the wireless card.

For the installation to boot, the dual core had to be disabled from the BIOS, but you can re-enable it after the install.

Tested and working: Graphics card (Resolution 1280x800,Wide) Ethernet card (connected to the Internet) USB (External USB Hdd) DVD-R (DVDs etc)

The above worked after the installation without any tweaking.

Still working on the wireless.

PS: System boots in 12 seconds!

HP Pavilion dv6000 - dv6426us

Installed properly with everything functioning except the wireless (Intel pw3945) and media card reader. Setup normally ran hot (up to 70C), but with the install option "remove thermal kexts" and using SpeedStep to limit each core down to 800Mhz, it runs at a cool and comfy 54C-52-C.

[edit] Sony

[edit] Sony VAIO BX660P

Vaio BX660P works well.

Issues: For Darwin Bootloader to be recognized, needed to partition drive into 2 parts, and write bootloader to MBR.

Sound works on startup

Graphics somewhat work, couldnt get drivers for ATI mobility 1600 to work

Wifi doesnt work

Bluetooth works

Webcam doesn't work . .

[edit] Sony VAIO VGN-140G

Vaio VGN-140G

Installed using VMware in XP.

Boots using Acronos OS Selector

Display is GMA 950 works

DVD-R worked but I believe Toast Burned out the motor burning while burning a CD at 1x (replaced with Apple Super Drive from ebay ($40))

Wifi dosent' work (Intel Pro) replaced with Dell Wifi Mini-express card ($10) (listed in this HAL) now seen as airport card

Belkin 7050 V4 also works for wifi, though not seen as an airport card.

Ethernet Works after patching.

USB works.

External Display port Works (VGA Out).

Will not wake from sleep mode (turn off sleep mode to avoid this).

After Modifications and Patches ($50 worth) works 99% . . . . . .

[edit] Sony VAIO PCG-GRT240G


  • CPU: Intel® Pentium® 4 processor 2.66GHz (8kB internal data cache, 512kB L2 onboard cache)
  • MEMORY: 1024 MB DDR SDRAM (2 x 512MB)
  • LCD: 15.0”�XGA (1024x768) with XBRITE™�technology
  • VIDEO: NVIDIA® GeForce4™ 420 Go 32MB video DDR SGRAM
  • AUDIO: Sony SiS7012 Audio Codec
  • ODD: SONY DVD RW DW-U50A (ATAPI33, DVD+-RW, CD-RW, 8MB cache)
  • BUS Speed: 533Mhz
  • MODEM: 56K
  • Touchpad: Alps
  • NIC (ETHERNET): SiS 900-based PCI Fast Ethernet Adapter
  • WIFI: LAN-Express AS IEEE 802.11 miniPCI Adapter (based on Atheros AR5212/5213)
  • HDD: WDC WD2500BEVE-00WZT0 250GB (ATA100, 2.5", 5400rpm, 8MB Cache) : 233GB
  Partition 1 - XP_RECOVERY : 5GB (Primary, NTFS, Hidden)
  Partition 2 - XP_BOOT (C:) : 16GB (Primary, NTFS, Active)
  Partition 3 - OSX86_BOOT (/) : 24GB (Primary, HFS+)
  Partition 4 - N/A : 188GB (Extended)
  Partition 5 - XP_DATA (D:) : 32GB (Logical, NTFS)
  Partition 6 - SHARED_FS (F:) : 132GB (Logical, FAT32)
  Partition 7 - LINUX_BOOT (/) : 20GB (Logical, EXT3)  
  Partition 8 - LINUX_SWAP : 4GB (Logical, swap) 
  • USB: Sony SiS5597/8 Universal Serial Bus Controller (x3)
  • CardBus bridge: Ricoh RL5c476 CardBus Controller
  • PCMCIA: Ricoh RL5c476 CardBus Controller
  • Bluetooth: N/A
  • FireWire: Sony RL5c552 IEEE-1394 Controller
  • OS: uphuck 10.4.9 Install DVD v1.4 intel only R3

LCD works natively at 1024x768 w/o GeForce and NVidia kexts [1]; speakers plus their menu bar Volume icon work with SiS 7012 driver [2], mic / headphones untested; wired NIC unknown / unrecognized; WiFi plus its menu bar AirPort status icon work natively; CardBus untested; modem untested; PCMCIA untested; USB works natively (at least with flash drive); touchpad works natively; optical drive works; FireWire untested; Memory Stick PRO slot untested; power management plus menu bar Power icon work.

[1] Remove / relocate GeForce*.kext and NVDA*.kext in /System/Library/Extensions with single-user or DVD boot after initial install. [2] See http://forum.insanelymac.com/index.php?showtopic=29051&st=0&p=733192&#entry733192 for more information.

Notes: Power-on start-up boots WinXP partition with chained boot loader allowing selection of XP (Windows bootloader), OSx86 (Darwin), or Ubuntu (Grub) platform. Each system provides similar selectability prior to actual O/S load. For long-running processes or over long idle periods, system seems to freeze or hang (i.e. clock stops updating), yet mouse movement or keyboard action unfreezes display and restores normal operation (still seeking fix). Fan runs high constantly (still seeking fix). OSx86 shows HD disk capacity as 128GB and appears to see only those partitions within the first 128GB of disk space (still seeking fix). CD/DVD burning functional (i.e. with iTunes and Disk Utility), yet use of iDVD or iMovie (the original impetus of this particular effort) for such appears to overwhelm system processor and overtax user patience.


.

[edit] Rock

[edit] Support Prescott

  • OS: Uphuck 1.3i r3, 10.4.9 (size: about 1.3Gb)
  • CPU: Intel Pentium 4 3.40Ghz
  • Graphics Card: ATI Mobility Radeon 9600 256MB - QE/CI not working and resolution can't be changed.
  • Audio: No problems at all.
  • Keyboard: Fine!
  • Touchpad: Fine!
  • DVD-R: Fine!
  • USB: Fine!
  • Ethernet: Not working.
  • Wireless: Intel 2200BG - Had to install iwidarwin.
  • Card Readers: Untested.
  • Webcam: Not working. . . . . . . . . . . . . . . .

== . . . . . .


This page was last modified on 2 July 2011, at 15:52.
This page has been accessed 188,585 times.
Powered by MediaWiki © 2013 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers