HCL 10.5.0/Desktops

From OSx86
Jump to: navigation, search
OS X 10.5.0
Hardware Compatibility

This is a hardware compatibility list ONLY for OEM desktop computers. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying a desktop. Don't forget to add how you got OSx86 running on your x86 desktop computer, and to use proper English. Please see the discussion page for proper instructions on how to input your system specs. Also, please contribute to the HCL 10.5.0 page, which should list a more granular view of compatibility. If your computer isn't listed, you should try it if you have a SSE2 or higher processor. Use vanilla kernel if it is supported.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.5.0 builds only.

Please list your computers in alphabetical order by manufacturer (Asus, Acer, Dell, HP, etc)

For how to edit the Wiki, please see this thread. Thank you!

Note: Please add whether your device supports QE, Quartz Extreme, graphics. Try playing a movie with Quicktime Player.

Contents

[edit] ASUS

[edit] V3-P5945G (Barebones PC)

  • FireWire and USB work
  • Integrated GMA950 graphics working
  • SATA and PATA working
  • Audio AL883 needs some kext

[edit] Compaq/HP

[edit] Presario SR5013WM

Everything working out of the box except networking (easy fix) .

[edit] HP d530 SFF

Specs: 2.8 GHz Pentium 4 Northwood | 1 GB Ram | nVidia 6200A(GP)

Method: Just get the ToH RC2 DVD and the install works out of the box except for a few things.

Quirks: The Apple System Profiler crashes for some reason and the Broadcom Patch from the d530 10.4.8 HCL needs to be applied for ethernet. The graphics card is working with the NVinject Leopard only build. (FULL QE/CI) .

[edit] Dell

[edit] Latitude D820

Everything works:

  • Intel Core 2 Duo T7200 2 Ghz
  • 4 GB Ram (Shows 3.25 GB)
  • 100 GB SATA HDD
  • Sigmatel HD Audio 9200
  • Dell TrueMobile 1490 Wireless
  • Broadcom 57XX (%h 1600) Product ID
  • NVidia Quadro 110

[edit] Precision 490

  • All working perfectly
  • Intel 1000MT only working in PCI-X slot
  • DE500B network only in PCI-X
  • USB, Audio, etc. works

[edit] Precision 670

  • Impressive compatibility
  • Xeon 2x 3.2GHz
  • 4 GB 400MHz DDR
  • 150 GB USB 2.0 HDD
  • Linksys PCI Wireless-G
  • Soundblaster Audigy
  • ATI 256 FireGL

[edit] Dimension 3000

Used ToH 10.5 RC2 (10.5.0)

  • 2.8GHz P4 (Prescott Core) / 768MB RAM
  • Onboard Audio works (Ch. 3/6 on Audio MIDI Setup)
  • Onboard LAN supported (Pro 10/100 VE); no mods necessary
  • USB 2.0 Works, but does NOT bring device out of sleep
  • Onboard IGFX2 works, but not QE/CI supported
  • Used ATI X1300 PCI card (works with QE/CI/Rotation/Refresh/Resolution using NatitX1300.kext); shows as PCIE 1X card in System Profiler
  • Onboard modem NOT supported
  • Must either use patch to make volume bootable OR install on top of Tiger.
  • Dual-booting with Vista

[edit] Dimension 3100/E310

Used dd method with BrazilMac

  • Onboard audio works with hda patcher Codec: SigmaTel 9200 HDAudio (Right click the link, click save link as SigmaTel.txt)
  • No QE/CI with graphics, used NVidia PCI FX5500
  • Onboard ethernet works. If there are any issues reinstall the ethernet Here.

Contact Millentree10 on InsanelyMac if you have problems.

[edit] Dimension 4550

ToH 10.5.0

  • Everythings works onboard sound LAN etc.
  • 2GHZ CPU 693MB RAM
  • GeForce FX5200 or ATI Rage 128 .

[edit] Dimension 4600

  • IDE working
  • SATA and audio untested
  • LAN works (only after you manually reload kexts at boot with -f)
  • Dual monitor support with stock FX5200 works ; can't use DVI -> VGA adapter on second connector

[edit] Dimension E520

[edit] Dimension E510 (aka 5150)

  • Sigmatel HD 9220 audio Needs 9220 codec patch using AppleHDAPatcher v1.16 +
  • Integrated GMA945 working with QE/CI

More information is required for this computer.

[edit] Medion

[edit] M3 Composer 5200

  • Intel D915GUXLKR
  • Reatek ALC860 HD Audio
  • 60GB SATA 2.5" 5400 RPM
  • Marvell Yukon 8050 10/100/1000 Gigabit Ethernet
  • nVidia GeForce 7950GT 570M Extreme 512MB (CI/QE/Full Resolution/Full Refresh) with NVinject and kext edits
  • DVD+-RW (No burning support)
  • USB Card Reader and Front panel work.

I have everything working except for input on audio, i'm still working on it. For the nvidia card you need to edit the NVDAResman.kext, NVDAHal40.kext, and GeForce.kext to get it working. It does work 100% though, full hardware acceleration!

[edit] Shuttle

[edit] SD39P2 (Barebones PC)

  • BCM5789 - Used the driver patched for 10.4 (notably no longer needs to be loaded from the RC)
  • Audio requires patching
  • EHCI requires patching
  • FireWire seems to be working ; not confirmed

Post with drivers and links: http://www.insanelymac.com/lofiversion/index.php/t51891.html)

Users Notes:

Used the ToH RC2 install, had to do the boot patch/process (patch, unmount, patch). Included ToH kernel didn't like my chipset+Quad CPU so used bootflags "cpus=1 -legacy -f".. once in OS X installed EFI and vanilla 9.0.0 kernel (+dsmos.kext).. kernel booted fine (no flags) and detected all cores. Updated to 10.5.1 w/o issue. .

[edit] SD37P2 (Barebones PC)

  • Ethernet works with AppleBCM5751Ethernet.kext from Tiger
  • Sound works with patch from Tiger

This page was last modified on 2 July 2011, at 18:47.
This page has been accessed 176,140 times.
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers