HCL 10.5.0/Portables

From OSx86
Jump to: navigation, search
Mac OS X 10.5.0
Hardware Compatibility

This is a hardware compatibility list for portable computers. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying a portable computer. Don't forget to add how you got OSx86 running on your portable x86 computer, and to use proper English. Please see the discussion page for proper instructions on how to input your system specs. Also, please contribute to the HCL 10.5.0 page, which should list a more granular view of compatibility. If your computer isn't listed, you should try it if you have a SSE2 or higher processor. Use vanilla kernel if it is supported.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.5.0 builds only.

Please list your computers in alphabetical order by manufacturer (Asus, Acer, Dell, HP, etc)

For how to edit the Wiki, please see this thread. Thank you!

Note: Please add whether your device supports QE, Quartz Extreme, graphics. Try playing a movie with Quicktime Player.

Contents

[edit] Acer

[edit] Acer Aspire 5610z-2966

All works except 5 in 1 card reader

Everything working with EFI and Vanilla kernel except for Power Managemen.

[edit] Acer Extensa 5620z

Intel Pentium T2310 1,46 GHz

work with Iatkos 1.5.1 EFI bootloader except 5 in 1 card reader touchpad work without scroll- middle button

[edit] Acer Aspire 9410-2028

Everything works with ToH Leopard except 5 in 1 card reader, WiFi recognized as AirPort .

EFI 5.1 working .

[edit] Acer Aspire 5570z

  • BrazilMac DVD installs fine ; endless loop of welcome vide, have to upgrade from Uphuck
  • No WLAN, Ethernet, PCMCIA
  • GMA950 graphics fully working

[edit] Acer Aspire 3623NWXMi

  • Not working at all
  • Hangs before starting installer GUI (BrazilMac + Patched SSE2 kernel) .

[edit] Acer Travelmate C202TMi

  • NVIDIA GeForce Go 6200TC - QE & CI Working on the external panel with NVinject Go and modified kext's
  • ALC260 Audio doesn't work
  • IntelĀ® PRO/Wireless 2945ABG not working
  • Broadcom NetXtreme BCM5788 Gigabit Ethernet - Works with modified kext, MAC 00:00:00:00:00
  • Texas Instruments PCIxx21/x515 Cardbus Controller not working
  • Texas Instruments OHCI Compliant IEEE 1394 Host Controller working
  • Texas Instruments PCIxx21 Integrated FlashMedia Controller not working
  • LCD screen working perfectly .

[edit] Acer Travelmate 2410

(attaching external monitor prevent hangs to blue screen at boot[DVD, Mac OS X])

  • Install Method: ToH 10.5 (Straight from DVD, has to use the DVD to boot also)
  • Intel 910GML SSE2 Only Chipset Working
  • Intel Celeron M 1.60Ghz working
  • ATA/100 HDD working
  • Intel GMA900 VGA 64mb working (hangs at blue screen after boot, keep trying & it works :)
  • Pioneer DVD-RW Dual Layer working
  • Trackpad working fully
  • Ethernet working
  • WiFi not working
  • All straight from the box :)

[edit] Acer Aspire 9423

  • Install method: ToH RC2 + EFI v5 + 10.5.1 Update
  • Audio working with AlC883 patch
  • GeForce 7300 working with NVinject
  • Ethernet working out of the box
  • Intel 3945 Wireless and PCMCIA not working
  • USB works only if device is plugged in before boot
  • Keyboard and Touchpad work but no scroll or middle button
  • Integrated Webcam and Card Reader not working

[edit] ASUS

[edit] Z71V

  • Marvell GB Ethernet supported with skge.kext
  • GeForce Go 6600 working with NVinject and standard nVidia kexts
  • External VGA not tested
  • Sound Working with Azalia - use id: 0x26688086 in Info.plist - note this does not show up in System Profiler and was hard to get to work
  • Intel wireless and FireWire not tested

Used Leopard TOH installer. To boot without the DVD, use the script.sh command off the DVD. Overall the system is snappy enough for surfing and general use. Does not seem to recover nicely if the monitor is allowed to sleep, so leave that disabled.

[edit] F3JC

[edit] F8SG

  • Touchpad, USB works well
  • CD/DVD working with burning after installing Patchburn
  • nVidia GeForce Go 9300MG working with QE/CI (NVKush nVidia kexts )
  • Bluetooth 2.0 fully working
  • Sound ALC660 works well without extern speakers.
  • Realtek 8618 works well
  • Wireless Intel 4965ABG does not work (iwi4965[1] driver does not work)
  • Integrated camera (D-Max) works well
  • Card Reader not tested yet
  • ExpressCard not tested yet
  • Firewell not tested yet
  • Battery works not tested

-Used Leopard [iAtKos], [IPC] or [Jas] installer image.

-Used [Make Bootable HD for Lerpard] image to format partition with Virtual Machine.

-To boot with the DVD, use parameters "cpus=1 -v" to install

-[IPC] and [Jas] cannot startup with 2 Core

-Cannot recover if the monitor sleep. .

[edit] F6E

  • Install 10.5.6 Retail Update 10.5.8
  • CPU Core 2 work (by DSDT Pather)
  • GMA X3100 work (QE/CI support)
  • ALC 660 work (by iDeneb v1.4)
  • Card Reader /Webcam work
  • Bulebooth 2.0 work
  • RTK8168 work
  • Wireless 3945ABG no work
  • TouchPad work (by VoodooPS2)
  • PowerOHR work (by VoodooPower)
  • Battery work (by VoodooBattery)
  • Sleep no work
  • CPUPowerManagement work (by GenericCPUPowerManagement)

-All Knowledge From http://bbs.pcbeta.com/forum-136-1.html

[edit] Compaq

[edit] c255us

Installed using flat image, everything works except:

  • Audio Line In/Line Out Jacks
  • Broadcom BCM4311
  • Battery meter now showing up

[edit] Presario V4000 (V4310NR)

  • This may or should work on all other V4000's with intel graphics 9xx.
  • Installing iDeneb Light 10.5.8. Have been able to install Snow leopard but cannot get USB to work.
  • Installing iDeneb Light DVD onto the Machine. There will be selected kexts that iDeneb will already have selected, leave
  • those selected.
  • iDneb Light following Kexts on installation.
  • ICHx Fix, Jmicron ATA, IOPCMCIA, System Management (all).
  • Ethernet Apple BCM 440x, IOUSB, IOSDHC, Voodoo 950 Kernel.
  • Voodoo PS2 Controller, Seatbelt, IO80211_tiger.
  • Go to www.kexts.com, you need to register in order to download. Then download kext utility, hardware info, and the newest seatbelt
  • kexts. Use Kext utility to install Seatbelt and any other kexts.
  • Wireless IWI2200 not working, tried all current IWI2200 kext from IWI Project. There is a wireless card that will work Broadcom
  • 4321AG or Broadcom 4313.
  • I then removed the hard drive and connected it to another machine running OS X and installed chameleon RC5 747
  • and then install the Graphics from www.kexts.com follow this link
  • http://www.kexts.com/view/102-intel_dell_gx280_gma_915_10.5.8_tested.html this will enable multiple resolutions.
  • (Screen savers and iLife 09 (iPhoto) will work without issues).
  • Put the hard drive back into the machine and boot up.
  • If you get a Kernel Panic force the machine off then turn back on and when chameleon bootloader appears type -x and boot up
  • once you log in then run disk utility and repair permissions. Reboot and there should not be any more issues.
  • Have tried to get the on board SD card reader to work but to no avail. Used the Hardware info app and shows
  • PCIxx21 Integrated FlashMedia Controller. Cannot seem to get it to work. Tried the IOPCI kext but no work.
  • Machine runs best with 1.5 to 2 GB ram.
  • Bios should be updated to verF21.

[edit] Presario C712NR

  • Both CPU cores working
  • Intel GMAX3100 fully working with Paulicat's natit.kext for X3100
  • Wireless working out of the box
  • DVD Burner working fully with burning
  • Audio works with AppleAzaliaAudio.kext but no headphones or mic working
  • USB 2.0 fully working
  • Requires ACPIPS2Nub.kext for PS/2 and Power Management
  • Wireless on/off button works but you can't turn it back on with the button (have to turn on AirPort in System Preferences)
  • Volume Up/Down/Mute, Brightness control, and Home keys (PgUp and PgDown too) work on keyboard ; no other special keys working
  • Sleep works but will not wake after sleep
  • Power Management doesn't fully work (sleep sometimes crashes, no battery meter, no SpeedStep)
  • Guide here
  • Basic Method:

Format/unmount target drive -> Run script from "I_am me" with target drives changed-> install brazilmac leopard DVD-> Del: AppleIntelCPUPowerManagement.kext & AppleIntelIntegratedFramebuffer.kext (messes with x3100) & AppleEFIRuntime.kext (can freeze you at spinning apple logo)-> copy dsmos.kext (newest one not from PC-EFI 5.1), & ACPIPS2Nub.kext, Natit.kext over and chmod/chown them all and delete extensions.mkext and finally repair permissions.

  • 10.5.1 Update works

[edit] Presario V6409TU

  • Installed using Kaliway
  • Everything works out of box including wireless
  • Battery meter doesn't show
  • Volume up down / brightness control works.
  • Expose / Spaces works

[edit] Dell

[edit] Inspiron 9300

Leopard works ; Some programs don't work (iCal, etc.) ; LAN doesn't work, WLAN works .

[edit] Inspiron E1505

  • Install method: ToH
  • No sound, no working patch
  • Networking and built-in modem don't work
  • AirPort/Dell Wireless 1390/1490 working
  • Ricoh Card Reader not working

[edit] XPS M1330

Notes:

  • GeForce 8400GS, VESA only works at 1280x800
  • Integrated Broadcom 59xx not working
  • Intel 4935abg not working
  • Integrated Sigmatel audio only working through headphone jack
  • All else works

[edit] Latitude D620

  • Processor only one core working
  • Sigmatel audio works with AppleHDAPatcher (Version 1.16) and Sigmatel9200.txt
  • GMA950 Graphics not working, various issues

Users Note on GMA950:

The graphics card works fine, but has a BIG problem. The mouse trailing effect... When moving the mouse over a text-field the cursor will stuck there. The problem seems to be related to "AppleIntelIntegratedFramebuffer.kext" in combination with the GMA950 driver...

When using the GMA950 patch from the JaS 10.4.8 DVD the problem is fixed, but CI/QE not working anymore... So this is no good solution.

Waiting for a fix... .

  • Broadcomm NetExtreme works with hex edit but causes a kernel panic after a few minutes of browsing the web
  • Dell TrueMobile 1490 after a quick fix: .

Users Note on TrueMobile:

The wireless card works fine, but is configured with the wrong id (en0). So edit the NetworkInterfaces.plist and look for "en0" and replace it with "en1". Also look for the line below of the entry "IOInterfaceUnit" and replace "0" with "1".

That's all... Now the card has the correct ID to get the "normal" card (see Broadcomm 57xx) working as en0...

[edit] Gateway

[edit] MT6821

  • Using patched AppleAHCIPlatform.kext for battery meter and PS/2 support
  • Onboard wireless not working

System works fully with EFI 5.1 and Vanilla kexts (running 10.5.1). Sleep and wake working .

[edit] NX570XL

  • Brazilmac with patched AppleHDA.kext for Sigmatel 9205 sound, IOPCCardFamily.kext for PCMCIA slot, Dynex WLAN card in PCMCIA slot (internal Intel ABGN card not working), PowerManagement.bundle for power meter, and ATI X1400 working with QE/CI enabled at 1400x1050 (stretched) resolution with minor tearing. Have not tried EFI. .

[edit] HP (Hewlett-Packard)

Hp hdx 18t-1200 sound wont work network wont work install all chameleon bootloaders NVIDIA geforce whatever number of mb works that you have thats it havent tried 10.5.1 update used ipc distro others didnt work

[edit] dv5240ea

[edit] Kalyway 10.5.1

  • Audio works
  • nVidia GeForce Go 7400 works
  • DVD Drive works
  • USB Bus
  • HP IR Remote Control works
  • Intel Wireless PROSet/Wireless 3945a/b/g not working
  • Mic in/out and SPDIF not working
  • Recovery from sleep not working
  • Card Reader not working

[edit] Leo4All v2

  • Audio does not work
  • nVidia GeForce Go 7400 works
  • DVD Drive works
  • USB Bus
  • HP IR Remote Control works
  • Intel Wireless PROSet/Wireless 3945a/b/g not working
  • Mic in/out and SPDIF not working
  • Recovery from sleep not working
  • Card Reader not working

[edit] Leo4All v3

does not install - gives an "Waiting for root device" error

[edit] dv6447om

  • Audio works (built in speakers only) with this patch
  • GMA950 Graphics working perfectly, QE/CI, Rotation, etc.
  • Integrated Webcam working perfectly out of the box
  • USB and FireWire working (FireWire not tested, but is detected)
  • DVD drive works, burning not tested but System Profiler says its supported
  • HP IR Remote works fine with FrontRow
  • Dual Displays work
  • Intel Wireless PROSet/Wireless 3945a/b/g not working
  • Mic in/out and SPDIF not working
  • Recovery from sleep not working
  • Card Reader not working

Installed with ToH RC2 .

[edit] dv2113

  • Install method: Leopard flat image
  • Using Leopard flat skip first 32k:

dd if=leopard-flat-img of=/dev/sda6 bs=64 skip=32768

  • Booted using chain0 from Tiger (placed on Linux ext partition) and GRUB:

root (hd0,1)/boot/chain0 chainloader (hd0,5)+1

  • Everything works out of the box except for Intel 3945 Wireless and Card Reader which don't work .


[edit] G5050eo

  • Install Method: Retail Disc with BrazilMac (oui) patch
  • Celeron 520 @ 1.6ghz

  • GMA950 works straight off

  • HDAudio works - output only (connexant audio codec)

  • Realtek RTL-8139 works straight off

  • Broadcom bcm4311 doesn't work due to "soft" switch - (14e4:4311)

No further testing done so the issues with sound & wlan may be fixable - very easy install.

[edit] IBM/Lenovo

[edit] X60 Series

Everything works out of the box, except the Atheros WLAN. Atheros WLAN worked in 10.4.10, so I copieed the IO802Family.kext from the backup. Airport card is in the system (about this MAC-More info), but cannot switch on.

No ACPI. In battery mode I cannot see the battery percentage left... I think the processors runs on full speed (and no power management at all). I had to run the machine all night, on morning it was very hot. In windows it was always cold...

Working with EFI + Vanilla kernel

[edit] MSI

[edit] M660

Many problems, tried many methods and no success:

  • Wireless not recognized
  • DVD not recognized
  • Audio not recognized


[edit] Olivetti

[edit] Olibook 610-430 (ECS/Uniwill Barebone)

  • Install Method: JaS 10.4.8 + ToH 10.5.0 RC2 (otherwise ToH release loops forever at welcome screen. Failed to upgrade with Kalyway 10.5.2 Combo Update, probably my mistake though)
  • Processor: Intel Celeron M 430 (1.73ghz) Core Solo Yonah
  • Chipset: Intel 945GM1940GML
  • Video: Intel GMA 945 - Works with QE/CI enabled, can change resolutions for the internal and external monitor. Minor mouse tearing / artifacts in Firefox 3 and MS Office. Quake 3 works great. S-Video TV Out doesn't work, stays at blue screen when booting.
  • Audio: Realtek ALC883 - Works with headphones or external speakers, mic-in not tested. There's a way to enable internal speakers with a patch but then line-out doesn't work. SPDIF Not tested.
  • LAN: Realtek 8139 - Works OK.
  • Wi-Fi: Intel PRO/Wireless 3945ABG - NOT WORKING
  • Touch pad: Works OK.
  • USB ports: All working. Tested with Logitech MX518, A4Tech Spanish Keyboard (all keys detected) and Sony Ericsson Z550a.
  • Power Management: Sleep not working.
  • SATA: Works OK.

[edit] Sony

[edit] VAIO VGN-SZ73B

  • Only boots in legacy mode (one core working)
  • Sigmatel audio needs patching
  • Integrated GMA950 graphics all working
  • DVD drive works/burning not tested
  • Wireless not tested

[edit] Toshiba

[edit] Satellite A105-S4134

Working with EFI + Vanilla kernel. All hardware working out of the box except for:

  • Modem
  • Intel pro wireless 3945
  • Card Reader
  • Bult-in Microphone
  • Fingerprint reader (UPEK is about to release a Mac driver that may make the reader work)
  • AppleIntelIntegratedFrameBuffer.kext had to be patched for proper display on the panel

EFI 5.1 + Vanilla kernel working

[edit] Satellite A135-S4487

  • Install method: Leopard flat image
  • Everything works except for Intel 3495ABG wireless .

mk

[edit] Satellite A100-813

  • Install method: ToH RC2
  • Audio working with AppleHDAPatcher by Taruga
  • GMA950 graphics working perfectly
  • Bluetooth and USB working out of the box
  • Integrated LAN and DVD-RW working perfectly
  • FireWire not tested but detected at 400Mbps
  • Intel 3945 Wireless, Wake from Sleep, and Card Reader not working .

[edit] Satellite P100-ST1072

  • Install method: ToH
  • Conexant HD Audio work with AppleAzaliaAudio.kext
  • Intel Pro/100 LAN working with patching
  • GeForce Go 7600 working with NVinjectGo.kext
  • Fingerprint scanner is identified as "Biometric Coprocessor"
  • Intel 3945 Wireless not working
  • Keyboard Media keys don't work
  • USB not working. Verbose boot says it can't take control of USB from BIOS.

[edit] Satellite P100 191 PSPA6E (P100 in Europe = P105 in US)

  • what do you need:

BootCD Generic.iso Leo DVD Retail

  • Bios:

Bit Enable Lan Disable cd first boot

  • Install:

select lang goto harddisk and delet partition then install after install automatic reboot now u need to plug in external mouse and keyboard change to generic cd enter 80 for hhd enter leo will start up install lan network install kext IOPCMCIAFamily.Leopard.zip from http://chunnan.blogspot.com/ restart activate network in bios install USB (did not work well for me become to hot! ) install kext AppleUSBController.kext.zip from above restart usb should work now with devices pluged in after bootup install USB (Snow Leo) install kext IOUSB.Family.kext http://www.insanelymac.com/forum/index.php...st&id=81340 restart

install trackpad and keyboard install kext VoodooPS2Controller.kext with trackpad scrolling support restart

install bootloader download chameleon DFE for dard disk following this tutorial http://menoob.com/hackintosh/hackintosh-install-a-mac-leopard-os-x-retail-dvd-on-a-pc/

deleted the AppleCPUthermo.kext because of heat

hang up with kalyway hang up with tony x86 iboot

Usb devices work ONLY when pluged before system start.

[edit] Winbook

[edit] M 8640

  • ToH works after applying bootload script
  • Runs very slowly
  • Built in Audio, Wireless, Ethernet, and PCMCIA don't work
  • Video sort of working
  • Keyboard and trackpad works
  • USB, DVD, and ACPI seem to be working

This page was last modified on 22 December 2012, at 14:22.
This page has been accessed 379,662 times.
Powered by MediaWiki © 2013 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers