HCL 10.5.4/Desktops

From OSx86
Jump to: navigation, search
OS X 10.5.4
Hardware Compatibility

This is a hardware compatibility list ONLY for OEM desktop computers. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying a desktop. Don't forget to add how you got OSx86 running on your x86 desktop computer, and to use proper English. Please see the discussion page for proper instructions on how to input your system specs. Also, please contribute to the HCL 10.5.4 page, which should list a more granular view of compatibility. If your computer isn't listed, you should try it if you have a SSE2 or higher processor. Use vanilla kernel if it is supported.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.5.4 builds only.

Please list your computers in alphabetical order by manufacturer (Asus, Acer, Dell, HP, etc)

For how to edit the Wiki, please see this thread. Thank you!

Note: Please add whether your device supports QE, Quartz Extreme, graphics. Try playing a movie with Quicktime Player.

Contents

[edit] Dell Dimension e520

iAtkos v4i, used ToH kernel 9.2 (vanilla did not work on Pentium D model, Core 2 Duo model untested)
Selected both S-ATA patch and nForce SATA, this was the only way the machine would boot (still waiting for root device)
nVidia GeForce 7300LE working well with NVInject 256, but no Quartz Extreme.
Onboard network does not work, Netgear GA311 working out of box.
Onboard sound untested (STAC 9227, unable to test due to taruga's site being down), using Griffin iMic sound card, works out of box.
All USB ports working perfectly, time machine working, sleep mode working without a hitch, all in all much better than Kalyway 10.5.2.

UPDATE 24/07/2009: same user as before, retried this installation with a few tweaks as an academic exercise. Installed main system, ToH kernel, Darwin Bootloader, SATA and nForce SATA patches and nothing else. Booted into system, downloaded EFIStudio with functioning Netgear GA311 in order to write information for new XFX geforce 8800GS XXX 384mb. Successful, quartz extreme working. Extracted Sigmatel 9227 kext from the iPC 10.5.6 Final DVD via Pacifist, sound working. Finally, updated system kernel to Voodoo 9.5 using OSX86Tools. Basically have achieved a perfect system with this method, minus updates.

In order to boot the e520 bios must be set to RAID ON. This new method is much better because it uses all the e520's default hardware except for the network card. a kext does exist for the network available on the iDeneb dvd as well as iAtkos 7i, but this has not been tested.

System has now been formatted in order to return to iPC 10.5.6.

[edit] Acer Aspire X1200 Boxer

Leo4all v4 Processor AMD Athlon Dual Core 4200+  : Works RAM 2 GB DDR  : Works Nforce 720a chipset Mobo  : Works HDD - SATA 320 GB  : Cannot boot from this; Installed onto a USB external HDD; reads and writes USB - mouse, keyboard, ext HDD, etc  : Works Nforce 10/100/1000 ethernet adapter  : Does not work ALC 880 sound  : Does not work

[edit] eMachine T3656

Installations Methods iATKOS i4.0i/Kalyway 10.5.4 Install DVD/JaS Mac OS X 10.5.4 Client+Server/Mac OS X Leopard Retail DVD with Boot-132 as a bootloader

  • Installation from Mac OS X Leopard Retail DVD allows you to upgrade software without kernal panic through Apple Software Update *

Processor Intel Celeron 2.0 GHz 440 - FSB(Front Side Bus)800 MHz MegaHertz

RAM 1 GB DDR2 - 2 Slots are avaliable for upgrade and both are recongnized

Graphics Intel GMA 950 - Graphics Acceleration causes kernal panic on all installations

HDD SATA II 160 GB - I haven't tried multiple HHD using the SATA Controllers

USB(Most Hardware is supported I havent ran into any problems)

PS/2 Devices - Can be Utilized *Except when using Retail DVD via Boot-132 use PS2Keyboardfix.pkg*

I/O Devices - All are detected

Ethernet OnBoard Realtek 10/100Mbps Ethernet

Audio Sound Card Realtek Drivers are supported from most installations except Jas SERVER use the ALC883.pkg([1]

[edit] Dell gx620

iATKOS i4.0i/Kalyway 10.5.4 Install DVD Processor: Intel Pentium 4 3.39 GHz 800Mhz bus speed

Memory: RAM 4 GB DDR 533 Mhz ;Works

HDD - WD SATA 640 GB : HDD; reads and writes

USB - mouse, keyboard, ext HDD, etc  : Works

Video: Integrated Intel Graphics Media Accelator 950: Quartz extreme; Supported Core image; hardware accelarated

Audio: Ac97 sound : Does not work, updated with kext from mac girl still no resolve Networking: it sees all of the ports but i never tried using the ethernet port although dont thinks it works using belkin usb adapter for wireless networking and internet. firewire when installed was recongnized

Applications: Final cut pro 5, shake 4.1, blender, adobe photoshop CS, Logic 8 ; final seems to only work with the belkin wireless adapter up and running which i haven't figure out why before that it was crashing everytime logic works but all the audio editing is useless without a working audio card i may have to buy one tring to avoid it, even though i have 4 GB of kingston ram it still could use lil more pick up comparing to my 2.5 GB G5 mac at my studio would love any suggestion on how to get this audio working currently looking for the best motherboard out of the box that comparable to a G% with working audio open to suggestions


This page was last modified on 2 July 2011, at 18:58.
This page has been accessed 64,142 times.
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers