HCL 10.6.7/Desktops

From OSx86
Jump to: navigation, search
Mac OS X 10.6.7
Hardware Compatibility

This is a hardware compatibility list ONLY for OEM desktop computers. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying a desktop. Don't forget to add how you got OSx86 running on your x86 desktop computer, and to use proper English. Please see the discussion page for proper instructions on how to input your system specs. Also, please contribute to the HCL 10.6.7 page, which should list a more granular view of compatibility. If your computer isn't listed, you should try it if you have a SSE2 or higher processor. Use vanilla kernel if it is supported.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.6.7 builds only.

Please list your computers in alphabetical order by manufacturer (Asus, Acer, Dell, HP, etc)

For how to edit the Wiki, please see this thread. Thank you!

Note: Please add whether your device supports QE, Quartz Extreme, graphics. Try playing a movie with Quicktime Player.

Contents

[edit] Lenovo

[edit] Dell

[edit] Dimension 9100

(NOTE: 64bit so far unachievable)

  • Specs
    • Intel® Pentium® D 925 (3.0 GHz, 800FSB)
    • 4 GB Dual Channel DDR2 677 MHz - 2x2GB
    • Nvidia GT430 1GB
    • 80gb 7200 RPM SATA HDD
    • Chipset Intel ICH7
    • Optical Drive IDE: DVD-RW
    • Sigmatel 9221 HD audio
    • Realtek 8139 10/100
    • Onboard network (not working)
  • Install Methods
    • Hazard 10.6.2 install disc
    • Legacy Kernel
    • IOPCIFamily fix (essential to stop KP)
    • About this Mac SMBIOS fix
    • VoodooHDA for 2 Channel
    • Chameleon RC4
  • After Install
    • Run 10.6.5 combo update (or greater) - do not restart after completion
    • Install latest legacy kernel from Netkas
    • Run Tonymacx86's Multibeast and choose Chameleon RC5, VoodooHDA and Graphics Enabler=Yes bootflag.
    • Restart and if necessary boot with flag "legacy_kernel".
    • Run Tonymacx86's Nvidia Fermi update
    • For QE/CI - Patch com.apple.Boot.plist with EDID via gfxutil - check http://tonymacx86.com/viewtopic.php?f=3&t=8157
    • Install CUDA update from Nvidia if desired
    • In /Extra/com.apple.Boot.plist enter flags - FSB:199510282, USBFix=Yes
    • Realtek 8139 use: PCGenRTL8139Ethernet-1.2.0. Will work at reduced speed until you follow included instructions to patch. Then full 10/100
  • Working
    • Dual Core, CUDA and everything working fantastic except onboard LAN and chop issues with USB audio cards, Cakewalk UA-25EX in particular.
    • Tests with Final Cut studio 3 work great, RT Unlimited at High quality playback, initial problems with RT profiling allowing only low/med playback. To Fix, remove one 2gb stick of RAM, restart, clear final cut preferences and RT profile again. Then install second 2gb stick.

[edit] GX 620 slim

    • Pentium D2.8
    • 1.5gb ram
    • 40gb HD
    • Intel GMA 2772 looking for a fix for it but the other two ones work
    • ( just remember to select the first kernel when installing iatkos)


[edit] Inspiron 580MT

    • Working perfectly. Using Hazard 10.6.6i (patched), only needs a few kexts for sound and network.
    • Also requires editing of smbios.plist for correct info, and I added PlatformUUID.kext with my boot-UUID value edited in (this might not be necessary).
    • I removed the two AHCI injectors from /Extra. Updated with 10.6.7 Combo Update from Apple. Added pmVersion=21 to avoid kernel panic, and get sleep working perfect again. NO DSDT REQUIRED! (DVI -> HDMI adaptor doesn't work).
    • Everything works perfectly, USB, Sleep, Hibernate, Card-reader etc. etc. Full instructions and guide available here:

http://www.insanelymac.com/forum/index.php?showtopic=253260


[edit] Optiplex 755

Hardware Name Chipset Notes
Optiplex 755 Intel Q35 + ICH9R
  • Processor: 2.33GHz Intel Core2 Duo
  • RAM: 2GB 600MHz DDR2

Installation

  • YOU HAVE TO UPDATE BIOS FROM A4 TO A10! Otherwise the Harddisk is not visible in iBoot after Installation!
  • Retail OS X 10.6.3 retail DVD via iBoot. Update to 10.6.7 with ComboUpdate.
  • SATA. works fine.
  • optical drive: ASUS DRW-24B3ST
  • USB:(working OOB)
  • Graphics: ATI HD5450 works with ATI5000injector and lion kexts
  • Ethernet: Intel 82566CN. Using e1000.kext All works! (via Multibeast)
  • Audio: SoundMAX digital audio (use VoodooHDA) (via Multibeast)
  • MacPro3,1 via MultiBeast.


[edit] Precision 470/670

Follow this link for full installation details.

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Dell Precision Workstation 670 Intel® E7525 (ICH5)
  • BIOS: A07
  • CPU: single/dual Intel Nocona/Irwindale Xeon 64bit (2.8GHz to 3.8GHz) & single/dual Intel Paxville dual-core Xeon 2.8GHz (XC837/XC838 motherboards)
  • RAM: 4GB 400MHz DDR2 ECC
  • Video: PCIe x16 nVidia GeForce 9800GT 512MB
  • Audio: built-in Intel AD1980 AC'97 SoundMax
  • Network: built-in Intel Pro/1000 MT Gigabit Ethernet
  • Hard Disk: Intel ICH5 Ultra ATA (SATA-1) & IDE controller + Adaptec Ultra320 SCSI RAID controller
  • Installed retail Snow Leopard 10.6.3 with MyHack 3.1.2 or Nawcom BootCD/ModUSB + legacy kernel (Darwin 10.4.0 to 10.8.0 v2) + Combo update to 10.6.7
  • Full installation method + bootpack (DSDT + kexts) + EDP available at www.osxlatitude.com
  • GeForce 9800GT natively supported with full DSDT patch or PciRoot set to 4
  • Boots only with no NullCPUPowerManagement & no SleepEnabler kexts, otherwise KP or boot loops
  • Built-in Ethernet detected but not working (always down with "cable unplugged") with vanilla AppleIntel8254XEthernet kext v 2.1.3b1. Use older version v1.1.2 (from Tiger?) of that kext instead.

Issues

  • Adaptec SCSI controller not detected - no kext seem to exist
  • Audio unsupported in 64bit kernel mode (corrupted audio that may cause system crash
Tick.png Tick.png

[edit] Vostro 200 (SlimTower)

Follow this link for full installation details.

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Dell Vostro 200 (ST) Intel® G33 (ICH9) Express chipset
  • CPU: Intel Core 2 Duo E8600 3.33GHz
  • RAM: 4GB 800MHz DDR2
  • Video: PCIe ATI Radeon Pro X1300/X1550 256MB (0x7183) -> Ok with patched ATI kexts
  • Audio: buit-in Realtek ALC888 -> Ok with VoodooHDA kext
  • Network: built-in Intel 82562V-2 10/100Mb built-in Ethernet -> Ok with AppleIntelE1000 or Intel82566MM kext
  • Hard Disk: 2 x SATA HDD 320GB 7200RPM
  • Card Reader: Internal-USB TEAC CA200 19-in-1 -> works OOB
  • Used unlocked BIOS 1.0.16 from www.bios-mods.com to provide HDD AHCI mode. Use RAID HDD mode with standard BIOS
  • Installed retail Snow Leopard 10.6.3 with MyHack 3.1.2 + Combo update to 10.6.7
  • Full installation method + bootpack (DSDT + kexts) + EDP available at www.osxlatitude.com
  • Full QE/CI in 32+64bit kernel mode (with patched ATI kexts)
  • Card reader works OOB
  • Sleep/wake + HDD icons + restart/shutdown fixed with DSDT patch
  • Installation should work just the same on Vostro 200 Mini-Tower (MT)
Tick.png Tick.png

[edit] Lenovo

[edit] Lenovo M57e

  • Used 10.6.6i by Hazard, then downloaded combo update normally. (Only SleepEnabler panicked the system. used pmVersion=0 flag to disable it and installed the 10.7.0 updated kext
  • Everything works except GFX Card.
  • Specs:

- Intel Core 2 Duo E8400 3 GHz - 3 GB RAM - Intel ICH7 G31/G33 MoBo Chipset - Marvell Yukon Ethernet adapter - ATI Radeon HD 4350 1 GB GFX Gard (QE/CI not working) - 160 GB HDD. Kexts used apart from vanilla installation: RadeonHD.kext for native resolution, VoodooHDA.kext with PrefPane for working audio.


-AMD PHENOM II X2 550BE -MSI 770C45 MOBO

 SB710 CHIPSET

-DDR3 1333 4GB RAM -NVIDIA 9600GT 1GB PCIE -ALC 888S AUDIO ONBOARD -320GB HD SATA -DVD RW SATA -REALTEK PCIE GBE ETHERNET CARD ON BOARD

Everything works, sound=stereo out(no mic), and random glitches appearing in screen sometimes Used SnowLeoDvd from a torrent Chameleon Bootloader Legacy Kernel AzaliaAudioPkg from insanelymac Running Starcraft 2 on the machine without problems Most of the applications working without problem

[edit] Lenovo Idea Centre K210 series

Chipset Specs Installation Notes
  • North Bridge - Intel G31
  • South Bridge - ICH 7
  • Processor: Intel Core 2 Duo Processor E
  • RAM: 2 GB DDR2 667 MHz
  • Motherboard: IBM / Lenovo G31T-LM2 LGA775 Ver: V1.0 (This is compatible with same model Gigabyte MB)
  • Graphics: Integrated (Intel G31)
  • Monitor: Compaq MV 540 (1024x768 resolution only)
  • Hard Disk:80 GB ATA and 250 GB SATA (used 80 GM ATA for OSX installation and others as data)
  • Bootloader: Chameleon
  • Set the SATA mode to AHCI in the BIOS
  • Used HAZARDs' 'Snow Leopard 10.6.1-10.6.2 SSE2 SSE3 Intel AMD' to install Snow Leopard 10.6.2
  • At boot typed cpus=1 arch=i386
  • Customized selection as:
  • Combo 10.6.2
  • Chamelion 10.5
  • Eliot
  • IOATASATAFX
  • SMBIOS Resolver
  • UUID
  • Fake SMC
  • Updated by downloading the 10.6.7 combo update from Apple's site.
  • Backed up 10.6.3 kexts
  • AppleHPET.kext
  • AppleACPIPlatfrom.kext
  • IOVideoFamily.kext
  • IOUSBMassStorageClass.kext
  • IOUSBFamily.kext
  • IOPCIFamily.kext
  • Installed the Update, but did not restart.
  • Used Kext Helper b7 to install the 10.6.3 kexts. '
  • Restarted having installed the kexts - should boot to OS X normally.
  • Made installation with 1GB RAM only and run SL with 2GB RAM after installation
  • Video did run in QT after updating Perian and installing Nice player.
  • safari and firefox (installed only) did crash repeated it was due to FLASH
  • preview didn't show images nor the PICASA

This page was last modified on 15 April 2014, at 20:37.
This page has been accessed 84,185 times.
Powered by MediaWiki © 2013 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers