HCL 10.7.0/Desktops

From OSx86
Jump to: navigation, search
OS X 10.7.0
Hardware Compatibility

This is a hardware compatibility list ONLY for OEM desktop computers. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying a desktop. Don't forget to add how you got OSx86 running on your x86 desktop computer, and to use proper English. Please see the discussion page for proper instructions on how to input your system specs. Also, please contribute to the HCL 10.7.0 page, which should list a more granular view of compatibility. If your computer isn't listed, you should try it if you have a SSE2 or higher processor. Use vanilla kernel if it is supported.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.7.0 builds only.

Please list your computers in alphabetical order by manufacturer (Asus, Acer, Dell, HP, etc)

For how to edit the Wiki, please see this thread. Thank you!

Note: Please add whether your device supports QE, Quartz Extreme, graphics. Try playing a movie with Quicktime Player.

Contents

[edit] Acer Aspire X1700

  • BIOS: The first
  • CPU: Intel Celeron Dual-Core E1200 @ 1.6Ghz
  • RAM: 3Gb Transcend DDR2 800Mhz
  • VGA: Onboard Nvidia GeForce 7100/Nforce 630i does not work properly in OS X
  • Monitor: Acer X192w on DVI port
  • Audio: onboard OK
  • Ethernet: onboard OK
  • HDD: Hitachi 320 GB, 7200rpm, 16MB cache OK
  • DVD: LabelFlash OK
  • USB: all ports OK
  • Keyboard: Trust USB keyboard (PS/2 devices don't work)
  • Mouse: Firstline FMO100 USB mouse OK.


  • Installed OS X 10.7 GM (Final) using TonyMacX86 method "xMove + MultiBeast: Install OS X 10.7 Lion on any Supported Intel Core 2 or Core i based PC" [1]
  • Bootloader - Chimera V1.4.1
  • Kexts used: EasyBeast, Mac Pro 3,1 Definicion, VoodooHDA.kext
  • Video: Any kexts. No GraphicsEnabler option in com.apple.Boot.plist, QE/CI Disabled, only video resolution 1024x786x32 , tested only DVI port
  • Audio: VoodooHDA.kext v. 2.6.2 [2]
  • SATA: Works good with EasyBeast, OK
  • Ethernet: Works good with EasyBeast, OK
  • Sleep & Wakeup: Works fine, any kexts needed, OK
  • Reboot & Shutdown: Works
  • OSX Lion boots 64 bit kernel by default

[edit] HP

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
HP DC7700 Ultra Slim (C2d) Intel Q965 Express *Intel C2D 6300 1.68GHz
  • Intel GMA 3000
  • 3 Slot 3GB max
  • Audio - Realtek ALC262 Not Working
  • Video - Works but fixed Res: 1024*768
  • Ethernet - Intel 82566 Needs kext (http://osx86.co/f57/intel-ethernet-82566-kext-for-snow-anyone-t3829/page2.html)
  • Install method - Used (Mac OS X Lion For Common PC Niresh12495 - KextsFixed Hacintosh) can be found at TPB... (surprised how easy and quick it was) Used the bootloader from MultiBeast 4.0.2: Lion Edition
No Yes


[edit] Dell

[edit] Precision Workstation

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Dell precision T5400 Xeon and T7400 Xeon also Runs on Dell Optiplex GX745 (C2d) Intel 5400 / 5400b *Intel QUAD XEON 3.0GHz (Pecision T7400)
  • NVIDIA Quadro FX 1700
  • 8GB RAM DDR2 800Mhz
  • Install method - Installed from 8GB thumb drive using "Myhack 2.0 RC 1" Installer Package [3] up and running in 20 mins just point and click using Lion 10.7 Retail
  • Audio - VoodooHDA works
  • Video - Works but reports only 3mb ram
  • Ethernet - Need kext Update for Broadcom 57xx 021e1028167a
Yes Yes

[edit] Optiplex 745

Hardware Name Chipset System information Notes
Please provide your feedback here
32/64 bit mode
Dell Optiplex 745 [4] Intel Q965/ICH8
  • BIOS: v. 2.6.4 (latest) [5]
  • CPU: Intel Core 2 Duo E6600 (2.40Ghz/4M/1066).
  • RAM: 4 GB DDR2 800 Mhz/PC2-6400 5-5-5-15 in dual channel mode (Kingston KHX6400D2B1K2/4G).
  • VGA: Gainward NVIDIA GT 220 512 MB DDR3 PCI-e card (barely fits, other cards may not clear the mainboard capacitors or the CPU cooler). ''Onboard Intel GMA 3000 is supported. Note ( GMA 3000 will support with GMA950 KEXT and enabler also desired resolutions in Chameleon peripherals needs to be done ) then you will get your screen resolutions with no problem ....any questions edited by ( arifshen@aol.com ) on Jan 2012
  • Monitor: Samsung SyncMaster T220 LCD/TFT on DVI port.
  • Audio: Onboard Intel HD Audio Controller (ICH8 family).
  • Ethernet: Onboard Broadcom BCM5754.
  • Bluetooth: Bluesoleil chipset USB dongle (p/n: BD-203).
  • HDD: Seagate Barracuda 7200.11 SATA 3Gb/s 320 GB, 16MB cache [model ST3320613AS]
  • DVD: GSA-H31N (crossflashed H30N firmware to original H31N drive [6] to gain DVD-R DL burning functionality).
  • Keyboard: Dell USB keyboard.
  • Mouse: Razer DeathAdder 1800 dpi USB mouse. Use USB Overdrive [7] to adjust mouse pointer tracking speed and acceleration, as built-in OS X mouse adjustment seems inefficient. This utility will also make additional mouse buttons operational.
  • Webcam: Logitech HD Pro Webcam C910 [8]
  • Installation: Installed Mac OS X 10.7 (AppStore version 11A511) using Mald0n's method [9]. Boot USB pendrive (read note for SATA below) and then create a GUID partition HFS+ journaled, install OS X, then install Chameleon, Extra_Lion folder and kexts on HD.
  • Bootloader: Chameleon 2.0 RC5 r1083 [10]. After installation use Chameleon Wizard [11] to easily update the bootloader and to tune your Boot.plist and SMbios.plist files.
  • System kexts: FakeSMC, AppleRTC (apply patch [12] to solve CMOS reset issue after S3 sleep/wakeup - simply run this code in terminal, type in password and you are set), EvOReboot, NullCPUPowerManagement, Sleepenabler.
  • Video: NVEnabler64 [13]. QE/CI enabled, all video resolutions up to 1680x1050@32 on both DVI and VGA ports OK. If using a CUDA capable NVIDIA GPU (i.e. GT 220) install latest CUDA drivers for OS X [14]. CUDA technology partly offloads CPU tasks to the GPU, overall making your system faster, especially at multitasking. You can check if CUDA is enabled by running CUDA-z utility [15].
  • Audio: VoodooHDA.kext v. 2.7.3 [16]. This modified version enables VoodooHDA preference pane settings for Intel HD audio controller (by default only HDMI can be selected) and includes volume level (PCM, iGain, Mic, iMix, iMonitor) adjustments and SSE2 sound treatment auto-enable fix, for distortion-free audio. To avoid KP install AppleHDADisabler.kext in /S/L/E or simply delete AppleHDA.kext in /S/L/E prior to installing VoodooHDA.
  • SATA: Use Normal mode in BIOS. ICH8 controller requires IOATAFamily.kext v. 2.5.1 from SL 10.6.3+ [17] which you must also place in your USB pen drive, in /E/E, so as to make the installer see your internal drives.
  • Ethernet: BCM5722D.kext [18] (latest version with device ID string corrections in info.plist). Cannot login to AppStore unless the EFI string of the ethernet device is injected in com.apple.Boot.plist (use EFI Studio 1.1 [19] to extract string).
  • Bluetooth: USB dongle works OOB.
  • PS/2: Doesn't work OOB, needs Apple PS/2 kexts [20] which must be placed in /E/E on both pendrive and target partition.
  • USB: All ports OK.
  • Webcam: Works OOB with Facetime, Skype etc. Adds up as a digital audio input (mic) device.
  • Sleep & Wakeup: Works OK, patch AppleRTC.kext (as per the instructions above) and use Sleepenabler.kext of appropriate version (10.7.1/10.7.2 version [21]) in /E/E.
  • Reboot & Shutdown: Works OK, use EvOReboot.kext in /E/E to avoid occasional system hang in reboot/shutdown sequence.
  • To easily install kexts, repair file permissions and rebuild kext cache (for both /E/E and /S/L/E) use Kext Wizard [22].
  • 64-bit Kernel and Extensions: Yes (by default).
  • Use model identifier iMac8,1 in smbios.plist. This setting combined with NullCPUPowermanagement.kext in /E/E yields smoother graphics and better video playback performance plus a higher Geekbench [23] score.
  • CPU powermanagement (P states) does NOT work. CPU throttling does NOT occur. Tried Voodoo power kexts but they simply do NOT work. Probably a DSDT patch is needed.
  • If experiencing random KPs at boot time insert a 10 sec timeout in Chameleon. This allows electronics to warm up and function properly before the OS gets loaded.
  • Updated to 10.7.1 (11B26) using the downloadable package provided by Apple [24]. No problems found.
  • Updated to 10.7.2 (11C74) using the downloadable package provided by Apple [25]. No problems found.
  • Updated to 10.7.3 (11D50) using the downloadable package provided by Apple [26]. No problems found.
  • Updated to 10.7.4 using Software Update. No problems found.
Tick.png Tick.png

[edit] Optiplex 755

Dell Optiplex 755 Desktop

  • Processor: Intel Core 2 Duo @ 2.66ghz
  • Ram: 4gb DDR2
  • Video: NVidia GeForce 8400GS 512mb (Need NVInject.kext or search kexts.com for 8400GS and use the one for Lion)
  • Graphics: QI/CE Fully Working With Resolution Support
  • Network: Onboard Intel (Worked OOB but was broke after running MultiBeast, fixed with Intel82566MM.kext)
  • Audio: Onboard Working (Needed VooDooHDA.kext to make it work)
  • HD: Seagate 160gb 7200rpm (Stock Dell HD)
  • DVD: Stock Dell DVD Drive
  • All USB and Serial Ports Work (Didn't try the LPT Printer Port)

Installed OSX Lion 10.7.0 using UniBeast 1.1.0 and the App Store Version of Lion. After making the USB Drive (see Tony Mac's blog) installed without a hitch. Went through Apple's setup and after the setup I ran MultiBeast for Lion which broke my Ethernet, but allowed me to boot without the USB drive being in. After the reboot, I put the ethernet kext mentioned above and the NVidia kexts on the desktop and ran KextBeast to install them. Rebooted and everything is working GREAT! App Store works, Office 2011 works, iLife '11 works. It is a great machine thus far. Email me if you need direction or kexts j.t.a.y.1.8.7.@.g.m.a.i.l.c.o.m without the extra '.'

UPDATE: Did the Apple Software Update to 10.7.3 and everything is working like it should and I didn't have to reinstall any Kext's

[edit] Optiplex 760

QE
Icon U.png
Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Dell Optiplex 760 Intel Q43 Express w/ ICH10D
  • Intel Core 2 Duo E8400 @ 3.0Ghz
  • RAM: 2GB 1333 Mhz DDR3
  • VGA : Integrad IntelGMA4500 64Mb
  • Audio : onboard Full working
  • Network: Intel WG82567LM Full working
  • Graphic: working with NO QE/CI
  • Monitor : Dell 22" DVI Cable
  • Hard Disk : Seagate SATA II 320Gb
  • DVD : TSSTCorp Sata TL-463A
  • USB, eSata: all work
  • Installed 10.7 Final with USB Pen creation + Chameleon 2.0-RC5-r755.pkg + Extra_Lion.pkg (followed Mald0n method on InsanelyMac)
  • I have used OSInstall.mpkg MBR patched to install dual boot on HD
  • Boot USB Pen and then create a MBR partition HFS+ journaled , then install as usual, Then install Chameleon , Extra_Lion and Kexts on HD
  • Bootloader - Chameleon 2.0 RC5 r755
  • DSDT created by DSDT autopacher
  • Kexts used : fakesmc.kext,NullCPUPowerManagement.kext, ElliotForceLegacyRTC.kext (needed to avoid Bios Reset)
  • Audio - VoodooHDA.kext v. 2.62 (x86_64).
  • Video - no Kext - com.apple.Boot.plist - Graphics Mode=1280x1024x32 - GraphicsEnabler=Yes
  • SATA - AHCI in BIOS (Set by default on BIOS)
  • Ethernet - IntelE1000.kext
  • Sleep & Wakeup : Works , no Kext needed
  • OSX Lion start in 64 bit kernel by default [27]
  • Best Regards by PippoX0
Yes Yes

[edit] Vostro 430

QE
Icon U.png
Hardware Name Chipset Notes
Dell Vostro 430 Intel P55
  • Processor: Intel Core i7 CPU 860 @2.80GHz
  • RAM: 6GB 1333MHz DDR3

Installation

  • xMove + Multibeast used.
  • Two SATA Hard disk (because I want to change the one where Snow Leopard was). HD #1 Snow leopard 10.6.8. HD #2 Two partitions (Lion, and Lion installer prepared by xMove).
  • Use the last version of Multibeast (3.8) in order to have the last bootloader (with the 3.7.2 the Lion installer causes Kernel panic at reboot).
  • From Snow Leopard 10.6.8 working installation use xMove and write Lion installer partition (remember to mount InstallESD.dmg or xMove will fail) on #2 drive. Reboot and select the partition written by xMove. The installation will be normal.
  • At the end of the installation reboot, I was unable to boot my new Lion, so boot in the old Snow Leopard and run Multibeast to make the new drive bootable and fix a few things -> Multibeast options - Easybeast, VooodoHDA 0.2.1, set Apple model to 11.1.
  • Reboot and select the hard disk where you have installed Lion. It will boot normally and your Lion will be up and running.
  • USB: All work.
  • Graphics: NVidia GTS 240 1024mb DDR3. Works with QE/CI via DVI. Only one monitor works.
  • Ethernet: Onboard Broadcom BCM57780 works with this kext http://www.kexts.com/view/1785-ar9285-bcm57780.html
  • Audio: Onboard work with VooodoHDA 0.2.1.
  • Updated to 10.7.2 without problems.

[edit] Vostro 460

QE
Icon U.png
Hardware Name Chipset Notes
Dell Vostro 460 Intel H67
  • Processor: Intel Core i5 CPU 2500 @3.33GHz
  • RAM: 4GB 1333MHz DDR3

Installation

  • Boot into iBoot then insert your retail Snow Leopard DVD and install
  • After install, reboot back into iBoot and boot off the drive you just installed SL to.
  • Once SL is up and running, run UpdateHelper and reboot.
  • Now update to 10.6.8 (DO NOT RESTART) and then run Multibeast(select both the easy option and System Utilities) and Chimera 1.5.1 updater BEFORE RESTARTING. THEN you can reboot.
  • Once booted back up, use xMove, reboot and select the Installer partition you just copied Lion (via xMove) to and install Lion OVER your SL parititon.
  • After Lion is up and running, you will need to re run Multibeast and use it to install the lastest Voodoo audio drivers. Just select the latest version from the Audio drivers list in Multibeast.

Setup

  • Two SATA Hard disks (One for Windows, one for OS X. Created xMove partition on OS X drive).
  • Reboot and select the hard disk where you have installed Lion. It will boot normally and your Lion will be up and running.
  • USB: All work.
  • Graphics: The built in Sandy Bridge HD 2000 does NOT WORK properly. It will only run at 1024x768 with no QE. I recommend buying a PCI-E video card. I have the Sapphire ATI Radeon 6450 DDR3 1GB. It's a budget card that is very affordable and it works PERFECT with OS X (full resolution and QE/CI, plus both the VGA and HDMI ports work fine but I have not tested DVI). Just make sure you set graphics enabler to NO in your boot file or this card will NOT work at all. This is very important because it will not boot Lion if it is not set to NO.
  • Ethernet: Onboard Broadcom BCM57780 doesn't work (I just used a cheap USB WiFi adapter I found on eBay for internet).
  • Audio: Onboard work with VooodoHDA from Multibeast.
  • Sleep: Does not work, not too concerned about it since I don't use sleep anyway, but I'm sure theres a way to fix it.
  • Updated to 10.7.1 without problems. Current 10.7.2 beta also works fine.
  • Note: If you get any KP's while booting, boot with -v. I haven't had a single KP while running the OS. It actually runs better then a real Mac!

IF YOU NEED HELP INSTALLING OR HAVE QUESTIONS E-MAIL ME: toldyaboy1111@aim.com

[edit] Gigabyte

[edit] Custom

QE
Icon U.png
Hardware Name Chipset Notes Patches Used 32/64bit working with patches
GA-G41M-Combo ICH7
  • BIOS updated : September, 06 2010
  • Intel Core 2 Duo 2.7 Ghz
  • Memory : 2GB of Ram - 1333 Mhz (DDR3)
  • VGA : nVidia Geforce 8400 GS 512 MB
  • Audio : Full working
  • Network Full working
  • Graphic Full working with QE/CI
  • Monitor : Hp w1707 with connect by DVI Cable
  • Hard Disk : Seagate 1TB
  • Installed 10.7 Final on Mac App Store by Hackboot v6.2 CD
  • Use hackboot v6.2 to boot EFI first and then install by tut split my HD with new partition (10GB) to restore install InstallESD.dmg on that disk to install.
  • Bootloader - Chameleon 2.0 RC5 r1191 [VS] (Tested on July 20, 2011)
  • DSDT created by DSDT autopacher and it's so amazing :)
  • Audio - Voodoo HDA 0.2.62 (x86_64) driver Modded to link from Speaker to PCM with Volume Control worked perfectly.
  • Video - nVidia Geforce 8400 GS 512 MB (works with nVEnabler64.kext)
  • SATA - AHCI in BIOS (Set up default on BIOS)
  • Ethernet - AtherosL1Cthernet.kext (the below link it's lastest version to fix any random kernel Panic).
  • Sleep & Wakeup : Works perfectly, no need to install SleepEnable.kext !
  • Here all my file with GA-G41M-Combo for Lion: [28] (Found on a haft of day to take full files)
  • Default Lion will be using 64 bit kernel
Yes Yes
GA-EP45-DS3R ICH10
  • BIOS F11e
  • Intel Core 2 Quad Q9450 2.6GHz
  • Memory : 4GB of Ram - 1333 Mhz (DDR2)
  • VGA : Apple ATI Radeon HD 5870 1GByte GDDR5
  • Audio : Full working
  • Network Full working
  • Graphic Full working with QE/CI
  • Monitor : Apple 27" LED Cinema
  • Hard Disk : OCZ VERTEX 240GB SSD
  • Installed 10.7 Final from Mac App Store using Tonymacx86 iBoot+MultiBeast+xMove (Highly recommended) CD's with MultiBeast options [iMac, GraphicsEnabler=NO, 64bit, PCI Root ID fix]
  • Pre edited DSDT was downloaded from Tonymacx86 as 'DSDT-GA-EP45-DS3R-1.0-F10.aml.
  • Audio - Onboard
  • Video - Apple ATI Radeon HD 5870 (works out of the box for both OSX 10.7 and Windows 7)
  • SATA - AHCI in BIOS (Set up default on BIOS)
  • Ethernet - Onboard, but needed MultiBeast patch after installing Lion.
  • Sleep & Wakeup : Works perfectly, no need to install SleepEnable.kext !
  • Default Lion will be using 64 bit kernel
Yes Yes

[edit] Lenovo

[edit] ThinkCentre A55 (8975)

QE
Icon U.png
Hardware Name Chipset Notes Patches Used 32/64bit working with patches
IBM - Unknown Intel 946GZ
  • BIOS updated : Stock
  • Intel Core 2 Duo E2180 2.0Ghz
  • Memory : 2GB of Ram - 533 Mhz (DDR3)
  • VGA : ATI Radeon HD 2400 Pro (94c3)
  • Audio : Built in - Unknown (not tested)
  • CMedia PCI Audio Device
  • Network : Ethernet supported!
  •  : Railink T61 Turbo Wireless - Not Supported/Cant find any kext
  • Graphic : Can only achieve a widescreen resolution when in safe mode + using ATY_INIT, otherwise stuck in 4:3 aspect ratio
  • Monitor : AOC F22S VGA
  • Hard Disk : Western Digital 320GB
  • Installed 10.7 Via iAtkos V2
  • Had to install EFI 10.6 and patch with 10.7 then boot off memory stick
  • Bootloader - Chameleon 2.1
  • Audio - CMI8738PCIAudioDriver.kext - Stereo output working perfectly, havent tested input or 5.1
  • Video - Good luck with a 2400...
  • SATA - AHCI in BIOS (Set up default on BIOS)
  • Ethernet - RTL8138.kext works great!
  • Sleep & Wakeup : No need to change anything works out of the box!
Yes Yes

This page was last modified on 11 May 2012, at 13:07.
This page has been accessed 169,631 times.
Powered by MediaWiki © 2013 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers