Editing HCL 10.5.8/Desktops

Jump to: navigation, search

Warning: You are not logged in.

Your IP address will be recorded in this page's edit history.
The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 1: Line 1:
{{Desktops|10.5.8}}
+
{{10.5.8}}
 
+
 
===DELL Dimension 9200===
 
===DELL Dimension 9200===
 
*Core Quad 6600 2,4 Ghz
 
*Core Quad 6600 2,4 Ghz
 
*1,5G RAM
 
*1,5G RAM
 
*NVidia 8600 GTS 256MB
 
*NVidia 8600 GTS 256MB
*used iatkos v7 to install and next Retail 10.5.6 with 10.5.8 Combo Update
+
*used iatkos v7 to install and next Retail 10.5.6 whit 10.5.8 Combo Update
 
*Bootloader - Chameleon 2.0 RC
 
*Bootloader - Chameleon 2.0 RC
 
*Graphic - EFI String
 
*Graphic - EFI String
 
*NIC & Audio - use package from iPC 10.5.6 final
 
*NIC & Audio - use package from iPC 10.5.6 final
*Almost working - does not correctly recognize RAM module and processor (see as 4,8 unknown).
+
*Almost working - not correkt recognize RAM module and procesor (see as 4,8 unknow).
 
+
=== Dell Dimension 9100 ===
+
* '''Processor:''' Pentium D. Both cores running.
+
* '''Install Method:''' iAtkos v7 10.5.7. Use default kernel.
+
* '''Update Method:''' 10.5.8 Combo Updater, patch device/vendor IDs in same drivers again.
+
* '''Graphics:''' Dell-branded (00c1) nVidia GeForce 6800 256MB. Use nVidia EFI with VGA/DVI only. Add 0x00c110de to NVDANV40Hal.kext and NVDAResman.kext
+
(There was some page that said that the EFI string should be generated on 10.5.7 to be correct which is what was done)
+
* ''Sound:'' Default drivers work.
+
* ''Wireless:'' Add in PCI WiFI card Vendor,Device 168c,1a added to IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext
+
WPA for WiFi cannot be enabled from AirPort GUI. Need to use a terminal command instead:
+
(unfortunately this needs to be done on each boot. Does some one know how to automate this step?)
+
sudo networksetup -setairportnetwork "your wifi name" "password"
+
 
+
===DELL Dimension 5150===
+
* 3.2Ghz P4 SSE SSE2
+
* Sound: Sigmatel STAC9221 (Patched with [http://www.insanelymac.com/forum/index.php?showtopic=32859 AppleHDAPatcherv1.20] and codec dump from Linux -- lookup guides)
+
* Ethernet: [http://go.redirectingat.com/?id=292X457&xs=1&url=http%3A%2F%2Fforum.insanelymac.com%2Findex.php%3Fact%3Dattach%26type%3Dpost%26id%3D13054&sref=http%3A%2F%2Fwiki.osx86project.org%2Fwiki%2Findex.php%2FHCL_10.5.6%2FDesktops%23Dimension_5150_.2F_5100 AppleIntel8255x.kext]
+
====Initial install with iPC 10.6====
+
* Kernel: Voodoo
+
* Chipset: Intel ICHx SATA Drivers
+
* Fixes and Paches: (included in options) Seatbelt.Kext 10.5.5 (fixes errors mounting DMG images); CPUs=1 fix (under one of those lists)
+
* Fixes and Paches: (included in options) in the "Apple SMBIOS Patch" section Select SMBIOSResolver
+
* Applications: As you see fit, but you will likely need OSx86Tools and KextHelperB7 at some point
+
* Audio: Nothing now (will patch AppleHDA.kext using codec dump and AppleHDAPatcherv1.20 after install)
+
* Ethernet: Nothing now (replace with AppleIntel8255x.kext using KextHelperB7 after first boot)
+
* Graphics: DEPENDS ON YOUR CARD and largely independent from install (lookup guide for your card-- no idea about the stock one for this system). If you happen to have installed a PCIe EVGA 9500GT dual DVI, then choose NewMacbook kext option under nVidia and create a custom EFI graphics string using the NVCAP method, by obtaining your NVCAP value analyzing the card under DOS)
+
====Upgrade from 10.5.6 to 10.5.8 using iDeneb Combo Update====
+
* '''''THIS UPDATE DEFAULTS TO VANILLA KERNEL WHICH IS NOT COMPATIBLE WITH PENTIUM. So BEFORE YOU REBOOT use the 10.5.8Tool from same package and fix Voodoo Kernel. (If you forget, use 'kernel=voodoo' boot option, then fix after boot)''''' (I also installed Chameleon RC2 but you probably don't have to if you like the older versions. Or update to the most recent version; currently RC4)
+
* Then REBOOT. First reboot may not work, try again, and if you have trouble, explicitly define boot flags when chameleon is loading (press any key for startup options). '-f' (explicitly loads kexts) '-v' (to show you verbose output of what is going on) and look for errors-- there shouldn't be any. If really stuck use '-x'.
+
* Then you have to fix the seatbelt.kext to match the 9.5 voodoo kernel or mounting DMG will cause a panic (Use the 10.5.5 one found [http://www.insanelymac.com/forum/index.php?showtopic=148566 here])
+
* Now you should be there.
+
* Sound: If it's broken again (mine was). Rereun AppleHDAPatcherv1.20 using your codec dump. You won't see results until a reboot.
+
* Graphics: My QE/CI wasn't working at first, but on verbose boot,I noticed the iDeneb 10.5.8 update (or else Chameleon) had installed ALCinject.kext which was taking control of my graphics loading. I deleted this and rebooted, and everything was fine, as before, with just the EFI string. If you have a different graphics card, this may not even be an issue for you.
+
'''''ALL OTHER KEXTS PATCHED IN 10.5.6 REMAINED AND WORKED ON THEIR OWN.'''''
+
 
+
===DELL Dimension 4700===
+
2.8Ghz P4 SSE SSE2
+
ICH6
+
IntelPro100VE
+
WMP300N (BCM43XG)
+
Nvidia 7300 LE 128MB
+
100% working:
+
- ideneb 1.6 LE 10.5.8
+
  Bootloader: Chameleon 2
+
  Kernel: Qoopz 9.8.0
+
  Patches: AppleSMBIOS 800 Mhz
+
  Fix: CPUS=1_Fix, Seatbelt Fix (had to update to 9.8.0 [http://www.insanelymac.com/forum/index.php?showtopic=148566])
+
  Network: Intel100ProVE, Broadcom Wifi
+
  Video: NVEnabler w/ Full QE/CI Rotation and resolutions
+
 
+
===DELL Dimension 4400===
+
 
+
2.0 GHZ Intel P4 Processor
+
 
+
1 GB RAM
+
 
+
AGP Nvidia FX5200
+
 
+
USB sound adapter
+
 
+
*Step 1.
+
Install ipc 10.5.6
+
 
+
    *  iPC 10.5.6 Universal Final
+
    * Kernel: 9.5.0 voodoo Kernel
+
    * Chipset Drivers: LegacyAppleIntelPIIATA
+
    * Audio Drivers: AC97
+
    * Fixes and Patches: AppleSMBIOS ToH (Fixes "About This Mac" crash)
+
      Seatbelt.Kext 10.5.5 (fixes errors mounting DMG images)
+
    * Used NVIDIA FX5200 AGP 128MB,installed NVKush.
+
      had to overwrite coregraphics.framework with 10.5.5 to fix graphical artifacts.
+
      Full QE/CI Rotation and resolutions
+
Ac97 audio didn't work correctly with onboard audio so I used a usb sound adapter.
+
 
+
Update Chameleon to version 2. 10.5.6 runs great!
+
 
+
---Copy your entire chameleon 2 /extra folder to a usb Flash drive for later.---
+
 
+
*Step 2. 10.5.8
+
 
+
Keep your 10.5.6 drive and use another drive for 10.5.8
+
 
+
Install Ideneb v1.6 lite edition(10.5.8)
+
Choose the following options...
+
    * Ideneb main system
+
    * bootloader: Chameleon 2
+
    * Kernel: Voodoo 9.5
+
    * Ideneb x86 essential patches: Apple Decrypt, Disabler
+
    * Fix: seatbelt Fix
+
    * Audio: VoodooHDA
+
    * Ethernet: Intel100proVE
+
    * Video: NVKUSH
+
    * cleanup
+
Then install....
+
 
+
*Step 3
+
 
+
Boot Ipc 10.5.6 final disc.
+
Unselect EVERYTHING including the base system.
+
 
+
select and install only
+
    * Chipset Drivers: LegacyAppleIntelPIIATA
+
    * Fixes and Patches: AppleSMBIOS ToH
+
 
+
*Step 4
+
 
+
Slave the 10.5.8 drive you just created and boot your iPC 10.5.6 as master.
+
copy the Chameleon 2 /extra folder from your 10.5.6 install or from your usb flash drive to the root of your iDeneb 10.5.8 drive.(same location)
+
Now your 10.5.8 drive should be bootable. :-)
+
 
+
I've tried to update the iPC 10.5.6 installation at least a dozen times using other tutorials with no luck. This was the only way I could get 10.5.8 to run on this system.
+
 
+
good luck!
+
 
+
===Dell Dimension 4500===
+
(almost the same as the 4550)
+
*Pentium 4 2.53Ghz, 1.5GB Ram
+
*No audio (can be fixed by using a USB audio adapter)
+
*NO QE / CL
+
*iDeneb v1.6 10.5.8- Kernal = 9.5.0 Voodoo; Fix= ICHxFixed, Seatbelt Fix, 1=CPUs fix Ethernet = Intel100VE
+
*NO SLEEP
+
 
+
===Dell Dimension 4550===
+
*Pentium 4 2.53Ghz, 1.5GB Ram
+
*No audio
+
*NO QE / CL
+
*iDeneb v1.6 10.5.8- Kernal = 9.5.0 Voodoo; Fix= ICHxFixed, Seatbelt Fix, 1=CPUs fix Ethernet = Intel100VE
+
*NO SLEEP
+
 
+
=== Dell Dimension 3000 ===
+
 
+
* iDeneb V 1.6_1058 Lite Edition
+
* '''Kernel:''' 9.8.0 (Qoopz)
+
* '''Fixes and Patches:''' SMBIOS Enabler, Seatbelt.Kext 10.5.5 (fixes errors mounting DMG images) Kept all necesary fixes and patches checked
+
* '''Bootloader:''' Chameleon v1.0.12 (V2 won't work)
+
* '''Chipset Drivers:''' ICH x Fixed
+
* '''Network Intel100ProVE
+
* '''Audio Drivers:''' Not available in this version.
+
 
+
=== Dell Dimension e520 ===
+
 
+
Specifications
+
*Intel Pentium D 2.79GHz
+
*Sigmatel STAC9227
+
*Intel 82566MM/DC
+
*Nvidia Geforce 7300 LE
+
*'Bios revision 2.4.0
+
 
+
Installation Instructions<br />
+
Bios: Set RAID Mode to ATA/Autodedect <br />
+
Install IPC 10.5.6 with the following options
+
*Kernel: StageXNU
+
*Network: Intel 82566MM/DC
+
*Chipset: Intel ICH10 Sata Support
+
*Graphics: EFI Studio
+
Update with Apple Software Update to 10.5.8 <br />
+
Boot With IPC-CD on Installation Options untick everything (Including the Main Installation) except:
+
*StageXNUKernel
+
*ICH10 Sata Support
+
*Sound: Sigmatel STAC9227
+
*After Installation start EFI-Studio and Patch Graphics to Support Nvidia 7300LE
+
 
+
----
+
  
===Dell Optiplex GX620===
 
* Works 100% (except sleep, dsdt patch might fix that tho)
 
* Pentium D 3.2ghz
 
* 2GB RAM
 
* 250GB MBR HFS+
 
* GMA 950, AC97 Audio, BCM5751 enet
 
* I installed ideneb 1.6 with following options.
 
* ICHX Fixed
 
* Qoopz 9.8.0
 
* AppleBCM5751
 
* Seatbelt fix
 
* Intel GMA 950 Desktop
 
* all default patches
 
* IOUSBFAMILY.kext
 
* mouse lag fix
 
I just went by instinct, some other configs might work.
 
At this point, everything except Audio worked. I downloaded appleac97audio.kext here. http://www.insanelymac.com/forum/index.php?showtopic=88597 If you already have it, you don't need it. Then, I modified the file per instructions here. http://wiki.osx86project.org/wiki/index.php/HCL_10.4.6/Desktops#Dell_Optiplex_GX520.2FGX620
 
Basically, i went in to AppleAC97Audio.kext/contents/plugins/AppleAC97AudioIntelICH.kext/Contents/Info.plist (before I added the kext) and found line:
 
  <string>AppleAC97AudioIntelICH</string>
 
  <key>IOPCIPrimaryMatch</key>
 
  <string>0x266e8086</string>
 
and made it look like this:
 
<string>AppleAC97AudioIntelICH</string>
 
  <key>IOPCIPrimaryMatch</key>
 
  <string>0x27de8086 0x266e8086</string>
 
and then added the kext. I used kexthelper b7, but adding the kext manually and flushing caches would work too. Now audio works, including front outputs
 
Problems: DMG seatbelt problem, apparently ideneb 1.6 doesn't have qoopz seatbelt fix. http://www.insanelymac.com/forum/index.php?showtopic=148566 here you can find the appropiate file (for qoopz 9.8.0, the 10.5.8 seatbelt.kext) and how to install it. After this, my machine has no more kernel panics.
 
 
===HP Pavilion a300n===
 
===HP Pavilion a300n===
 
*Intel Celeron 2.68 ghz
 
*Intel Celeron 2.68 ghz
Line 211: Line 20:
 
**Kernel 9.7.0voodoo
 
**Kernel 9.7.0voodoo
 
**ps/2 mouse and keyboard installed
 
**ps/2 mouse and keyboard installed
everything works perfectly. on board network worked right after first install shows up as macpro 2.48 ghz intel core solo. 100% perfect in functionality.
+
everything works perfectly. on board network worked right after first install shows up as macpro 2.48 ghz intel core solo. 100% perfect in functionality. . .
 
+
  
 
=== Dell Optiplex GX280 ===
 
=== Dell Optiplex GX280 ===
Line 228: Line 36:
 
** Chipset - ICHx Fixed
 
** Chipset - ICHx Fixed
 
Everything works great, Haven't found anything other than the MAC Address of the onboard NIC.  Video is a little sluggish when screen saver is on, but I figure its cause of the weak onboard video. HT is turned ON in Bios, Shows up as 2x 3.46 ghz Intel Core Solo.
 
Everything works great, Haven't found anything other than the MAC Address of the onboard NIC.  Video is a little sluggish when screen saver is on, but I figure its cause of the weak onboard video. HT is turned ON in Bios, Shows up as 2x 3.46 ghz Intel Core Solo.
 
=== Dell Optiplex GX270 ===
 
 
One way:
 
* Intel Pentium 4, 2.8 GHz
 
* Used iDeneb v1.6 10.5.8 Lite to install (Initially had to use safe mode to use OSx86)
 
* Onboard Audio ( had to install via OSx86 Tools and use AppleAC97audio.kext)
 
** Used the Leo4Allv2 (10.5.2) extensions to fix most problems
 
* Onboard NIC (During Install: Ethernet - Broadcom - AppleBCM571) (No MAC Address but works fine)
 
* 2gb DDR2
 
* 250gb Sata HD
 
* NVIDIA GeForce 5200 using Kush
 
* Bootloader - Chameleon V2
 
* Kernel - 9.5.0 VooDoo (Appears as "Darwin" in System Profiler)
 
* Used GenericATA and ICHxxx fix
 
Shows up as 2.8 Intel Core Solo> Graphics
 
 
Another way:
 
* iPC 10.5.6 > iDeneb 10.5.8 Combo Update
 
** Install iPC 10.5.6, backup extensions and kernel, install iDeneb 10.5.8 Combo Update, reboot into safe boot (-x), restore extension and kernel, fix disk permissions, reboot and enjoy.
 
* Intel Pentium 4 @ 3.2GHz (showed as Core Solo in About this Mac)
 
* 80GB IDE/ATA HDD
 
* 1GB DDR RAM
 
* Nvidia GeForce FX 5200
 
** NVkush first, then CoreGraphics.framework afterward with pacifist.
 
*** Install them before Combo Update.
 
* The bootloader doesn't matter, but use Chameleon v2 if you want to.
 
* Voodoo 9.5.0 Kernel
 
* Go to [[HCL 10.5.6/Desktops]] for the fixes, because these fixes will still work after update process.
 
  
 
=== Dell Vostro 200 Slim Tower ===
 
=== Dell Vostro 200 Slim Tower ===
Line 268: Line 47:
 
* Sleep/power-down/reboot do not work - all hang
 
* Sleep/power-down/reboot do not work - all hang
 
* Was able to update to 10.5.7 using Software Update; only had to reinstall ALC888 driver and IONetworkingFamily fix
 
* Was able to update to 10.5.7 using Software Update; only had to reinstall ALC888 driver and IONetworkingFamily fix
* Was able to subsequently update to 10.5.8 using Software Update; as before, had to reinstall ALC888 driver and IONetworkingFamily fix and all is well
+
* Was able to subsequently update to 10.5.8 using Software Update; as before, had to reinstall ALC888 driver and IONetworkingFamily fix and all is well . . . . .
  
 
=== Dell Vostro 200 Slim Tower ===
 
=== Dell Vostro 200 Slim Tower ===
Line 280: Line 59:
 
*  Ditched the Radeon and bought a 35 USD WinFast GeForce PX8400 GS TDH All works but Quartz Extreme:Not Supported You need NVinject 0.2.0 for dual head  Not the Works with NVinject 0.2.1
 
*  Ditched the Radeon and bought a 35 USD WinFast GeForce PX8400 GS TDH All works but Quartz Extreme:Not Supported You need NVinject 0.2.0 for dual head  Not the Works with NVinject 0.2.1
 
* Was able to update to 10.5.8 using Software Update and you should
 
* Was able to update to 10.5.8 using Software Update and you should
  only had to reinstall ALC888 driver from the DVD iPC, easy... just locate it and double click
+
  only had to reinstall ALC888 driver from the DVD iPC, easy... just locate it and double click . .
* shut down not working it will restart... anyone has a suggestion about this?
+
* shut down not working it will restart... anyone has a suggestion about this? . . . . .
  
 
=== Packard Bell ===
 
=== Packard Bell ===
Line 305: Line 84:
 
Took a backup of all the kext files.
 
Took a backup of all the kext files.
 
Downloaded the iDeneb Combo upgrade 768 Mb. Installed it, copyed the backup kext files back. First restart run with the -v -f mode to make sure all kext files loaded.
 
Downloaded the iDeneb Combo upgrade 768 Mb. Installed it, copyed the backup kext files back. First restart run with the -v -f mode to make sure all kext files loaded.
Everything works.  
+
Everything works. . .
 
+
==Compaq Evo D510==
+
 
+
* iDeneb 10.5.8
+
* Kernel: Qoopz
+
* Video: None (resolution at 1024x768, cant change)
+
* Audio driver: AC97 (need to install from the net after install)
+
* Chipset: I installed all apart from SAS, SiliconMotion and Nvidia ones, dont know which one it needs, sorry!
+
* CD Drive: Works fine
+
* Ram: I have 2x1024mb sticks instsalled, works fine
+
* USB: Works fine
+
* Keyboard: I have the apple USB keyboard, no problems
+
* Network: I installed both the intel drivers, works fine, although you have to boot -f every time for it to work
+
* Bootloader: Chameleon v1.0.12 (Chameleon v2 refused to boot)
+
* Problems: Clicking 'About this mac' force logs you out to the login screen, losing any unsaved work. Apart from that, pretty good Hackintosh machine....
+
* Note: The seatbelt fix on the install DVD doesn't work, download and install this instead of it: http://rapidshare.com/files/272585439/seatbelt_1058.zip
+
 
+
== Shuttle ==
+
 
+
=== Shuttle XPC SN27P2 ===
+
 
+
==== Install Method: iDeneb Lite 10.5.8 ====
+
* BIOS: ?
+
* Board: NVIDIA MCP55 ULTRA
+
* Chipset: nForce 570 MCP
+
* Processor: AMD Athlon 64 3200+
+
* Audio: Realtek AC882  (Need patch)
+
* LAN: Marvell 88E1116 PHY aka nForceLan (Need patch)
+
* IDE: nForce (works)
+
* SATA: nForce (works)
+
* Wireless: No
+
* Firewire: ?
+
* Video Card: Nvidia 7300GS with 256Mb (Works with NVinject)
+
* RAM: 2GB Kingston DDR2 (2 modules)
+
* USB: nForce (works)
+
* bootloader: Chameleon 2
+
* Kernel: Qoopz 9.8.0
+
 
+
 
+
 
+
1) In Bios disable floppy disk and change the first boot to CD/DVD device
+
 
+
2) Insert the IDeneb Lite 10.5.8 in your device and restart your computer
+
 
+
3) Using the disk utility create two empty partitions the first with 20MB and the seconds with all capacity, format the second as Mac Os Extended (Journaled).
+
 
+
4) From installations options select Qoopz 9.8.0 as kernel, nforce chipset and nvinject (For my Nvidia 7300GS, but may be you must change this option depending of your graphic card)
+
 
+
5) Install IDeneb Lite
+
 
+
6) After install you network card, sound card and ACPI will do not work, you will need [http://www.mediafire.com/?8s948lp1jnl8iqr download some patches].
+
 
+
7) Unzip the patches in you Mac Os (You will need copy the files from other computer with Inet)
+
 
+
8) Run Kext Help application and drag the files AppleSMBIOS.kext and nForceLAN.kext to this application and press "EASY INSTALL" (This will fix your Network Card, some ACPI issues and the "About this Mac" restart problem)
+
 
+
9) Install the ALC882 AppleHDA v.0.4b.mpkg
+
 
+
10) Drag the file codec#0 to AppleHDAPatcherv1.20 (This two last steps will fix your ALC882 Sound Card issues)
+
 
+
11) Reboot computer, cross you fingers and prepare the champagne bottle
+
 
+
 
+
If you still have problems with your sound card, go to Systems Preferences -> Sound, and choose other output device.
+

Please note that all contributions to OSx86 may be edited, altered, or removed by other contributors. If you do not want your writing to be edited mercilessly, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource (see OSx86:Copyrights for details). Do not submit copyrighted work without permission!

Cancel | Editing help (opens in new window)
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers