HCL 10.7.4/Desktops

From OSx86
(Difference between revisions)
Jump to: navigation, search
(DELL)
(DELL)
Line 36: Line 36:
  
 
==DELL==
 
==DELL==
 +
===Optiplex 320===
 +
{| class="wikitable" width="100%"
 +
!Hardware Name 
 +
!Chipset
 +
!Notes
 +
!Patches Used
 +
!colspan="2"| 32/64bit working ''with'' patches
 +
|-
 +
|Dell Optiplex 320
 +
|ATI Express 200 Chipset
 +
|
 +
* Intel Core 2 Duo E4300 @ 1.96 Ghz
 +
* RAM: 1GB 533 Mhz DDR2
 +
* VGA : nVidia GeForce 8400 GS 1GB DDR3 (OnBoard ATI X1100 Not tested)
 +
* Audio : Voodoo HDA 2.7.2
 +
* Network: BCM440XEthernet.kext
 +
* Graphic: Working with QE/CI
 +
* Hard Disk : SATA works using ATIATA & ATIPATA kexts installed in /s/l/e/IOATA.kext/Contents/Plugins/
 +
* DVD : OOB
 +
* USB: Works using IOUSBFamily.kext rollback from Multibeast 4.6.1
 +
 +
In order to install on this machine, it's best to have a working Snow Leopard install to begin with because it requires a '''LOT''' of tweaking before your system will boot.  After several failed attempts at installing and upgrading I finally resorted to using Carbon Copy Cloner to clone my other desktop's 10.7.4 install onto the hard drive and then installed the necessary patches.  Patches include USB Rollback, PCI rollback, SATA kexts, VoodooHDA, BCM440XEthernet.kext.  Boot using rBoot -v -x for first boot after patching and run Repair Permissions from DiskUtil.  It will squawk about several drivers being the wrong versions or improperly installed EVERY time you repair permissions.  A weird little qwirk I found with this NIC is that it will fail to configure using DHCP if you have it's MAC addr assigned a static IP in your router.  Clear it's DHCP lease in your router and let it configure itself automatically the first time.  Then you can assign the MAC a static IP after first configuration.  It wouldn't hurt to erase /Library/Preferences/SystemConfiguration/* and clear all settings in the Network preferences pane the first time.  This tends to fix the "Device could not be verified" error in the App Store too.
 +
Also this is VERY IMPORTANT!!! DO NOT USE KERNEL CACHES.  I know it slows down boot time, but it will kernel panic EVERY TIME without fail if you use kernel caches.
 +
 +
Like I said, it's a pain getting 10.7.4 running properly on this computer, but worth the struggle in the end.  check my other thread on getting 10.6.8 installed for a good place to start [[HCL_10.6.8/Desktops#Dell_Optiplex_320_2]]
 +
|
 +
* IOPCIFamily 10.6.7 rollback and npci=0x3000 to bypass PCI CONFIGURATION BEGIN hang
 +
* IOUSBFamily rollback from Multibeast in order to get my wireless Mouse and Keyboard working (this computer has no PS/2 ports so this is pretty important)
 +
* Ethernet works with BCM440XEthernet.kext, but ONLY in 32 bit.  64 bit causes KP on boot.  Must use 'max_valid_dma_addr=1024' boot flag and 'EthernetBuiltIn=Yes' and Ethernet EFI String in org.chameleon.Boot.plist
 +
* Sound works ONLY in 32 bit with VoodooHDA.kext version 2.7.2 extracted from Nawcom's ModCD.  No other version I tried works properly
 +
* Vanilla Kernel.  no surprises there
 +
* Graphics work using Apple official NVDANV50Hal.kext after adding devID to info.plist '0x10c310de'.  I've had mixed results with this card on all three of my computers.  Works with custom EFI String using VGA on this Optiplex 320, but works OOB with just the devID using DVI on my P5KPL-AM EPU computer, and requires 'GraphicsEnabler=Yes' using HDMI on my G31M-S R2.0 computer.  YMMV
 +
* Boot handled by latest Chimera from Multibeast 4.6.1 'Easybeast'
 +
|Yes
 +
|Yes
 +
|-
 +
|}
 +
 
===Optiplex 330===
 
===Optiplex 330===
 
{| class="wikitable" width="100%"
 
{| class="wikitable" width="100%"

Revision as of 20:22, 11 July 2012

OS X 10.7.4
Hardware Compatibility

This is a hardware compatibility list ONLY for OEM desktop computers. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying a desktop. Don't forget to add how you got OSx86 running on your x86 desktop computer, and to use proper English. Please see the discussion page for proper instructions on how to input your system specs. Also, please contribute to the HCL 10.7.4 page, which should list a more granular view of compatibility. If your computer isn't listed, you should try it if you have a SSE2 or higher processor. Use vanilla kernel if it is supported.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.7.4 builds only.

Please list your computers in alphabetical order by manufacturer (Asus, Acer, Dell, HP, etc)

For how to edit the Wiki, please see this thread. Thank you!

Note: Please add whether your device supports QE, Quartz Extreme, graphics. Try playing a movie with Quicktime Player.

Contents

Acer

Acer Aspire m1640

QE
Icon Y.png
Type Component Working Notes
CPU Intel Pentium E2160 @1.80Ghz (Dual Core) Yes Natively supported
GPU Nvidia GeForce 8500GT 256MB Yes Add GraphicsEnabler=Yes into com.chameleon.Boot.plist and install NVEnabler64.kext (QE/CI:WORKING, MULTI-RES.:WORKING)
MOTHERBOARD ASUS P5QPL-AM Yes Native - Doesn't need DSDT
CHIPSET G41/ICH7 Yes Natively supported
SATA/IDE SATA/IDE Yes Natively supported (Lion was installed into an IDE Drive)
RAM 2GB DDR2 Yes Natively supported
ETHERNET Atheros AR8121/AR8113/AR8114 PCI-E Yes Install this package
AUDIO Realtek ALC887 6 Channels Yes Install VoodooHDA 0.2.56 from Multibeast
MIC Realtek ALC887 6 Channels Yes Install VoodooHDA 0.2.56 from Multibeast
CARD READER Integrated Card Reader Yes Natively supported
SLEEP Sleep Yes Natively supported
SPEEDSTEP SpeedStep Yes Add these positive strings: GeneratePStates, DropSSDT and CSTUsingSystemIO into org.chameleon.Boot.plist
KEXT Other essentials kexts / FakeSMC.kext, EvOReboot.kext, ApplePS2Controller.kext, AppleACPIPS2Nub.kext

DELL

Optiplex 320

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Dell Optiplex 320 ATI Express 200 Chipset
  • Intel Core 2 Duo E4300 @ 1.96 Ghz
  • RAM: 1GB 533 Mhz DDR2
  • VGA : nVidia GeForce 8400 GS 1GB DDR3 (OnBoard ATI X1100 Not tested)
  • Audio : Voodoo HDA 2.7.2
  • Network: BCM440XEthernet.kext
  • Graphic: Working with QE/CI
  • Hard Disk : SATA works using ATIATA & ATIPATA kexts installed in /s/l/e/IOATA.kext/Contents/Plugins/
  • DVD : OOB
  • USB: Works using IOUSBFamily.kext rollback from Multibeast 4.6.1

In order to install on this machine, it's best to have a working Snow Leopard install to begin with because it requires a LOT of tweaking before your system will boot. After several failed attempts at installing and upgrading I finally resorted to using Carbon Copy Cloner to clone my other desktop's 10.7.4 install onto the hard drive and then installed the necessary patches. Patches include USB Rollback, PCI rollback, SATA kexts, VoodooHDA, BCM440XEthernet.kext. Boot using rBoot -v -x for first boot after patching and run Repair Permissions from DiskUtil. It will squawk about several drivers being the wrong versions or improperly installed EVERY time you repair permissions. A weird little qwirk I found with this NIC is that it will fail to configure using DHCP if you have it's MAC addr assigned a static IP in your router. Clear it's DHCP lease in your router and let it configure itself automatically the first time. Then you can assign the MAC a static IP after first configuration. It wouldn't hurt to erase /Library/Preferences/SystemConfiguration/* and clear all settings in the Network preferences pane the first time. This tends to fix the "Device could not be verified" error in the App Store too. Also this is VERY IMPORTANT!!! DO NOT USE KERNEL CACHES. I know it slows down boot time, but it will kernel panic EVERY TIME without fail if you use kernel caches.

Like I said, it's a pain getting 10.7.4 running properly on this computer, but worth the struggle in the end. check my other thread on getting 10.6.8 installed for a good place to start HCL_10.6.8/Desktops#Dell_Optiplex_320_2

  • IOPCIFamily 10.6.7 rollback and npci=0x3000 to bypass PCI CONFIGURATION BEGIN hang
  • IOUSBFamily rollback from Multibeast in order to get my wireless Mouse and Keyboard working (this computer has no PS/2 ports so this is pretty important)
  • Ethernet works with BCM440XEthernet.kext, but ONLY in 32 bit. 64 bit causes KP on boot. Must use 'max_valid_dma_addr=1024' boot flag and 'EthernetBuiltIn=Yes' and Ethernet EFI String in org.chameleon.Boot.plist
  • Sound works ONLY in 32 bit with VoodooHDA.kext version 2.7.2 extracted from Nawcom's ModCD. No other version I tried works properly
  • Vanilla Kernel. no surprises there
  • Graphics work using Apple official NVDANV50Hal.kext after adding devID to info.plist '0x10c310de'. I've had mixed results with this card on all three of my computers. Works with custom EFI String using VGA on this Optiplex 320, but works OOB with just the devID using DVI on my P5KPL-AM EPU computer, and requires 'GraphicsEnabler=Yes' using HDMI on my G31M-S R2.0 computer. YMMV
  • Boot handled by latest Chimera from Multibeast 4.6.1 'Easybeast'
Yes Yes

Optiplex 330

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Dell Optiplex 330 Intel G31 Express chipset w/ ICH7R
  • Intel Core 2 Duo E7200 @ 2.53 Ghz
  • RAM: 4GB 800 Mhz DDR2
  • DVI : nVidia GeForce 6800 256MB (OnBoard video Intel GMA 3100 tested no QE/CI)
  • Audio : Voodoo HDA 2..62
  • Network: BCM5722D Kext
  • Graphic: Working with QE/CI after NVInject and NVEnablber Kexts
  • Hard Disk : SATA 80GB 7200 RPM HDD )
  • DVD : DVD+/-RW
  • USB: Working
  • BIOS : Set to Factory Defaults (Set to RAID for AHCI support)
  • Installed Software Updates
  • Installed Chameleon 2.62 RC5
Yes Yes
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers