HCL 10.8.1

From OSx86
Revision as of 16:13, 13 September 2012 by Poco (Talk | contribs)

Jump to: navigation, search

Contents

Motherboards

Asus

Hardware Name Chipset Notes Patches Used


P8Z68-M Pro Z68 System Configuration:
  • CPU: Intel Core i5 2400 @ 3.1GHz
  • GPU: ATI 6850 1024 MB
  • RAM: 2x4GB DDR3 G.SKILL CL9 RipjawsX
  • Keyboard: Apple Keyboard
  • Mouse: Logitech MX518

Components Status:

  • All works, sleep, wakeup, shutdown, restart, speedstep, USB3.0, HDMI

Install method:

Patches
  • Latest Chameleon Bootloader
  • Kexts (FakeSMC, LNX2Mac's Realtek RTL81xx for LAN, Kext for Realtek ALC892 and USB 3.0 3rd Party)
  • DSDT and SSDT, smbios.plist from iMac 12,2
  • Patched AICPUPM.kext (Lion 10.7.3) for Speedstep from InsanelyMac
  • Modded Bios for P8Z68-M Pro
P5Q Deluxe Intel P45 System Configuration:
  • CPU: Intel Q6600 CPU 2.34 GHz GHz Detected as Quad-Core Intel Xeon
  • Video: ATI Radeon HD 4870x2
  • Memory: 2x2 GB DDR2 800 MHz RAM
  • HDD: 500GB Seagate HDD
  • Triple-Boot - Mountain Lion, Windows, Ubuntu Linux

Installation:

  • Bios: stock 2301
  • SATA: AHCI in BIOS
  • Install Method via USB Drive: [10.8.0]
  • Patched DSDT.aml
Patches:
P8Z68-M Pro Z68 System Configuration:
  • CPU: Intel Core i5 2400 @ 3.1GHz
  • GPU: ATI 6850 1024 MB
  • RAM: 2x4GB DDR3 G.SKILL CL9 RipjawsX
  • Keyboard: Apple Keyboard
  • Mouse: Logitech MX518

Components Status:

  • All works, sleep, wakeup, shutdown, restart, speedstep, USB3.0, HDMI

Install method:

Patches
  • Latest Chameleon Bootloader
  • Kexts (FakeSMC, LNX2Mac's Realtek RTL81xx for LAN, Kext for Realtek ALC892 and USB 3.0 3rd Party)
  • DSDT and SSDT, smbios.plist from iMac 12,2
  • Patched AICPUPM.kext (Lion 10.7.3) for Speedstep from InsanelyMac
  • Modded Bios for P8Z68-M Pro
P7H55-M LE Intel H55 System Configuration:
  • CPU: Intel i3 530 CPU 2.93 GHz Detected as Intel Core i3 2,93 GHz
  • Video: Gainward GeForce GTS 450 1024MB GDDR5 (128bits)
  • Memory: 2x4 GB DDR3 1333GHz Kingstone
  • HDD: 750 GB
  • Wifi: TP-Link TL-WN851ND
  • Bluetooth: Sitecom 2.1

Installation:

  • SATA: AHCI in BIOS
  • Install Method via USB Drive: [10.8.0] (npci=0x3000)
  • Update the Mountain Lion using "Software update" to 10.8.1
Patches:
  • Sleep ans Speedstep: WORKS OOB
  • Audio: Voodoo 2.7.4 Mod.
  • Ethernet : AppleIntelE1000e
  • Wifi : AtherosAR9227 recognized as airport
  • Bluetooth : works
  • Appstore works
  • ICloud works
P5B Intel P965/ICH8 System Configuration:
  • Install method: App Store purchase. Then App Store Update to 1.8.1
  • CPU: Intel Q9650 3GHz Detected as Quad-Core Intel Xeon
  • Memory: Samsung M378T5663EH3-CF73E DDR2 666 MHz 4 x 2Gb, Dual-channel
  • HDD: SAMSUNG HD103SI 1TB SATA
  • Video: ASUS GeForce EN210 Silent 512Mb DDR3
  • Audio: Digidesign MBox2 Pro FireWire, Logitech HD Webcam C510 USB
  • Ethernet: Realtek® PCI-E Gigabit (onboard)
  • Webcam: Logitech HD Webcam C510
  • Bluetooth: D-Link DBT-122
  • Peripherals: Apple Keyboard A1243, Apple Trackpad A1339
  • PCI cards: ST-Lab FireWire Controller (TSB43AB23 chip), UAD-2 SOLO DSP
  • Shutdown: Yes
  • Restart: Yes
  • Sleep: Not tested
  • FaceTime/iCloud/App Store: working


Bootloader:

  • Chameleon v2.1svn r2035
  • SMBIOS: MacPro3,1
Patches:
  • BIOS: SATA in AHCI mode. Disable Serial and Parallel ports. Memory remap, ACPI 2.0, ACPI APIC options enabled.
  • Kexts: FakeSMC, RealtekRTL81xx
  • Kernel flags: npci=0x2000 GraphicsEnabler=Yes EthernetBuiltIn=Yes USBBusFix=Yes
P8Z77-V LE PLUS Intel Z77 System Configuration:
  • Sound = Onboard ALC889 Driver
  • Wireless = TP-LINK TL-WDN4800 (PCI-E)
  • Peripherals = Logitech Keyboard and Mouse MK300 on KVM switch; Asus DVD OEM Drive
  • Video = Radeon HD 6870
  • Processor = Core i7 3.4 GHz
  • Memory = Asus DDR3 4GB 1600 MHz x2
  • Storage = 120 GB Corsair Force 3 SSD Partitioned to 40 GB for Mac and 80 GB for future OS install;1TB 7200 RPM SATA HDD Slave
  • Sleep: A little clutchy, need more testing to confirm.
  • Shutdown:Successful
  • Restart: Successful
  • Facetime: Unconfirmed
  • Appstore: Successful
Patches:
  • BIOS: For Install, run video in iGPU and plug into the motherboard. After initial install, run with your video card. Everything else use the Optimized Mode (F5)
  • Kexts:Realtek ALC8.xx->ALC889 and Lnx2Mac's RealtekRTL81x Ethernet (Unnecessary for recognition, but a safe bet).
P5PL2-E Intel 945G/ICH7 System Configuration:
  • Install method: App Store purchase. Then App Store Update to 1.8.1.
  • CPU: Intel C2D E6400 2.13GHz (Overclocked to 2.33Ghz)
  • Memory: Corsair DDR2 667 MHz 2 x 1Gb, Dual-channel
  • HDD: WD5000AADS-00S9B0 500Gb SATA
  • Video: GeForce 9500 GT Silent 1024Mb
  • Audio: M-Audio ProFire 610 (via ST-Lab FireWire Controller vs TSB43AB23 chip)
  • Ethernet: Realtek® RTL8111B PCI-E Gigabit (onboard)
  • Bluetooth: D-Link DBT-122
  • Shutdown: Yes, Restart: Yes, Sleep: Not tested
  • FaceTime/iCloud/App Store: working


Bootloader:

  • Chameleon v2.1svn r2035
  • SMBIOS: MacPro3,1
Patches:
  • BIOS (v0601, 01/19/07): SATA in AHCI mode. Serial and Parallel ports - disabled. Microcode updation, Execute Disable Function, ACPI 2.0, ACPI APIC options - enabled. Enhanced C1 Control, Hyper Path 3, Dram Trolling Threshold, Suspend Mode options - Auto.
  • Kexts: FakeSMC, RealtekRTL81xx, IOPCIFamily (from www.osx86.net).
  • Kernel flags: GraphicsEnabler=Yes EthernetBuiltIn=Yes USBBusFix=Yes
  • If you forget enable Execute Disable Function in BIOS - mach_kernel boot will not start.
  • If you forget copy IOPCIFamily.kext to /S/L/E or /E/E - video will not work.

|-

|P8Z68-V Pro/Gen3 |Z68 |System Configuration:

  • CPU: Intel Core i7 2600K @ 3.4GHz
  • GPU: ATI HD6850 1024 MB
  • RAM: 4x2GB DDR3 G.SKILL
  • Keyboard: Logitech Keyboard
  • Mouse: Generic

Components Status:

  • All works, sleep, wakeup, shutdown, restart, speedstep, USB3.0, DVI1 and DisplayPort

Install method: |Patches

  • Latest Chameleon Bootloader
  • Kexts (FakeSMC, Intel Kext for LAN, Kext for Realtek ALC892 and USB 3.0 3rd Party)
  • NON-DSDT or SSDT
  • Speedstep only at 16 and 34
  • Modded Bios for P8Z68-V Pro/Gen3

\_

Intel

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Intel DG41RQ Intel G41 (LGA775) System configuration:
  • CPU: Intel Core 2 Duo E7500
  • GPU: XFX ATI Radeon HD 6450
  • HDA: Realtek ALC662
  • NIC: Realtek RTL8111D

BIOS Settings:

  • Load Default settings
  • Boot Device set to Legacy & SATA only
  • Enable UEFI Boot

Installation method:

  • Fresh Install of Retail ML 10.8.0
  • OS X Update 10.8.1 via AppStore

Working:

  • Shutdown/Reboot
  • Mac App Store
  • iCloud
  • DVD Player
  • VGA, HDMI, DVI-D

NOT Working:

  • Sleep/Wakeup
  • Patched DSDT (Fully Patched including GPU & SpeedStep)
  • Patched Pithecia Framebuffer
  • FakeSMC 4.0 Rev.617 [1]
  • Chimera 1.11.1 Bootloader
  • VoodooHDA 2.7.4 (Two personalities included for on-board audio and HDMI Audio)
  • RTL81xxx 0.0.90
Tick.png Tick.png

Gigabyte

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
GA-Z77X-UD5H rev1.0 Intel Z77 (LGA1155) System configuration:
  • CPU: Intel IvyBridge 3770K
  • GPU: Integrated Intel HD4000
  • RAM: Both Corsair and Kingston 16GB DD3 1600 1.5V (I have two computers set up.)
  • HDD: Intel 520 SSD 120 GB
  • Audio: Realtek ALC898
  • Network: Intel and Atheros
  • Peripherals: USB keyboards/mouse


BIOS Settings:

  • Load Default settings
  • Change SATA from IDE to AHCI. Intel Virtualization enabled.
  • Set Graphics to IGFX, Internal Graphics Memory Size to 64!!!! Do not use anything other than 64.
  • Reference: TonyMac Guide to Gigabyte 7 Series 1155 boards


Working:

  • Shutdown/Reboot
  • Mac App Store, iTunes Store, iCloud
  • Sleep / Wakeup using Power button, USB keyboards or mouse
  • All graphic ports work: Display Port, HDMI, VGA
  • All other ports working. For analog sound though, only orange and black analog outputs work for now.
  • Intel Speedstep
  • USB 3.0

Installation method:

  • Reference to follow TonyMac Unibeast Guide
  • WHEN BOOTING FIRST TIME, SET TO safe mode -x, and then install Multibeast.
  • For UniBeast, DO NOT check of EasyBeast. Choose UserDSDT or DSDT-Free Installation. And Choose Realtek Audio Driver 898 WITH DSDT (believe me).
  • Check off also BOTH Network Intel driver and Atheros drive
  • Check of TRIM for SSD drive
  • Check Hardware Monitors plugins

Works like a charm! Very fast and stable. Feels like a real Mac!

Tick.png Tick.png
GA-B75M-D3H rev1.0 Intel B75 (LGA1155) System configuration:
  • CPU: Intel Xeon E3-1275
  • GPU: Gigabyte HD 6850 OC
  • RAM: Kingston HyperX 16GB
  • HDD: Intel X-18m G1 80GB SSD
  • Audio: Realtek ALC887
  • Network: Realtek RTL81XX
  • Bluetooth: Digitus DN-30200 Broadcom chip - works OOB
  • Bluetooth: modded Apple A1181 Bluetooth Model + 3.3v voltage regulator (Cambride Sillicon Radio chip)
  • Peripherals: USB keyboards/mouse for installation. Apple mini wireless keyboards + Magic trackpad for normal use.


BIOS Settings:

  • Load Default settings
  • Change SATA from IDE to AHCI
  • Disable on board graphic card
  • Reference: Gigabyte UEFI guide


Working:

  • Shutdown/Reboot
  • Mac App Store
  • Sleep / Wakeup using Power button, USB keyboards or mouse (Digitus Bluetooth wakes computer up instantly -> disabled)
  • FULL Sleep / Wakeup through Bluetooth with modded Apple Module
  • AMD HD6850: two monitor works with: Display Port -> HDMI Adapter and DVI1. Did not try HDMI, DVI2 does not work.

NOT Working:

  • Intel Speedstep (see Patches)

NOT Tested:

  • iClound
  • VGA, HDMI, DVI-D (onboard - disabled)
  • USB 3.0 (recognised in Hardware Info but does not work with USB 2.0 devices)

Installation method:

  • Fresh Install of Retail ML 10.8.0 through Unibeast
  • Disable AMD HD6850 card during installation HD6XXX fix
  • Re-enable AMD HD6850 after installation using KextBeast
  • OS X Update 10.8.1 via AppStore
  • Post installation using Multibeast 5


Multibeast 5:

  • UserDSDT or DSDT-Free Installation.
  • Audio: ALC887/888b Without DSDT, Current
  • Network: Official Realtek 2.0.6
  • FakeSMC, Motherboard Plugins, Radeon Plugin, HWMonitor Application
  • Storage: IOAHCIBlockStorageInjector
  • Intel Speedstep fix: SSDT Intel Sandy Bridge core i7
Tick.png Tick.png
GA-Z68A-D3-B3 Intel Z68 System configuration:
  • CPU: Intel Core i5 2500K
  • GPU: MSI GT640 1Gb DDR3
  • HDA: Realtek ALC889
  • NIC: Realtek RTL8111E

Installation method:

  • Fresh Install of Retail 10.7.4 with Clover rev.611 (logon to iCloud and install FakeSMC)
  • OS X Update 10.8.1

Working:

  • Shutdown/Reboot
  • Mac App Store
  • iCloud
  • DVD Player
  • D-Sub, HDMI, DVI-D
  • Sleep/Wakeup
  • DSDT: HPET, TIMR, PWRB, HDEF, SBUS, LPCB, EHC1, EHC2 (Work and without patched DSDT, but need additional kexts (HDAEnabler))
  • SSDT with CPU states
  • FakeSMC 4.0 Rev.617
  • Clover rev.611
  • AppleHDA (3-port ALC889 from Sergey Galan)
  • RTL81xxx 0.0.90
Tick.png Tick.png
GA-EP45-UD3P Rev 1.6 P45/ICH10R

Components:

  • Intel Core2Quad Q6600
  • Samsung 1TB boot bunch more 1+500GB drives for other OSes
  • 8GB Gskill DDR2 800MHz
  • Nvidia 9800 GTX+
  • Pioneer DVD-RW
  • Jabra Bluetooth
Options selected:
  • JMicron
  • alc889a
  • Realtek (prob not even needed)
  • Chimera

Used this DSDT file (through multibeast) UD3P DSDT At this forum.

Tick.png Tick.png

MSI

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
P45 Neo3-FR P45 System configuration:
  • CPU: Intel Core 2 Duo E8500 (3.17 GHz)
  • GPU: Gigabyte NVIDIA Geforce GTX 560 1GB
  • HDA: Realtek ALC888
  • NIC: Realtek RTL8111D
  • Wifi: TP-Link WN851ND (PCI Card) - Chipset Atheros AR9227

BIOS Settings:

  • Load Optimized settings
  • Enabled AHCI+IDE on the JMicron ATA Controller

Installation method:

  • App Store 10.8.1 InstallESD.dmg
  • Kernel Flag: ncpi=0x3000 (or hangs during boot)
  • Unibeast USB Installation
  • OS X Update 10.8.1 via Apple Support
  • Copied NVDAGK100Hal.kext and NVDAResman.kext from the USB Mountain Lion image into /S/L/E after installing

Working:

  • Graphics: QE, full 3D acceleration, native resolution, VGA+DVI monitors detected correctly
  • Wi-fi: Airport Extreme
  • Audio: Working with Analog Inputs/Outputs (digital not tested)
  • Ethernet: Working

NOT Working:

  • Sleep/Wakeup not tested
Multibeast 5.0.2 Post-installation:
  • DSDT-Free Installation selected
  • Drivers -> Audio -> Realtek ALC8xx -> Without DSDT -> ALC 888 -> Legacy (ONLY!)
  • Network -> Lnx2Mac's RealtekRTL81xxx
  • System definitions -> iMac -> iMac 12,1
  • Chimera 1.11.1 Bootloader
  • FakeSMC

W-fi (TP-Link WN851ND):

  • Obtain this Atheros-patched IO80211Family.kext (10.7.4 version seems to work)
  • Add the device ID pci168c,2d to IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Contents/Info.plist
  • Install edited kext using kext utility and reboot with -f -v
Tick.png Tick.png

Graphics Cards

Please specify if your card is AGP, Integrated, PCI or PCI-E.
Also, place chip and board manufacturer in their respective column.

PCI-E

ATI

Model Board-Manufacturer Notes QE/CI Output Dual display 32/64bit working with patch
HD 4870x2 2048MB DDR5 Club 3D
  • Chameleon 2.1 svn2050; GraphicsEnabler=Yes; (PciRoot=1, but might be mobo specific)
  • Install 10.8.0 exotic driver pack from Netkas

This will already make it work with QE/CI, but card shows as Radeon 4800 and doesn't interface well with monitor. Therefore:

  • Install a recent ATY_init (mine was of May 2011, but couldn't find the link I used anymore...) to fix this

Card will show up as 4870x2 (1 core) and fully work!

Tick.png 2x DVI Tick.png Tick.png Tick.png
HD 5450 1024MB DDR3 Silent Asus
  • Chameleon 2.1 svn2030; GraphicsEnabler=No; Graphics Mode=1920x1080x32
  • Must modify info.plist in ATI5000Controller.kext extension, see [2] and modify info.plist in AMDRadeonAccelerator.kext [3]
Tick.png

DVI

Tick.png Tick.png Tick.png
Radeon HD 6450 2GB DDR3 XFX Worked OOB. (DSDT edit + Pithecia FB Patch) Tick.png
VGA Tick.png
HDMI Tick.png
DVI-D Tick.png
Tick.png Tick.png Tick.png

NVIDIA

Model Board-Manufacturer Notes QE/CI Output Dual display
GTX 660ti Asus Works OOB with GraphicsEnabler=No. ASUS GeForce GTX 660 Ti DirectCU, part # GTX660 TI-DC2-2GD5 Tick.png DVI/HDMI/Displayport Not tested
GTS 450 Gainward Works OOB with GraphicsEnabler=Yes. npci=0x3000 Tick.png DVI/HDMI/VGA Not tested
GT 640 MSI Works OOB with GraphicsEnabler=No. MSI GeForce GT640 1Gb DDR3, Part #: N640GT-MD1GD3 Tick.png D-Sub/DVI/HDMI Tick.png
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers