HCL 10.8 Seeds

From OSx86
Revision as of 20:05, 25 March 2012 by Redrat76 (Talk | contribs)

Jump to: navigation, search

This is a component level hardware compatibility list for pre-release versions of Apple's Mac OS X Mountain Lion. As this is not the final release, compatibility may change throughout the builds, so please, do not rely on this list when buying hardware. It is for those who wish to share/experiment with pre-release versions of the OS. Add which parts you have working in the categories listed below, or create a new category. Please keep alphabetical order inside the categories. The categories themselves are ordered by popularity. Please list any caveats or problems as well.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for pre-release 10.8 builds only.

For how to edit the Wiki, please see this thread. Thank you!

You're looking for an Installation guide? see here

Contents

Motherboards

Asus

Hardware Name Chipset Notes Patches Used
P7H55D-M EVO Intel H55 System:
  • CPU: Intel Core i5-650
  • Memory: Kingston DDR3-1333 2 x 2 GB
  • HDD: Samsung 500 GB SATA
  • Video: GeForce GT 9500 1024 MB
  • Audio: Realtek ALC889 onboard
  • Ethernet: Realtek Gigabit Ethernet onboard
  • Wireless: D-Link DWA-556 (recognized as AirPort)
  • Bluetooth: D-Link DBT-122
  • Shutdown: Yes
  • Restart: Yes
  • Sleep: Yes


Bootloader:

  • Chimera 1.8.0
  • SMBIOS iMac11,1 with new serial number to make iCloud and App Store work


Patches (using MultiBeast 4.2.1):
  • UserDSDT (used my custom DSDT)
  • FakeSMC
  • ALC8xxHDA
  • AppleHDA Rollback
  • Realtek Gigabit Ethernet
  • 3rd Party SATA

P5W DH Deluxe Intel 975X Intel ICH7R System Configuration:
  • Intel E6400 CPU 2,13 GHz @ Overclocking 2,67 GHz, FSB 1333 Mhz, BUS 333 Mhz
  • ATI Radeon X1800XT (256MB DDR3 256Bit) 32/64Bit Work All Resolution + Dual Display, No QE/CI
  • Kit DDR2 4GB (4x1) 800 MHz Ram OCZ Platinum
  • Install Method: RETAIL USB_Sata HD Image

Components Status:

  • Audio ALC882M Stereo Line-Out x3, Line-In x1, Integrated microphone x1, Headphones Integrated x1, S/PDIF out x1
  • Ethernet - Native Works (Marvell Yukon Gigabit)
  • Wireless RTL8187 b/g - Works (Native Patch REALTEK) [http://eurico.net/files/driver_wlan_usb_snow.zip
  • USB 2.0 - Native Work
  • USB 3.0 PCIe (LACIE) - Native Work "SUPER SPEED"
  • IDE - Natine Work
  • E-SATA 3GB - Natine Work
  • Shutdown/Reboot - Work (SleepEnabler)
Patches
  • "PRIVATE" kext edited by PIEROF81

Mainboard

Graphic Card

P5K SE/EPU P35/ICH9 System Configuration:
  • CPU: Intel Core 2 Duo E8400 @ 3.6GHz
  • GPU: GeForce 8800GT 512MB
  • RAM: 2x2GB DDR2 Kingston HyperX
  • ODD: Sony Optiarc AD-7243S SATA
  • Keyboard: USB
  • Mouse: USB

Components Status:

  • All works
Patches
P8Z68-M Pro Z68 System Configuration:
  • CPU: Intel Core i5 2400 @ 3.1GHz
  • GPU: ATI 6850 1024 MB
  • RAM: 2x4GB DDR3 G.SKILL CL9 RipjawsX
  • Keyboard: USB
  • Mouse: Logitech MX518

Components Status:

  • All works,sleep, wakeup, shutdown, restart, USB3.0 not tested

Install method:

Patches
  • Kexts (Lan, Sound and 3rdParty Driver) installed with Multibeast Lion edition
  • DSDT and SSDT
  • Patched AICPUPM.kext (Lion 10.7.3) for Speedstep from InsanelyMac
  • Modded Bios for P8Z68-M Pro
Asus P8H61 H61 System Configuration:
  • CPU: Intel i3 2100 @ 3.10GHz
  • GPU: Asus EN210 1GB DDR3
  • RAM: 8GB 1333MHz DDR3
  • ODD: LG HL-DT-ST SATA
  • Keyboard: USB
  • Mouse: Bluetooth

Components Status:

  • All works (Shutdown/Reboot Work)
  • Sleep not tested
Patches
Asus P8H61-M-LE H61 System Configuration:
  • CPU: Intel i7 2600 @ 3.40GHz
  • GPU: ATI Radeon HD 4890 1024MB
  • RAM: 8GB 1333MHz DDR3
  • ODD: HL-DT-ST DVDRAM GH22NS70
  • Keyboard: USB
  • Mouse: USB

Components Status:

  • OS X Detects System as MacPro3,1.
  • iCloud/Mac App Store works. (See Patches)
  • All works (Shutdown/Reboot Work)
  • Sleep DOES NOT WORK! Did not extract DSDT.
  • Audio untested. As I use an External USB interface for audio.

Install method: iAtkos L2. Then, Upgraded to 10.8. Using Chameleon 2.1v1880.(See Patches.)

Patches
  • Follow this tutorial for QE/CI for 48xx Tutorial
  • To get iCloud/Mac App Store/FaceTime/Messages to work, Follow this Tutorial
  • To Properly Upgrade to 10.8, Follow This Tutorial
  • Delete the AppleTyMCEDriver.kext from your /System/Library/Extensions/ folder To boot without kernel panics.
Asus Rampage II Gene Asus Rampage II Gene System Configuration:
  • CPU: Intel Core i7 920 @ 2.66 GHz
  • GPU: nvidia 260 896 MB
  • RAM: 12gig 6x2GB DDR3
  • Keyboard: Dell Bluetooth
  • Mouse: USB

Components Status:

  • All works,sleep, wakeup, shutdown, restart.

Install normal akeSMC.kext

  • Patched CPUPowermagment.kext

ECS

Hardware Name Chipset Notes Patches Used
ECS H67H2-M4 Intel H67 System:
  • CPU: Intel Core i3 2100
  • Memory: DDR3-1333 4 x 4 GB
  • HDD: Seagate 1 TB SATA
  • Video: GeForce GT 9600 512 MB
  • Audio: Realtek ALC892 onboard
  • Ethernet: Realtek Gigabit Ethernet onboard
  • Wireless: TP-Link WN781ND (recognized as AirPort)
  • Bluetooth: Generic Cambridge Silicon Chip
  • Shutdown: Yes
  • Restart: Yes
  • Sleep: Yes


Bootloader:

  • Chimera 1.8.0
  • SMBIOS iMac12,1


Patches :
  • Custom DSDT
  • FakeSMC
  • ALC8xxHDA
  • AppleHDA Rollback
  • Realtek Gigabit Ethernet - Lnx2mac
  • 3rd Party USB3 PXHCD.kext : super speed USB
  • All kext in S/L/E

Gigabyte

Hardware Name Chipset Notes Patches Used
GA-P31-DS3L Intel P31 ICH7 Hardware:
  • Intel Core2Duo
  • ATI HD5670

Notes:

  • Chameleon RC5 Trunk 1822
  • Retail install from 10.8. Everything works: Speedstep, Ethernet, Sleep, Audio, Graphics
Kexts
  • FakeSMC ver. 2.1 (IntelCPUMonitor, IntelThermal, SuperIOFamily)
  • AppleHDA [1]
  • ElliottForceLegacyRTC

Binpatched AppleRTC.kext to prevent CMOS reset.

THE DSDT, org.cham.boot, smbios [2]


GA-G41-MT D3V Intel G41 Hardware:
  • Intel Core 2 Duo E6850
  • Nvidia GTX 560 Ti
  • RT73 USB wireless card
  • Logitech G19 Keyboard
  • Cyborg RAT7 Mouse

Notes:

  • Chimera Bootloader 1.8.0 + Extra folder here: [3]
  • Retail install from 10.8. Everything works: Speedstep, Ethernet, Audio, Graphics. Sleep not tested but should work.
Kexts
  • FakeSMC
  • NullCPUPowerManagement
  • AppleHDA patch + ALC889 enabler [4]
  • RT73USBWirelessDriver
  • RealtekRTL81xx
  • Graphics with GTX 560 Ti works OOB with just GraphicsEnabler=Yes and npci=0x2000
  • USB Overdrive used to make mouse work properly (very messed up without it)
  • Ukelele used to edit keyboard layout

Used DSDT: [5]


GA P55-UD4 Intel P55 + ICH7 Hardware:
  • i5 processor
  • GTS 450 video card

Notes:

  • Chameleon trunk 1820
  • Retail install 10.8
  • System works OOB after booting with UseKernelCache=no, just drivers for audio and network.
Kexts
  • FakeSMC
  • AppleHDA ALC889A, LegacyHDA, HDAEnabler
  • Lnx2mac
  • UseKernelCache=no


GA P41T-D3P Intel® G41 + ICH7 Chipset Hardware:
  • Intel Core2QuadQ9550 2.83 GHz.
  • EVGA Nvidea 9800GTX.

Notes:

  • Chameleon RC5 Trunk 1820
  • Retail install from 10.8. Everything works: Speedstep, Audio, Graphics, Wifi antenna, Ethernet
  • SMBIOS Mac Pro 3.1
Kexts
  • FakeSMC
  • AppleHDA AlC889 internal and Creative Audigy 4Pro internal/External.(MultiBeast 4.2.1,ALC 8xx, Apple HDA Rollback, HDA Enabler 889 / Kxproject)
GA X58A-UD7 Intel® ICH10 Chipset Hardware:
  • Intel Core i7 920
  • Sapphire 5770.

Notes:

  • Chameleon RC5 Trunk 1822
  • Install from Appstore 10.8. Everything works: Speedstep, Audio, Graphics, Ethernet
  • SMBIOS Mac Pro
Kexts
  • FakeSMC
  • AppleHDA
  • RealtekR1000SL

Tutorial: Video Tutorial

GA X58A-UD3R Intel® ICH10R Chipset Hardware:
  • Intel Core i7 950 @3.07 GHz
  • Sapphire 5850.

Notes:

  • Chameleon RC5 Trunk 1822
  • SMBIOS Mac Pro 5,1
  • Delete from S/L/E AppleIntelCPUPowerManagement.kext (it get a kernel panic during ML installation)
Kexts
  • FakeSMC
  • RealtekRTL81xx
  • ApplePS/2
  • JMicron36xSATA

Tutorial: visit Guide

GA EP-35C-DS3R Rev 2.1 Intel® P35+ICH9R Hardware:
  • Core2Duo E8400 processor
  • 2x4GB RAM DDR3 1333MHz Kingston
  • Sapphire Vapor-X HD 5770 1024MB DDR5

Notes:

  • Chameleon Andy RC5 r755
  • Retail install 10.8 using xMove method
  • System works OOB , just drivers for audio and network.
  • GraphicsEnabler=Y
  • SMBIOS Mac Pro 3.1
  • All works except sleep
Kexts
  • FakeSMC
  • AppleHDA ALC889A, LegacyHDA, HDAEnabler
  • Lnx2mac


Intel

Hardware Name Chipset Notes Patches Used


Intel DH55HC H55 System Configuration:
  • CPU: Intel core i3 540 @ 3.07GHz
  • GPU: Zotac GeForce 8400GS 512MB DDR3
  • RAM: 2x2GB DDR3 1333MHz Kingston
  • ODD: LG GH22NS30
  • Keyboard: USB
  • Mouse: USB

Functionality:

  • All works well (onboard sound - not tested as I use a Creative SoundBlaster USB soundcard)
  • installed to a 500GB laptop drive (5400rpm) so performance is somewhat slow but certainly good enough to test Mountain Lion
  • Zotac GeForce 8400GS works OOB with graphics enabler=yes. Tested HDMI only, resolution at 2048x1152
  • As with Lion, at shutdown, the OS shuts down, but the computer stays running (seems to be a problem with Intel boards)
  • Followed tutorial Here
  • FakeSMC.kext
  • NullCPUPowerManagement.kext
  • SMBIOS Mac Pro 3.1
  • Used Multibeast for Lion to install Intel network
DX58SO Intel X58 System Configuration:
  • CPU: Intel core i7 950 3.01GHz
  • GPU: Radeon Sapphire 5770 Vapour-x 1GB DDR5 (Works with GE = YES or NO)
  • RAM: 6GB DDR3 1333MHz
  • Wifi- DLink DWA 125 (Ralink Driver)
  • Retail Install
  • BootLoader : Chamaleon 2.1 RC5 r1820
  • SMBIOS: MacPro 4.1

Boot Flags:

  • GraphicsEnable=Yes
  • GeneratePStates=Yes
  • GenerateCStates=Yes
  • KernelCache=Yes


Kexts:

S/L/E

  • FakeSmc
  • AppleHDA(patched)
  • AppleIntel8256X
  • Legacy889HDA


Functionality:

  • Everything works flawless. Video, Audio, Lan , Firewire, Wifi
  • Power Management works with no Kext.
  • Shutdown and Sleep works with no Kext.
  • Geekbench: 11.000 aprox.
  • Cinebench: 6 aprox.
  • GPU 37 Fps


VIDEO DEMO

Patches
  • DsdtAutoPatcher link

Graphics Cards

Please specify if your card is AGP, Integrated, PCI or PCI-E.
Also, place chip and board manufacturer in their respective column.

ATI

Model Board-Manufacturer Notes QE Output Dual display 32/64bit working with patch
HD5450 512MB DDR2 Sapphire GraphicsEnabler=Yes, install ATI5000Injector.kext with Kext Utility, repair permissions, reboot. Tick.png Tested Vga / Hdmi ? Tick.png Tick.png
HD 5770 1024MB DDR5 Vapor-X Sapphire Work OOB with GraphicsEnabler=Yes Tick.png DVI/HDMI Tested Tick.png Tick.png Tick.png
X1800XT 256MB DDR3 256BIT MSI All work of the resolution (the same goes for X1300, X1600 and X1900! Sovrascrivento simply these kext with the application KextHelper. http://hotfile.com/dl/147794828/fdb76d5/OS_X_10.8_ATI_x1xxx_Pierof81.zip.html Cross.png DVI/DVI Tick.png Tick.png Tick.png
HD 4650 512MB DDR2 MSI Work with device id in ATI4600 & ATIX200 kext Tick.png VGA Tested Tick.png Tick.png Tick.png

NVIDIA

Model Board-Manufacturer Notes QE Output Dual display 32/64bit working with patch
8800gts 512(g92 chip) ASUS Works with nvenabler.kext.Just write to info.plist in the iopcimatch string your device ID.Don't forget to repair kext permission after this!! Tick.png DVI/DVI not tested Yes yes(just put nvenabler64.kext)
8400 GS 512GB DDR3 Zotac works OOB with GraphicsEnabler=Yes Tick.png tested HDMI only Not Tested ? ?
GTS 450 Gigabyte Works out-of-box, even without GraphicsEnabler Tick.png DVI tested ? Not tested Not tested
EN210 SILENT/DI/1GD3/V2(LP) Asus Works OOB with GraphicsEnabler=Yes Tick.png DVI Tested Not Tested Not Tested Not Tested
GTX 260 (1792 MB) OEM HP Works OOB with GraphicsEnabler=Yes Tick.png DVI Tested Not Tested Not Tested Not Tested
GTX 560 Ti Club 3D Works OOB with GraphicsEnabler=Yes Tick.png DVI Tested Not Tested Not Tested Not Tested

Network Cards

Wireless

Interface Standard Device Manufacturer Chipset Notes 32/64bit working with patch
Yes Yes
USB b/g/n DWA-125 D-Link Ralink Works with Ralink's installer (RT2870) Download here. Tick.png Tick.png

Wired (Ethernet)

Interface Standard Device Manufacturer Notes 32/64bit working with patch
Yes Yes

Sound Cards

Interface Hardware Name Manufacturer Notes 32/64bit working with patch
USB Sound Blaster X-Fi Go! PRO USB Sound Card Creative Labs Plug'n'Play, no configuration required Tick.png Tick.png

Other Accessories

Type of Accessory Item Description Manufacturer Notes 32/64bit working with patch
Yes Yes
Powered by MediaWiki © 2015 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki  |   PHP hosting by CatN  |   Designed by Ed Gain   |   Privacy policy   |   About OSx86   |   Disclaimers