Talk:Install On A Partition Simple And Accurate

From OSx86
Jump to: navigation, search
Please do not use this page to ask for help or information.
This wiki is meant as a source for OSx86 information. Any questions about OSx86 itself should be posted on the forum. All entries on this Talk page should be related to the formatting and/or editing of the article. Thanks for helping to clean up the wiki.

I wonder if we don't need rootnoverify instead of root in the grub.conf file.


[edit] Grub HFS+ Error

[edit] My problem

This doesn't work on my system. The reboot fails with grub complaining about a "HFS+ partition Error". I dd as indicated in the article, skipping the 63 first blocks of 512 bytes.

Strangely enough, I can mount the OS X partition, and the mount command does not complain about this "HFS+ error". The mounted partition works perfectly.

I've also set the flag "bootablCKJSDBcnakhsdbksh dvnjs hedcb njhe bdwed

I tried both root/rootnoverify. Not better.

My secondary disk is as follow:

 Name        Flags      Part Type  FS Type          [Label]        Size (MB)
  hdc1                    Primary   Solaris boot                       518.20
  hdc2                    Primary   W95 FAT32                         1998.75
  hdc3        Boot        Primary   Unknown (AF)                      7427.43
  hdc5                    Logical   Linux LVM                        10479.01
  hdc6                    Logical   Linux LVM                        10479.01
  hdc7                    Logical   Linux swap / Solaris              1571.03
  hdc8                    Logical   Linux raid autodetect             5239.51
                          Logical   Free Space                       85806.13

Any ideas or suggestions? -- User:rds


Yes, see below (last)-- "logical drive--pertaining other oses" about using the boot cd..

In my case it worked by running fdisk under Linux and then to change the partition type to af - (this wasn't set)

[edit] Check Grub is installed properly

try using " Even Easier Boot" method else, make sure you install grub where it should be installed if you get the boot selection then grub is properly installed. if not, its not.. :) you need a small 50meg partition (for example) in ext2 (example again) to install grub on linux, or on windows i guess it work s with ntfs or fat. prolly it doesnt if u install directly on hfs(+)

Unfortunately, Grub is installed correctly, I boot on linux every day ;-)

[edit] Must be primary partition

Same problem. But i have noticed, that when partition type is 0xAF (Not darwin boot 0xab), there is another error message: Error loading booter. In the original .img file there is 0xaf type is set. May be the partition must be PRIMARY? (I was trying to install it on hda6). Will try hda2 soon. (Sorry for my english). -- User:gloomy

Good point, my partition is of logical type. -- User:rds Yes, it works. Must be primary partition with 0xaf type. But now it halts while gray screen appears... :( -- User:gloomy

[edit] Discussion continues

I also get the HFS+ error. Does anyone have a solution for this? -- User:barretj Is it primary partition? Is the type of partition is 0xaf? Works for me now. -- User:gloomy

I have three partitions, 1 OEM (made by Dell) that is 55 megs, the main Windows NTFS partition at 50 gigs, and i made the AF type partition and made SURE it's marked as primary and I followed all the instructions, but it still says HFS+ partition error. what am i doing wrong? please help!! : | --user: sheikhmango

[edit] The proper Grub options

Ok, after spending some time with a trial and error approach, I finally decided to read the fine manual of Grub. Here are my conclusions:

  • rootnoverify does not help over root
  • the option chainloader --force sounds interesting.

I have updated the main article, because it works for me now. Mac OS X is pretty nice. It is pretty slow, also. (And just for the story, my keyboard was not detected on PS/2 but no probs on USB.)

Plz post a working GRUB configuration

[edit] Problems

I also get the HFS+ partition error. My hard drive is set up as follows:

  Name        Flags      Part Type  FS Type          [Label]        Size (MB)
   sda1                    Primary   NTFS             [^A]            15726.74
   sda2                    Primary   NTFS             [^A]            15726.74
   sda3        Boot        Primary   Unknown (AF)                     15726.74
   sda5                    Logical   Linux swap / Solaris               781.41
   sda6                    Logical   Linux ext3                       12905.47
   sda7                    Logical   Linux ext3                       19132.01

I really have no idea what I'm doing wrong. Help a complete newbie here? --Squirt 20:09, 24 January 2007 (CST)

[edit] Partition size

Is there a way to get the exact partition size to create? We are using the same tiger-x86-flat.img aren't we? -- User:foouser

Yes we are. I did not think about it yet. I have just running it!!! :) There are a lot of another problems. I just playing with it, not work in it. :) PPC emulation not working... Sad. I have not SSE3 on my notebook. :( Hint: if something halts during boot, add -v 6 parameter to kextd call in /etc/rc in single mode and see what it is (loading with -v of couse). In my case it was ACPI and Firewire modules. Just remove it. Sorry for my english egain. :) -- User:gloomy

[edit] Still waiting for root drive error

[asdorel's problem] OSX stalls at the grey loading screen. Enabling -v mode, osx outputs "Still waiting for root drive". Please help :(

[tom's problem] I think I'm getting the same error (Still waiting for root device). I have a P4 2.8 GHz with SSE3 on a Asus P4S800 mainboard. I also tried booting with rd=disk0s1 -v at the boot prompt.

[mike's problem] Hey Tom I also have the same problem on the same MOBO with a Celeron D with SSE3...

[Roofus's problem] I think I have the same problem it says waiting for root hub (I am thinking that is USB?) AMD64 3000+, ABIT AV8
tom: I also have something like this, but when I deactivate USB in the BIOS, it only says "Still waiting for root device" every 5 minutes or so.

[def's problem] I'm getting almost the same error: OSX stalls at grey screen, in -v mode it stops at the line: 'BSD root: disk0s2, major 14, minor 2' Anybody know what this means?

['s problem] I'm have same message after booting from DVD. Configuration - Asrock P4Dual 915GL, Celeron D, Toshiba DVD-ROM SD-M1912. I found in internet this: "If you do get text in verbose mode, then note any error messages, and note what the last messages are before the process grinds to a halt. If the last messages are a repeated "Still waiting for root device", then it means that Mac OS X is having some trouble with your CD-ROM device."

[Lino's problem] I'm having the same problem as every one of you! I think if happens because o my Promise RAID 2+0 Devise. Isn't it possible that it's just not suported? Even Windows XP asks for that type of driver right? With our without de array 2+0!!! Send help!!

[vtechstu's problem] Same thing here guys. Has anyone found a fix/solution to this? My same set supposedly works according to the list.

[koriakine] I solved this like this: whore correct memory_size=0x20000000 and prom_env_machargs = "" works well, before was this damn error

[edit] output block size can be bigger

Most people does not read man for dd, but those who read know that much faster copying can be done in such way:

 dd if=tiger-x86-flat.img of=/dev/hda2 ibs=512 skip=63 obs=1M


I dont think that the command above would be much faster, if i read the dd's manual well, the read buffer is still 512 Bytes... --User:wharever

you can do the following:

dd if=tiger-x86-flat.img of=/dev/hda2 ibs=32256 skip=1 obs=1M

(32256 = 512*63) i was able to speedup the process about 75%


Does the above DD still skip the first 63 bytes? -- Mike Mike, It does still skip the first 63 bytes

--anon I think that you mean 63 blocks :-)

[edit] Size of Partition

So with using this method. Are you then able to specify a partition bigger than the 6 gig image?

As far as i can tell: No. The closest i can get using dd to copy is using the method described in this thread.

Using the method described in the link in OSx i see a partition with a capacity that matches the actual partition size. However there is still a problem, disk utility shows the partition like this:

Capacity :  14.3 GB 
Available: 102.7 MB 
Used:        3.9 GB

Which is of course not correct. I haven't been able to fix this(tried fsck, disk utility and some other things) but i feel it should not be really hard to fix. Anyone have an idea how to fix this?

[edit] Marklar-Tiger.iso != tiger-x86-flat.img?

I'm confused. Is "Marklar's" release just the DVD with patches or is it an complete installation ready to mount? I only have the Marjklar release. Is it possible to do a simple installation w/o VMWare / PearPC using this image?

The Marklar-Tiger.iso is the DVD which allows you to install OS X on approved Apple Intel x86 systems.

So one used hacked versions of some key files and installed it and made a VMWare Hard Disk image. The tiger-x86-flat.img could be extracted to a hard drive. Then you could place the Hard drive into a x86 system and boot into OS X.

Ok, thanks. Got it :)

Also, "Marklar" isnt' a person; Marklar was Apple's codename for the Mac OS X on Intel project. It was rumored way back in 2002: :)

[edit] Block size when copying the image file

wrote: Correct me if i am wrong but i think using bs=8192 instead of bs=512 will speed things up while copying --

If you change the bs, then the skip parameter will have a totaly different meaning, since skip is expressed in blocks and bs gives the block size. I have not tested, but I am pretty sure that your partitopn will not be a correctly formated filesystem if you don(t skee p exactly 63*512 bytes. -- User:rds

Will this work with a SATA drive

[edit] Copying Image To Partition

I had the CMD window open for like a half hour and nothing happend, does it really take that long?

C:\Documents and Settings\Michael\Desktop\OSx86>dd if=tiger-x86-flat.img of=\\?\Device\Harddisk0\Partition2 bs=512 skip=63
rawwrite dd for windows version 0.3.
Written by John Newbigin <[email protected]>
This program is covered by the GPL.  See copying.txt for details

Nothing else after that...

COMMENT: In the windows version of dd you can add the switch --progress. Then you will see a progress indicator.

so your commandline should look like this:

dd if=tiger-x86-flat.img of=\\?\Device\Harddisk0\Partition2 bs=512 skip=63 --progress

[edit] are you sure boys?

really ? would the mac change the bootloader or anything else so that i cant log in winxp never again?

You don't actually INSTALL OSX, you only COPY an image over to the partition. Therefore, your MBR (and thus bootup stuff) is not changed. Your PC will still boot via the Windows partition since that partition is still the active partition. And even IF it WOULD be changed (which it won't be using this method, 100%) you can simply change the active partition with FDISK from DOS or whatever. Just add the C:\chain0 = "Mac OS X" entry to your boot.ini file to boot OSX.

[edit] Can I use PartitionMagic to make a partition?

I don't want to destory my Windows XP installation, so I wan't to make a new partition for mac at the end of disk. How can i do it?

Yes you can, I used PartitionMagic Version 8.0 to create a 6.5GB partition at the end of my drive for OSx86.

thanks a lot

What type of partitian did you make. Does Partitian Magic have option for HFS+

[edit] would the mac x86 destory the MBR or boot loader?

i heard someone cant turn off his pc in mac and he cant boot into xp now whats the matter and how to fix it?

i had that error the first boot in osx86 was ok dual boot ok but after the 2nd boot in osx86 and some exploration on xp partition the computer failed to start i had to boot from xp cd and delete the partition osx86 with command diskpart for recovering xp booting. maybe due to 2 partitions actives in same time... don't know.

If you screw up your XP boot.ini just put your XP CD back in on reboot and go into recovery. use commands FIXMBR FIXBOOT, however you won't be able to boot back into OSx86

[edit] my ethernet doesn't work

I can't get my ethernet to work. It detects my firewire but not my builtin-ethernet any ideas?

[edit] I get a kdp_poll error

What should I do?

Make sure you've installed OSX on the first partition on the primary master drive!

[edit] Using Diskpart To Create HFS+

I followed the guide to the letter typing in "create partition primary id=af", but when I use diskpart to create the partition, instead of getting an unknown partition, I get a primary partition and it shows up as an unformatted drive in my computer. Is there another windows utility that will create HFS+ or is there a way to get diskpart to work?

Diskpart won't create an HFS+ in windows it is just used to create a suitable partition so you can dd an image to it.

[edit] Error loading operating system with two partitions

Using the method outlined involving diskpart and dd, i successfully placed osx on my HD with a Windows XP dual boot. I used the windows bootloader to allow me to switch between operating systems. This lasted through the weekend. however late sunday, I began to receive the "error loading operating system" message upon loading Windows. Has anyone else received that? I used the recovery discs to solve the windows problem. I am just hesitant to do that again if that is the inevitable outcome. Has anyone else experienced that (assuming they are dualbooting on multiple partitions)?

Update - This appears to be caused by enabling hibernate mode for my notebook with Windows XP. After disabling macdrive, I was able to place Windows XP in hibernate mode. As the computer shut down, it may have altered the MBR or another important aspect of the partition to give the error message.

[edit] Added 2000 Diskpart

I just added the Win2k MS Diskpart. You can find it here:

The syntax is the same, I think. There might be a few small differences, but nothing affecting this tutorial. Feel free to correct it.

[edit] Very slow loading

Hi, using win2k bootloader it boots perfectly but after that it is VERY SLOW during the loading process.How can I do? Thanks.

Hardware: Acer Ferrari 4005 Wlmi..Turion 64(sse2+sse3 support) 2Ghz 1Gb DDR333 Ati x700 PCIe

[edit] stuffit expander causes .img file to be 2 GB

I know the article says to use WinRAR, but I already had Stuffit installed. Should a strong warning against stuffit expander be included in the appropriate section?

[edit] boot onto logical drive -- pertain the other oses

I'm waiting for a clean bootloader. I have used the patched Marklar installer (ppf'ed). I backed up my mbr before I installed it natively. After the install, I repaired my mbr.

steps: Prestuff--like make partition and of type 0xaf, at least 7-8 gigs. This is what I did- upon install, i went to a termbox and issued new "newfs_hfs" with -J (journaled) and -s (case-sensitive filenames). I already set and spaced a partition for this install previously with linux and cfdisk. I then continued in the gui with the installer-- but I think I had to reboot after issuing anyways-- once you're ready to install Macos, you shouldn't have trouble installing it to this hfs partition--(one problem it does is that it damages the windows-style and linux-style of partition table-- sector 0 of the hardrive so back up your partition table)

After rebooting, I repaired the mbr because somehow the installer corrupts this-- this is important to repair if you boot into windows or linux. (the corruption doesn't go too far-- it overwrites the first xx sectors and perhaps others but only at the start of the drive and before the first partition with windows, so it's safe). To boot into the far partition-- (this was on a logical drive)--> I use the installer cd and at the prompt (f8), I type :mach_kernel rd=disk0s8 (in my case it was disk0s8, you can find yours with the mount cmd in termbox while in mac installer).

I'm still trying to see how I can boot off the mach_kernel from the logical drive, which I've never been able to do.


I had the same problem, and here's how I solved it:

    Part 1 (primary) 512 M FAT    empty
    Part 2 (primary) 16 gb NTFS   WinXP
    Part3 (primary) 16gb EXT3      LInux
    Part 4 (Primary)
    Part 5 (Logical)  16 gb HPFS+  OSX86  active
    Copy file chain0 to C:/
    Make sure only partition 5 is active
    Boot Linux
    Edit /boot/grub/grub.conf to look like this:
    title Fedora Core (2.6.9-1.667)
         root (hd0,2)
         kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/
         initrd /boot/initrd-2.6.9-1.667.img
    title Windows XP
         rootnoverify (hd0,0)
         chainloader +1
    title OSX86
         chainloader (hd0,0)/chain0

Install with: grub-install /dev/hda that's it

[edit] Legal Disclaimer

There is a legal disclaimer at the top that says this is not to be used for illegal torrents, but for legal images only... and then the article proceeds how to install with deadmoo's image. Thoughts?

[edit] Booting from external HDD

Well, here I am. What I intend to do is to put the Image-File onto my external HDD, so that I can use the BIOS to select the boot device. In this way, I wouldn't have to manipulate (and endanger) my internal HDD's installation. Furthermore I would like to keep the data stored on the external HDD so far. So I resized the data partition on my ext.HDD using PMagic in order to free some space for OSX. Then, I created a new primary partition in that free space and I DDed the tiger-x86-flat.img to that partition, skipping the first 63 bytes. Now, of course,the BIOS won't boot from the external drive as there is no bootsector in the first partition. My question: (how) is it possible, to dd the image to my external HDD's primary partition _including_ the bootsector but _without_ the partition table (to preserve the existing partition structure)? If that does not work: Can grub boot from external HDDs? . .

[edit] Simple Solution for HFS+ Partition Error

i`ve had the problem of HFS+ partition error whit grub boot loader. to correct it i just simple change my boot loader from grub to LILO and add the correct entry for the Mac OS X partition when i restar it and select mac os x from the lilo boot menu it runs. i found this simple and efective.

[edit] Partition must be made active

For me with a current Linux neither grub nor LILO worked. Os X boots fine when the partition is marked active. So I use grub, install it in the root partition and have the following entry for OS X (assumed that the OSes are on primary partitions in the order Windows, OS X, Linux:

    title MacOS X
         rootnoverify (hd0,1)
         chainloader (hd0,1)+1

or alternatively

    title MacOS X
         rootnoverify (hd0,1)
         chainloader (hd0,2)/boot/OSX/chain0

where the additional chain loader files are stored under /boot/OSX in the Linux root partition.

Hope it helps...

-- anon

This page was last modified on 29 April 2008, at 11:02.
This page has been accessed 79,193 times.
Powered by MediaWiki © 2022 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki   |   Privacy policy   |   About OSx86   |   Disclaimers