HCL 10.4.9

From OSx86
Revision as of 05:04, 29 March 2007 by PANIC (Talk | contribs)

Jump to: navigation, search

This is a component level hardware compatibility list. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying hardware. Add which parts you have working in the categories listed below, or create a new category. Please keep alphabetical order inside the categories. The categories themselves are ordered by popularity. Please list any caveats or problems as well.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.4.9 builds only.

Contents

Motherboards

A comprehensive list of possible Intel chipsets

PLEASE INCLUDE THE SOUTH BRIDGE TOO

AMD


Abit

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

AsRock

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Asus

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

DFI

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

ECS

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Foxconn

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Gigabyte

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

MSI

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

PC Chips

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Intel


Abit

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Albatron

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

AsRock

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Asus

Hardware Name (socket type) Chipset Notes Fully working without patching
P4P800 VM

ASUS Page

Intel 865G GMCH / ICH5 Everything seems to works smoothly, SATA, network, USB. Audio works stereo, but output jack is mic in by default!
  1. To fix that (to change it back to the line out) you must modify the file '/System/Library/Extensions/AppleAC97Audio.kext/Contents/PlugIns/AppleAC97CodecAD198x.kext/Contents/Info.plist'
    1. Find the line with <string>ADS75 ADS74 ADS73 ADS72</string>
    2. Change it with <string>ADS75 ADS74 ADS73 ADS72 ADS70</string>
    3. The next step is to load the AppleAC97CodecAD198x.kext

With the 10.4.6 myz install disc + jaz 10.4.7 update: video with VESA 3.0 driver, no CI, no QE (no kext load, not even if editing the 830.kext). Recognized as an ADP2,1 (development platform).

Yes

Biostar

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

ECS

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Epox

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Gigabyte

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Intel

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Iwill

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

PC Chips

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder

Tyan

Hardware Name (socket type) Chipset Notes Fully working without patching
Place holder Place holder Place holder
  • Place holder
Place holder


Processors

AMD

Model Notes Recognized as Full Work / No Patch
Place Holder Place Holder Place Holder Place Holder

Intel

Model Notes Recognized as Full Work / No Patch
Celeron D 325 Used JaS 10.4.8 SSE2 SSE3 reseed w/Semtex 8.8.1 + JaS 10.4.9 SSE3 patch w/Semtex 8.9.1, it didn't worked well right away (choopy sound and slower GUI) but I set the com.apple.info.plist "<key> Kernel Flags </key>" entry with "<string>fsb=133</string>" and everything went smoothly! Intel Core Solo 2.53 Ghz (right speed) Yes / See Notes


Graphics Cards

Please specify if your card is AGP, PCI or PCI-E.
Also, place chip and board manufacturer in their respective column.

Note: For NVidia users, visit http://www.macvidia.org/ for updated drivers. For NVIDIA CARDS PLEASE SPECIFY IF THE CARD DOES QE/CI. Saying the macvidia drivers work but not specifying QE or CI is a bit misleading. If you are using the new kernel then download the Titan kext from http://omni.starchaser.org/titan/ to get QE/CI support

Note:These instructions may confuse noobs as they are a bit out of date. As far as i know, the MacVidia drivers do NOT support QE/CI AT ALL. You can use the kexts that come with your OSx86, or the ones from the 10.4.8 Intel update with your card. You may need to replace OpenGL.Framework too. Titan and Natit are merely enablers which make OSx86 think your VGA BIOS card is an EFI Firmware one (as on a real intel mac), and should load before the NVNVDA* kexts. An installer for Natit can be found at [1]. Check the forums for more info.

Note: For ATI users, visit http://omni.starchaser.org/ for experimental drivers.

Note: As of right now, all ATI cards with working kexts have severe slowdown issues with nForce3 chipsets. There is no fix for this, save getting editting out your card from the kext or using Quartz Debug to shut off Quartz Extreme. Edit: Just use agpgart to get no slowdowns at all on nForce3. Joblo10

PCI Express


ATi

Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Place Holder Place Holder Place Holder
  1. Place Holder
Place Holder Place Holder Place Holder

Intel

Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Place Holder Place Holder Place Holder
  1. Place Holder
Place Holder Place Holder Place Holder

Matrox

Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Place Holder Place Holder Place Holder
  1. Place Holder
Place Holder Place Holder Place Holder

NVidia

Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Place Holder Place Holder Place Holder
  1. Place Holder
Place Holder Place Holder Place Holder

AGP


ATi

Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Radeon X1600 Pro (256MB) Sapphire Works out of the box on an ASUS P4P800-VM MB Yes plus Q2D capable (gives a great speed boost on iWork '06 Pages program) Any Yes

NVidia

Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
GeForce Ti 4200 Leadtek Works using Natit. All resolutions. Still recognised as PCI card however. QE works All resolutions Semthex kernel, Natit kext and edited NVDAResman.kext, GeForce.kext (and NVDANV40Hal.kext-probably unneeded) with device/vendor id
Geforce 7100GS Used Natit with device id in needed scripts Yes,Yes DVI works with custom resolution settings and S-video work
GeForce4 Ti 4800SE 128mb AGP MSI Ti4800SE-TD8X Added DEV ID to Geforce.kext, added natit, it loads NvidaNV20HAL. Later added AGPGart which lowered cpu usage substantially CI & OpenGL, no QE Dual monitor, all res. Natit/AGPGart
Geforce 5200 (128MB) XFX/Inno3d Works using Titan Kext and Natit Installer 1.0. DVI works and QE & CI. no screen artifacts! (Device ID 0x0322) Yes, both Any No
GeForce FX 5200 Unbranded (DeviceID = 0x0322) Works using Titan. All resolutions, widescreen, CI/QE/GL. Yes All resolutions Titan
GeForce FX 5200 128MB COMPUSA Works using Natit. All resolutions, CI/QE VGA-DVI-TV OUT. Yes All resolutions Semthex kernel, New DVD no patch
GeForce FX 5500 Unbranded Works using Titan. All resolutions, widescreen, CI/QE/GL. Yes All resolutions Titan
GeForce FX 5600 XFX Works fully with latest Semthex under both Titan & Natit. (Natit provides better performance it seems.) Yes, both. Any Semthex kernel, Natit kext and edited NVDAResman.kext, NVDANV40.kext and GeForce.kext with device/vendor id (0x0312d10. - nix)
GeForce 5700 AGP 128MB Asus V9570TD 10.4.8/8.8.1: Works well w/Natit on JaS 10.4.8 ISO. Need to replase card ID in .plist files of Geforce.kext, NVDARESMAN.kext and NVDANV30Hal.kext, after that QE/CE works. Yes - Both [email protected], higher resolutions are supported. Yes/No (Need Natit; without editing .plists - QE/CE not supported).
NVIDIA FX5700LE (256mb) BFG Tech I was able to install the Titan kext while I was booted into the Install CD, so I got the cool Cube effect of the setup assistant! A tiny bit of lag while the card starts up again after not doing any QE/CI in a while, (Dragging something into Dashboard doesn't ripple the first time, but all times after that for like 10 minutes, unless you don't let it power down.) Both All that I can see, using 1280x1024 on my CRT, absolutely stunning. Titan activates about 90% of the card.
Geforce 5900XT (128MB) MSI Natit Installer 1.0. DVI works and QE & CI. no screen artifacts Yes, both Any No
Geforce 6200 128MB Leadtek Using Titan.kext Both 1280x1024 Yes/Requires Titan.kext
Geforce 6200 TurboCache XFX/Inno3d Works using Titan Kext and Natit Installer 1.0. DVI works and QE & CI. no screen artifacts! Yes, both Any No
Geforce 6200(256MB) NVIDIA, SPARKLE(Kurouto-Shikou released in Japan) Works using Titan Kext. Both VGA and DVI. Full QE/CI. No screen artifacts! Yes, both Any Titan
Geforce 6200 256MB XFX Installed Jas 10.4.8 SSE2 SSE3 Intel AMD DVD Both 1280x1024 (Highest For My Monitor) Just make sure you check Titan on the DVD for full QE/CI Support!
XpertVision Nvidia GeForce 6200 XpertVision Works using Titan. All resolutions, widescreen, CI/QE/GL. Both All resolutions Yes, with Titan
Geforce 6200TC 256MB PNY Using the NV40 nvidia patch Both 1280x1024 Yes/Requires NV40 patch who came on the installation, nothing more
Geforce 6600GT (128MB) Apollo Titan Kext DVI works and QE & CI. no screen artifacts, smooth as silk Yes, both Any No
GeForce 6600 TDH (256) Leadtek 10.4.8/8.8.1: AMD Final SSE2 SSE3 from Piratebay but without NV40 and X1000 , then installed latest Natit. 6600 TDH works perfectly, 7600GT need to edit Natit.kext and NV40 to include the device ID (02e0). Dual display works flawlessly on 6600, but on 7600 GT, digital output doesn't work, only works by using a convertor making both output analogue, which is bad for my cheap LCD display. BOTH All resolution and frequency Natit full work on 6600

7600GT required edit of Natit and NV40 kext and digital output won't work unless convert to analogue by adaptor. Make sure don't click X1000 ad NV40 support in 10.4.8 AMD Final SSE3 installation, then install latest Natit or Natit dual, then edit kext if 7600 GT.

GeForce 6600GT 128Mb Asus Works with new Natit Uni. installer! Yes, both. Any No
GeForce 6600GT AGP 128MB EVGA 10.4.8/8.8.1: Worked fine with natit and titan method. QE/CI fully work. Resolution and refresh work. World Of Warcraft works. WolfET Works. Dual-screen with natit (often 10sec blackscreen during startup). Yes, Both Any No, Need Titan or Natit
Geforce 6600GT 128MB NVidia/Club3D Works perfectly. Yes Any Yes
Gainward 6600GT (128Mb) nVidia / Gainward natit patch from Jas 10.4.8 Yes / Yes All Yes / No
Geforce 6800 (128MB) Leadtek Works perfektly using OSX 10.4.8_AMD_SSE3 from Piratebay after adding 0x004110de in IOPCIMatch in the Geforce.kext(Contents/Info.plist) and deleting AGPGuard.kext Yes, both Any Titan
Geforce 6800GT (256MB) ASUS Works using Titan Kext. Both VGA and DVI. Full QE/CI Yes, both Any titan 11-01
Microstar GeForce 6800 128MB NVIDIA Titan`s kext, Kexts and framework from Apple Intel Update. Both Any (Using 1680x1050 on 20" wide LCD) TITAN kext and edited NVDAResman.kext NVDANV40.kext and geforce,kext
Geforce 6800 GS 256MB XFX Everything works perfectly Both All Yes/Titan
Geforce 7600GS (256MB) PNY Had to install nvidiaNV40.pkg over a clean Jas 10.4.8, remove AGPGart.kext, edit GeForce.kext, NVDAResman.kext and NVDA40HAL.kext with my own device ID (0x02e1), install in /System/Library/Frameworks OpenGl.framework and QuartzCore.framework taken from original Apple 10.4.8 update using Pacifist, remove Extensions.mkext and Extensions.kextcache, set chown root:wheel and chmod 755 to all Extensions (eg. sudo chown -R root:wheel /System/Library/Extensions/*) and diskutil repairpermission /. After reboot I got QE/CI. Yes, both Any I have Titan.kext but not installed, maybe is included in nvidiaNV40.pkg
7600GT DDR3 (256) Leadtek 10.4.8/8.8.1: AMD Final SSE2 SSE3 from Piratebay but without NV40 and X1000 , then installed latest Natit. 6600 TDH works perfectly, 7600GT need to edit Natit.kext and NV40 to include the device ID (02e0). Dual display works flawlessly on 6600, but on 7600 GT, digital output doesn't work, only works by using a convertor making both output analogue, which is bad for my cheap LCD display. BOTH All resolution and frequency Natit full work on 6600

7600GT required edit of Natit and NV40 kext and digital output won't work unless convert to analogue by adaptor. Make sure don't click X1000 ad NV40 support in 10.4.8 AMD Final SSE3 installation, then install latest Natit or Natit dual, then edit kext if 7600 GT.

Geforce 7600GT (256MB) XFX Had to edit the NVDAResman and NV40HAL with my own device ID(0x02e0), only annoying thing is the dashboard crash when using it Yes, both Any Titan or Natit
ASUS N7600GS,(256MB) NVidia / ASUS Semthex Kernel, DVI Works, VGA Analog not tested yet. I Inserted "02e1" as dev-id into GeForce.kext, NVDANV40HAL.kext and NVDAResman.kext. Injection using Titan.kext YES / YES Tested up to 1680 x 1050 Yes / NO - Titan.kext
Geforce 7800GS 256mb BFG Using Titan 1.0 and Natit_Dual Both ALL Yes/No

PCI


Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
GeForce FX 5200 (128 MB) Nvidia Everything works, including Quartz Extream and Core Image, All right out of the box using the Tubgirl DVD, 10.4.8, Semthex 8.8.1 Yes! All Titan and NV40
PNY GeForce FX 5200 (256 MB DDR) Nvidia I picked up this card after my Intel onboard video refused to work and I saw the above post. Installed from the JaS AMD-Intel SSE2-SSE3 with PPF1 DVD. Must select the NV40/Titan option or you'll need to download a driver later. All resolutions, QE, and CI work. Yes All Titan and NV40 in installation options

Mobile


Hardware Name,(VRAM) Chip-Manufacturer / Board-Manufacturer Notes QE / CI Resolution Full Work / No Patch
Geforce4 Go 440 64mb Nvidia Works macvidiadrive no QE / CI Both ALL
Quadro4 700 GoGL (NV28GL) Dell Mobile Works using NVidiaEFI or using Natit but no internal diplay in that case. QE works All resolutions Semthex kernel, NVidia kext and edited NVDAResman.kext, GeForce.kext and NVDANV20Hal.kext-probably with device/vendor id
Geforce Go 6200 256MB ASUS Works using JAS Amd/Intel SSe2/SSe3 ISO and selecting natit and natit dual support Both ALL Yes/Natit
Geforce Go 7600 128mb SonyVaio Works perfectly using Titan OR Natit (all versions), but ONLY on an external monitor. Trying to solve that now. Both OK ALL Yes/titan or natit
Powered by MediaWiki © 2021 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki   |   Privacy policy   |   About OSx86   |   Disclaimers