Editing HCL 10.7.3

Jump to: navigation, search

Warning: You are not logged in.

Your IP address will be recorded in this page's edit history.
The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 32: Line 32:
 
*LAN/Ethernet works with patch
 
*LAN/Ethernet works with patch
 
*Audio works with patch
 
*Audio works with patch
**audio ALC888 worked out the box
+
**audio ALC888 worked out the box, but after installing Multibeast lost it in either S.L. or Lion
 
*Graphics NOW are working with drivers (No EFIstring). Dual Monitor full acceleration QE/CI
 
*Graphics NOW are working with drivers (No EFIstring). Dual Monitor full acceleration QE/CI
 
*Sleep= Unknown
 
*Sleep= Unknown
Line 39: Line 39:
 
**No changes on Bios requiered besides set to AHCI
 
**No changes on Bios requiered besides set to AHCI
 
*I used the Clean Retail method for both SL and Lion
 
*I used the Clean Retail method for both SL and Lion
*Boot with chameleon
+
*Boot with iBoot (i used v. 3.2)
**no flags requiered(u can use -v just to see what's going on).<br /> "GraphicsEnabler=Yes"
+
**no flags requiered(u can use -v just to see what's going on).<br /> "GraphicsEnabler=Yes" already <br />included with iBoot
***I tried a bunch of combinations before, BUT only messed up the booting process.
+
***I tried a bunch of combinations before, BUT only messed up the booting process. USE iboot 3.2 and above (or latest)
 
**Install (format ur HDD for fresh isntallation)and boot with no flags again.
 
**Install (format ur HDD for fresh isntallation)and boot with no flags again.
***Audio should work out the box
+
***Audio should work out the box, but will get messed up after installing MultiBeast (no big deal,<br /> we can fixed when u upgrade to Lion)
 
***WIFI Broadcom 1505 (14e4,4328) working out the box..LAN not working
 
***WIFI Broadcom 1505 (14e4,4328) working out the box..LAN not working
 
***Graphics card is dual pcb, but only 1 pcb was working. We'll use EFI string Later.
 
***Graphics card is dual pcb, but only 1 pcb was working. We'll use EFI string Later.
Line 49: Line 49:
 
**I'm using 10.6.6 Combo Update in order to use the APP Store and upgrade to LION.
 
**I'm using 10.6.6 Combo Update in order to use the APP Store and upgrade to LION.
 
**I got the graphics working with 10.6.8, BUT no LAN/Ethernet working so i couldn't use the App Store at all.
 
**I got the graphics working with 10.6.8, BUT no LAN/Ethernet working so i couldn't use the App Store at all.
**this is the important part. Check "EVOreboot" and "FakeSMC"
+
*Install MultiBeast (don't Restart yet).
**My wireless keyboard and mouse were recognize without any kexts
+
**I'm NOT using "DSDT" or "EasyBeast" settings from MultiBeast. (eventhough EASYBEAST works fine,<br /> I'm not using it because we only need a few changes)
 +
**Check "system utilities"/repair permissions
 +
**Check Bootloaders/Chimera ( I installed 1.9 after that just to be ready to upgrade to Lion)
 +
***Don't forget to check a "Theme" from "Customization"/theme/ section.
 +
**this is the important part. Check "EVOreboot" and "FakeSMC" from the "Kexts/Miscellaneous/" section.
 +
**that's it for MultiBeast. (My wireless keyboard and mouse were recognize without any kexts)
 
*Fix the Graphics
 
*Fix the Graphics
 
**I used this method [http://www.insanelymac.com/forum/index.php?showtopic=184318&st=20&p=1338125&#entry1338125 Nvidia GTX 295 EFIpack 1.2 Method]
 
**I used this method [http://www.insanelymac.com/forum/index.php?showtopic=184318&st=20&p=1338125&#entry1338125 Nvidia GTX 295 EFIpack 1.2 Method]
Line 63: Line 68:
 
*Sign in to your App Store (which apparently only cares about "en0) which mine at the time was the wifi.
 
*Sign in to your App Store (which apparently only cares about "en0) which mine at the time was the wifi.
 
*Buy Lion (after FEB 2012) 10.7.3 is the default.
 
*Buy Lion (after FEB 2012) 10.7.3 is the default.
 +
*Follow this guide from [http://tonymacx86.blogspot.com/2011/07/xmove-multibeast-install-os-x-107-lion.html tonymacx86]
 
**after booting to your partition "installer" (that the above guide makes you do).<br /> You WIL loose the full acceleration and also the DVIs ports (Meaning only 1 pcb will be working). <br />I think this is due to LION is reading the PCI Roots of the GTX 295 in reverse order in comparison to SL.<br /> Luckily, your HDMI still works so plug your monitor or TV there.
 
**after booting to your partition "installer" (that the above guide makes you do).<br /> You WIL loose the full acceleration and also the DVIs ports (Meaning only 1 pcb will be working). <br />I think this is due to LION is reading the PCI Roots of the GTX 295 in reverse order in comparison to SL.<br /> Luckily, your HDMI still works so plug your monitor or TV there.
 
*Install over your Snow Leopard partition and reboot normally (remember only HDMI works at this point)  
 
*Install over your Snow Leopard partition and reboot normally (remember only HDMI works at this point)  
Line 68: Line 74:
 
*Install the latest CUDA Driver from Nvidia. I'm using 4.2.5 version
 
*Install the latest CUDA Driver from Nvidia. I'm using 4.2.5 version
 
*Install the latest driver from Nvidia "270.00.00.00f01" <br />or anything that supports GTX 285 or 2xx series (no necessary to downgrade)
 
*Install the latest driver from Nvidia "270.00.00.00f01" <br />or anything that supports GTX 285 or 2xx series (no necessary to downgrade)
*I also downloaded this kexts from [http://www.osx86.net/downloads.php?do=file&id=2369&page=2 osx86]<br /> but I don't know if they were necessary.<br /> (I deleted the originals .kext and .bundle from /S/L/E and then installed the new ones)
+
*I also downloaded this kexts from [http://www.osx86.net/downloads.php?do=file&id=2369&page=2 osx86]<br /> but I don't know if they were necessary.<br /> (I deleted the originals .kext and .bundle from /S/L/E and then installed the new ones with KextBeast also from [[tonymacx86.com|"tonymacx86.com"]]
*smbios.plist -->MacPro5,1 & <br /> don't forget to check the last box at the end (for first time boot only.<br /> It will move your kexts to /System/Library/Extentions)
+
*Get MultiBeast for Lion from [http://www.tonymacx86.com/viewforum.php?f=125 Tonymacx86]<br /> and install with the same settings that we used for Snow Leopard +  smbios.plist -->MacPro5,1 & <br /> don't forget to check the last box at the end (for first time boot only.<br /> It will move your kexts to /System/Library/Extentions)
 
*Finally, DELETE your EFIstring from org.chameleon.boot.plist
 
*Finally, DELETE your EFIstring from org.chameleon.boot.plist
 
**I tried the "NVDA,Parent" method before<br /> and got me working with the DVI (I Switched the PCI roots Values),<br /> but I will not give you full acceleration QE/CI.<br />
 
**I tried the "NVDA,Parent" method before<br /> and got me working with the DVI (I Switched the PCI roots Values),<br /> but I will not give you full acceleration QE/CI.<br />
Line 78: Line 84:
 
**Install with kextBeast OR if u want more work, just add it to /S/L/E/IONetworkingFamiliy.kext/Content/Plugins/
 
**Install with kextBeast OR if u want more work, just add it to /S/L/E/IONetworkingFamiliy.kext/Content/Plugins/
 
***otherwise u can just place it in /S/L/E/ (that's where i have it)
 
***otherwise u can just place it in /S/L/E/ (that's where i have it)
*I try to use diff. options to make my audio work but only Voodooo will get me sound<br /> but gets me a Kernel Panic. So I had to use "GraphicsEnabler=Yes" "PCIRootUID=1" <br />in extreme cases "npci=0x3000" to boot to the screen again.  
+
*I try to use diff. options to make my audio work but only Voodooo will get me sound (From MultiBeast)<br /> but gets me a Kernel Panic. So I had to use "GraphicsEnabler=Yes" "PCIRootUID=1" <br />in extreme cases "npci=0x3000" to boot to the screen again.  
 
*RESTART!!!
 
*RESTART!!!
 
*You should be in the Lion screen now.<br /> I can share some files if necessary to get Your Monster Alienware<br /> and your Classic Monster GTX 295 to work. user "Cucho" on tonymacx86's website
 
*You should be in the Lion screen now.<br /> I can share some files if necessary to get Your Monster Alienware<br /> and your Classic Monster GTX 295 to work. user "Cucho" on tonymacx86's website
Line 84: Line 90:
 
|
 
|
 
*'''System:'''
 
*'''System:'''
 +
*MultiBeast
 
**#System Utilities
 
**#System Utilities
 
**#Bootloader and Theme
 
**#Bootloader and Theme
Line 92: Line 99:
 
*BCM5722D (Edited for BCM5784 <br />[http://www.osx86.net/downloads.php?do=file&id=1115 www.osx86.net]
 
*BCM5722D (Edited for BCM5784 <br />[http://www.osx86.net/downloads.php?do=file&id=1115 www.osx86.net]
 
*'''Audio:'''
 
*'''Audio:'''
**Try ALC888 or roll back first
+
**MultiBeast
**If the above doesn't work try VooDooo (KP expected use flags from guide)
+
***Try ALC888 or roll back first
 +
***If the above doesn't work try VooDooo (KP expected use flags from guide)
 
*'''Graphics:'''
 
*'''Graphics:'''
 
**Latest CUDA v 4.2.5 [http://www.nvidia.com/object/cuda-mac-driver.html www.nvidia.com/CUDA]
 
**Latest CUDA v 4.2.5 [http://www.nvidia.com/object/cuda-mac-driver.html www.nvidia.com/CUDA]
Line 105: Line 113:
 
|{{Y}}
 
|{{Y}}
 
|{{Y}}
 
|{{Y}}
|-
 
 
|}
 
|}
  

Please note that all contributions to OSx86 may be edited, altered, or removed by other contributors. If you do not want your writing to be edited mercilessly, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource (see OSx86:Copyrights for details). Do not submit copyrighted work without permission!

Cancel | Editing help (opens in new window)
Powered by MediaWiki © 2021 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki   |   Privacy policy   |   About OSx86   |   Disclaimers