HCL 10.7.4

From OSx86
Revision as of 09:50, 30 June 2012 by Huckleberrypie (Talk | contribs)

Jump to: navigation, search
macOS 10.7.4
Hardware Compatibility

This is a component level hardware compatibility list. We want to keep it as accurate as possible, but please, do not entirely rely on this list when buying hardware. Add which parts you have working in the categories listed below, or create a new category. Please keep alphabetical order inside the categories. The categories themselves are ordered by popularity. Please list any caveats or problems as well.

  • ONLY add hardware that you have TESTED. Don't add hardware just because you think it might work.
  • Please add hardware into tables.
  • This is for 10.7.4 builds only.

For how to edit the Wiki, please see this thread. Thank you!

You're looking for an Installation guide? see here

Contents

Motherboards

Abit

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Abit IP35 Intel P35 System configuration:
  • Intel Core 2 Quad Q6600
  • Chipset Intel P35
  • AMD Radeon HD4870 (GraphicsEnabler)
  • Audio ALC888 (DSDT mod + Binpatch AppleHDA)
  • PCI-e Network Card RTL8111C (Lnx2Mac)
Installation method:
  • Retail Lion 10.7
  • Combo Update to 10.7.4
  • Add DSDT, FakeSMC, Binpatch AppleHDA, Newest Chameleon

Working:

  • Shutdown/Reboot
  • Mac App Store
  • iCloud
  • Both DVI ports.

NOT Working:

  • Doesn't wake up from sleep mode
Tick.png Tick.png

ASRock

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
ASRock Fatality Z68 Professional Intel Z68 System configuration:
  • Intel Core i5 2600k
  • Chipset Intel Z68
  • 16GB Corsair Vengeance [email protected] 1600mhz / 4 X 4GB
  • NVidia GTX 570 (EVGA GTX 570 SC)
  • Audio ALC8xx (MultiBeast Realtek)
  • PCI-e Network Card (RealtekRTL81xx.kext)
Installation method:
  • iATKOS 10.7.3
  • Combo Update to 10.7.4
  • MultiBeast EasyBeast Install
  • MultiBeast Audio (Realtek ALC8xx)
  • MultiBeast Graphics (NVidia 4xx/5xx Support: 10.7.2+Combo) /
  • NVidia Hermes Driver 270.00 Download (nvidia.com)
  • NVidia Cuda Driver 4.2.7 Download (nvidia.com)
  • Note: Set bios to default, Set storage to AHCI, unhooked all USB devices except keyboard & mouse.
  • (Did not remove any ram or NVidia GPU for installation)

Working:

  • Shutdown/Reboot
  • Mac App Store
  • iCloud
  • Both DVI ports.

NOT Working:

  • Doesn't wake up from sleep mode


AsRock G41M-VS3 System configuration:
  • Intel C2Q 83000
  • 4GB Corsair DDR3 1333 RAM (if added another 4gb = installation failed and after installed successfull it'll always kernel panic after running in couples of minutes)
  • 1TB Seagate Barracuda HDD
  • Nvidia GT 210 1gb DDR3 Silent
  • Audio VT1705 (multibeast VoodooHDA 2.1)
  • Ethernet Atheros (multibeast maolj's ethernetL1cEthernet)
  • Asus N10-USB wireless
Installation method:
  • boot with rBoot for lion (chimera 1.9.1)
  • Retail 10.7.0 restored to another partition/hdd
  • multibeast 4.5.2 EasyBeast Install, IOUSBFamily Roolback, maolj's AtherosL1cEthernet
  • boot from HDD, if GPT error.. install chimera 1.9.2 from another working OSX. i have to boot with chimera 1.9.2 to get VideoCard (GT 210) to work fine with QE/CI
  • update to 10.7.4 with combo client update
  • install kext for audio (VT1705) with multibeast and choose VoodooHDA 2.1, i read from some forum to choose 2.2 but it didnt work for me.. 2.1 did.
  • wireless with asus usb-n10 working by installing official driver from asus website, or use this RTL8192SU_MacOS10.6_1079.zip more stable and advanced than asus's official
  • Mac App Store and iCloud working by following this article http://www.osxlatitude.com/how-to-fix-icloud-appstore-facetime/2/


Working:

  • Shutdown/Reboot
  • Mac App Store
  • iCloud
  • DVI, VGA and HDMI (connected to HD TV 1080)

NOT Working:

  • Doesn't wake up from sleep mode
Tick.png Tick.png

ASUS

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
P7H55D-M EVO Intel H55 System:
  • CPU: Intel Core i5 650
  • GPU: GeForce GT 9500 1024 MB
  • RAM: Kingston DDR3 1333 MHz 2 x 2 GB
  • HDD: Samsung 500 GB SATA
  • Audio: Realtek ALC 889 onboard
  • Ethernet: Realtek 8112L Gigabit onboard
  • Wi-Fi: D-Link DWA-556 (recognized as AirPort)
  • Bluetooth: D-Link DBT-122 with Magic Mouse, Magic Trackpad and Apple Wireless Keyboard
  • Shutdown: Yes
  • Restart: Yes
  • Sleep: Yes
Installation method: Clean installation of Mac OS X Lion 10.7.4 downloaded from Mac App Store. No custom DSDT used.

Post-installation:

  • System definition: iMac 11,1 (to make Mac App Store and iCloud work)

Patches applied (MultiBeast 4.5.2):

  • ALC8xxHDA
  • AppleHDA Rollback
  • HDAEnabler ALC889
  • 3rd Party SATA
  • Lnx2Mac's RealtekRTL81xx Ethernet

Tick.png Tick.png
Asus P5E-Deluxe Intel X48 System configuration:
  • Intel Core 2 Quad 9550K
  • Chipset Intel X48
  • MSI GTX 580 Lightning
  • Dual Display
  • Audio (Logitech H360 Headset) works by default
  • LAN (Marvell88E8056) works with drivers of iATKOS L2
  • Wireless Adapter ASUS WL-138g V2 works by default
Installation method:

- iATKOS L2 selecting:

  • Marvell Yukon 88E8056 kext
  • Voodoo HD Audio 2.2 kext

- UPDATE Mac OS X to 7.4

  • Install GTX 580 Drivers (use Champlist to install the Kext - Destination: System/Library/Extensions)

Working:

  • Shutdown/Reboot
  • Mac App Store
  • iCloud
  • Logitech H360 Headset
  • Dual Monitor [HDMI + DVI]

NOT Working:

  • Sleep mode
Tick.png Tick.png
Asus P5Q SE Intel P45/ICH10 System configuration:
  • Intel Core 2 Quad Q6600 2.39 GHZ
  • 3GB 666 MHZ DDR2 SDRAM (Generic 2 1ghz and 2 .5ghz)
  • Nvidia 8500 GT 256 MB
  • Dual Display
  • Onboard Audio works with drivers of iATKOS L2 Mic ?
  • Audio Diamond Express 7.1 PCI sound card works with (CMI8738AudioDevice.kext for 64 bit)
  • LAN (Atheros) works with drivers of iATKOS L2
  • Rear USB OOB and Front need USB Fix from iATKOS L2
  • SIIG RF Wireless Keyboard USB OOB
Installation method:

- iATKOS L2 selecting:

  • Already Chosen Kext Files by iAtkos installation CD
  • Atheros Wired Kext
  • Voodoo HD Audio 2.2 kext
  • NVEnabler
  • USB Fix for front case USB's
  • Install CMI Kext for Diamond Express 7.1 using Kext Drop

- UPDATE Mac OS X to 7.4

Working:

  • Shutdown/Reboot
  • Mac App Store
  • iCloud
  • SIIG RF Wireless Keyboard
  • Dual Monitor [HDMI + DVI]
  • Dual Boot with Win 7 on Seperate Hard Drive
  • Using Champlist Themed for Chameleon
  • All Seems To Work

NOT Working:

  • Sleep mode (disabled sleep mode)
Tick.png Tick.png
P5KPL-AM EPU P35 + ICH9, BIOS 501 Hardware:
  • Intel Core2Duo E6420 CPU 2.13 GHz
  • XFX GT240 512 mb DDR3 works fully

Notes

  • BIOS: Store Configuration ATA/IDE Enhanced;Enhanced Mode Support:S-ATA; IDE Detect Time: 35
  • Audio - works with VoodooHDA_261_HP_HDX18 (Output and Inputs) edit Info.plist, replace the key IOPCIClassMatch by IOPCIPrimaryMatch and put the PCI ID of your audio card in string. View: [1]
  • Ethernet - Works from pack Atheros AR8121 AR8113AR 8114
  • USB - All Work
  • IDE - Work
  • ICH9R - Works

Install Method:

  • 1.BootCD: BOOTCD.ISO
  • 2.iAtkos L1 from USB
  • 3. Boot with the comand: npci=0x2000
  • Bootloader: Chameleon 2.1svn
  • MacOsxUpp Combo 10.7.2
  • Shutdown/Reboot work 99.9% of the time.
  • Mac App Store WORKS!!!
  • iCloud WORKS!!!

Patches

  • Bootloader: Chameleon 2.1svn
  • Graphics Enabler
  • Built-in Ethernet
  • Extra/Extensions
  • FakesMc
  • Disabler
  • EVO Reboot
  • Update to 10.7.2, Update 10.7.3, and Update 10.7.4 ALL WORKING!
  • Sound+Ethernet: from download files


NOT Working:

  • Sleep mode (disabled sleep mode)
  • Microphone input

Useful Tools

Tick.png Tick.png
Asus P8H61 PRO Intel H61/ATX System configuration:
  • Intel Core i5 2500 @ 3.30 GHz (Quad Core) 6Mb Cache
  • Corsair 8Gb DDR3 1600 MHz
  • Asus NVIDIA GT440 1GB 1024Mb DDR3
  • Realtek ALC887 8-Channel High Definition Audio
  • Audio Diamond Express 7.1 PCI sound card works with (CMI8738AudioDevice.kext for 64 bit)
  • Realtek RTL8168/8111 PCI-E Gigabit Ethernet Adapter
  • Seagate Barracuda (500 GB, 7200 RPM, SATA-II) [Linux Hard Drive]
  • Western Digital 200 Gb, IDE with SATA-II Adapter [iAtkos Hard Drive]
  • Logitech K520 Combo Wireless Keyboard & Mouse
  • Logitech Z506 Surround Sound Speakers 5.1
  • Dual Monitor
Installation method:

- Select AHCI and set in Bios AHCI Mode

- iATKOS L2 selecting

  • Chameleon 2.1
  • Graphics Enabler
  • Built-in Ethernet
  • FakeSMC
  • Ev0reboot
  • Vodoo HDA 2.7.3
  • VGA GF100
  • Wired Realtek RTL 8111/8168

- UPDATE Mac OS X to 7.4

- Install Kext nVidia GeForce GT440 1Gb/ Silent Natit x86_64, heal kext with Kext Wizard and put this code in your org.chameleon.Boot.plist

<key>NVCAP</key>
<data>04000000 00000300 08000000 00000007 00000000</data>
<key>VRAM,totalsize</key>
<data>00000040</data>

Working:

  • Shutdown/Reboot
  • Mac App Store
  • Logitech K520 Combo Wireless Keyboard & Mouse
  • Logitech Z506 Surround Sound Speakers 5.1
  • Dual Boot with Ubuntu (Linux) on Seperate Hard Drive
  • All Seems To Work

NOT Working:

  • Sleep mode (disabled sleep mode)
  • iCloud
  • Dual Monitor (DVI + VGA)
Tick.png Tick.png

EVGA

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
EVGA 132-CK-NF78 nForce 780i System configuration:
  • Intel Core 2 Quad
  • Chipset nForce 780i
  • EVGA GTX 550 Ti
  • 60 GB IDE drive
  • Audio works with VoodooHDA.kext 2.7.3
  • LAN works with nForceLAN.0.64.5.kext
  • QE/CI works with NVEnabler.kext
Installation method:

- Used two separate hard drives. One for XP and one for Lion. Used Transmac on XP to write iATKOS L2 dmg to USB flash drive. Installed Chameleon Install 2.1 Rev 1806 for Windows and used to boot iATKOS L2 Lion USB flash drive. Installed Lion to GUID partition on empty hard drive. If you get kernel panic on first boot and hangs on pci configuration use flags -v npci=0x2000. If you see kernel panic about ElliotForceLegacyRTC.kext login to Windows and use transmac to delete the kext from Lion HD. Must use npci=0x2000 flag to boot. Will test again and add updates soon. - UPDATE Mac OS X to 7.4

  • Download 10.7.4 combo update and install. Restart.

Working: NOT Working:

Tick.png Tick.png

Gigabyte

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
GA-H55M-UD2H Intel® H55 Express Chipset System Configuration:
  • CPU: Intel Core i5 760
  • GPU: Asus Nvidia GeForce 9800GT 1GB
  • RAM: Buffalo 2x4GB 1333Mhz

Component Status:

  • All works

Notes:

  • Install method - Lion 10.7.4 installed with UniBeast
  • Multibeast . Lion Edition 4.5.2
  • EasyBeast: NO - UserDSDT: NO - System Utilities: YES
  • Audio: ALC8xxHDA: YES - AppleHDA Rollback: YES - Non-DSDT HDAEnabler: AC889
  • Disk: 3rdParty SATA - 3rdParty eSATA - JMicron36x ATA
  • Graphics: NO
  • Miscellaneous: ElliottForceLegacyRTC: YES - EvOreboot: YES - FakeSMC: YES - FakeSMC Plugins: Motherboard and NVIDIA - IOUSFamily Rollback. YES - NullCPUPowerManagement: YES
  • Network: Lnx2Mac's RealtekRT81xx
  • Bootloaders: Chimera v1.9.2 r1394
  • Customization: Boot Options: 64-bit Apple Boot Screen - PCI Root ID Fix - PCI Configuration Fix
  • System Definition: Mac Pro 3,1
  • Themes: Chameleon RC5
Tick.png Tick.png
Gigabyte EP45-UD3P Rev. 1.6 Intel® P45 + ICH10R Chipset System Configuration:
  • CPU: Intel Core 2 Duo E7400 2.8GHz
  • GPU: MSI Nvidia GeForce 8400GS 512BM
  • RAM: 7GB DDR2 800MHz Kingston KVR
  • Mac OS X Lion 7.4 (Build 11E53)
  • System defenition: Mac Pro 3.1

Component Status:

  • GPU Dual Monitor working.

Notes:

  • Installed Lion from App Store. Patched with Kakewalk
  • SOUND WILL WORK AFTER UPDATING TO 7.4!!!!
  • Software update to 10.7.4
  • Resolution at 1600x900 (Dell ST2010) and 1280x10249 (Unknown Sony display) with full acceleration
Patches
  • Kakewalk for appstore app patching.
  • right kext are installed during lion installation automatically
  • Onboard Apple Software update is working. used it for updating to 7.4
  • sleep not working yet.
  • time machine not tested yet.


Tick.png Tick.png
Gigabyte G41M-E2SL rev. 1.1 INTEL G41/ICH7 System Configuration:
  • CPU: Intel Core2Duo E6300 1.86 GHz
  • GPU: PNY GeForce 210 1Gb
  • Mac OS X Lion 10.7.4 (11E53)

Component Status:

  • Onboard Intel X4500 video not tested

Notes:

  • Installed from iAtkos Lion L2
  • Software update to 10.7.4
  • Resolution at 1680x1050 with full acceleration
Patches
  • AUDIO: Voodoo 0.2.61
  • GRAPHICS: "Graphics enabler" only
  • NETWORK: RealkTek RTL8111C Gigabit Ethernet recognized as RTL8169
Tick.png Tick.png
Gigabyte GA-H61M-D2-B3 (F10) INTEL H61 System Configuration:
  • CPU: Intel G840 - 2.80 GHz
  • GPU: Zotac GF9800GT 1Gb
  • RAM: 8GB 1333mhz RAM (2 x 4GB)
  • Mac OS X Lion 10.7.4 (11E53)

Component Status:

  • All works

Notes:

  • Install method - flash drive with XPC + flash drive with Lion 10.7.3 from AppStore
  • Update to 10.7.4 by using Software Update
  • Using DSDT from TonyMac DSDT Database
  • Using RTL8111E kext from Realtek offsite
  • Patch ALC889
Patches

DSDT

Tick.png Tick.png
Gigabyte GA-H61M-DS2 (rev 2.1) INTEL H61 System Configuration:
  • CPU: Intel Core i7 2600k 3.4GHz
  • GPU: Gigabyte geforce 210 1Gb
  • RAM: 4GB 1333mhz RAM ADATA

Component Status:

  • All works (but integrated graphics not intel hd 3000)i tried everything no QE/CI, no resolutions

Notes:

  • Install method - flash drive with unibeast + Lion 10.7 from AppStore
  • After dont update install multibeast (easybeast, lan driver 8111l, bootoptions 32bits Apple boot screen
  • Now in my case my hard drive does not boot after multibeast install boot error, solution (http://www.mymac4music.com/2011/10/boot0-error/)with new hard drives seagate 500gb sata III.
  • now you can boot from hd now install update 10.7.4 combo and everything
  • last Patch ALC887/888b (but you need select ALC8XXX and ALC887/888b in multibeast and from https://tonymacx86.com/viewtopic.php?f=16&t=59061&start=140 get the AppleHDA /887_Lion_AppleHDA_887-100302/ for lion ALC887 and install with kextbest)
  • sleep with SleepEnabler.kext 10.7.4 Dell N4050 from kexts.com
Patches

there is no DSDT for my motherboard revision version.?????

Tick.png Tick.png
GA-M67MA-USB3-B3 (F3) System Configuration:
  • CPU: Core i3 2100 - 3.06 GHz
  • GPU: Gainward GT430 1GB
  • RAM: 4GB DDR3 1333mhz (1x4GB)
  • Mac OS X Lion 10.7.4 (11E53)

Component Status:

  • All working

Notes:

  • Install method: iAtkos L1 (installing all drivers) -> update to 10.7.4 (run MultiBeast and select only sound drivers)
  • Using DSDT from TonyMac DSDT Database
  • Drivers from MultiBeast
  • All things work, exept sound, from DSDT.
  • Installed on an A-DATA NH92 ExHDD

MultiBeast Lion 4.5.2

  • EasyBeast: NO - UserDSDT: YES - System Utilities: YES

Using DSDT from http://www.tonymacx86.com/dsdt

  • Audio: ALC8xxHDA: YES - AppleHDA Rollback: YES - Patched AppleHDA: AC889
  • Miscellaneous: USB 3.0 NEC/Renesas and Etron
  • Network: Lnx2Mac ethernet drivers
Tick.png Tick.png
GA-Z68X-UD3H-B3 (F12) INTEL Z68 System Configuration:
  • CPU: Core i7 2600K - 3.50 GHz
  • GPU: Zotac GTX560 1GB
  • RAM: 32GB DDR3 1333MHz (4 x 8GB)
  • Mac OS X Lion 10.7.4 (11E53)

Component Status:

  • All working except sleep function
  • Onboard VGA not tested

Notes:

  • Install method: UniBeast + MultiBeast - Image from AppStore 10.7
  • Update to 10.7.4 (downloaded from Apple website)
  • Using DSDT from TonyMac DSDT Database
  • Drivers from MultiBeast

MultiBeast Lion 4.5.2

  • EasyBeast: NO - UserDSDT: YES - System Utilities: YES

Using DSDT from http://www.tonymacx86.com/dsdt

  • Audio: ALC8xxHDA: YES - AppleHDA Rollback: YES - Patched AppleHDA: AC889
  • Disk: IOAHCIBlockStorageInjector - 3rdParty eSATA
  • Graphics: NVidia 4xx/5xx 10.7.2+ Combo OpenCL
  • Miscellaneous: USB 3.0 NEC/Renesas and Etron
  • Network: Realtek Gigabit Ethernet 2.0.6 for 10.7
Tick.png Tick.png
GA-Z68X-UD3H-B3 1.3 (F12) INTEL Z68 System Configuration:
  • Core i7 2700K - 3.50 GHz (Clocked to 3.59)
  • GeForce 9800GT 1GB
  • 12GB DDR3 1333MHz (2x4 + 2x2)
  • 120GB OCZ Vertex SSD
  • ECHO AudioFire4 Firewire Soundcard
  • Mac OS X Lion 10.7.2.dmg

Component Status:

  • Sleep almost works, keyboard unresponsive after wake
  • Onboard audio seems to work (not tested, FW was OOB!)
  • USB3 status unknown.
  • Rest works.

Notes:

  • Install method: Kakewalk-4.1.1 with 10.7.2.dmg
  • System Update to 10.7.4
  • Drivers etc from MultiBeast 4.5.2

Benchmarks:

  • Geekbench = 12180
  • Cinebench openGL = 33.88 fps, rendering = 6.7 pts

MultiBeast Lion 4.5.2

  • UserDSDT (with no dsdt on desktop)
  • System Utilities
  • 3rdParty SATA
  • TRIM enabler
  • FakeSMC Plugins (Motherboard, NVIDIA, HWMonitor app)
  • USB 3.0 NEC/Renesas and Etron
  • Realtek Gigabit Ethernet 2.0.6 for 10.7
  • SSDT Core i7
Tick.png Tick.png
GA-X58A-UD3R rev 1.0 X58/ICH10 System Configuration:
  • CPU: Core i7 2.7 GHz
  • GPU: GTS 250 1GB
  • RAM: 8GB DDR3 1333MHz (Picks up as 1079MHz)
  • Mac OS X Lion 10.7.4 (11E53)

Component Status:

  • All working except sound, see below.

Notes:

  • Install method: Kakewalk 4.1.1 Image from AppStore 10.7
  • Update to 10.7.4 (Combo Update)
  • Use Kakewalk again after update to reinstall kexts for sound and sleep.
  • www(dot)kakewalk(dot)se
  • Graphics: Works out of box
  • Sound: Works after reinstalling kakewalk.
  • Miscellaneous: USB 3.0 (Think it is working)
  • Network: Works out of box
Tick.png Tick.png
GA-H61N-USB3 (F4) INTEL H61 System Configuration:
  • CPU: Core i5 2500K - 3.39 GHz
  • GPU: Intel HD graphics 3000
  • RAM: 8GB DDR3 1333MHz (2 x 4GB)
  • Mac OS X Lion 10.7.4 (11E53)

Component Status:

  • All working
  • Intel HD graphics 3000 - fully supported OOTB

Notes:

  • Install method: UniBeast + MultiBeast - Lion (AppStore)
  • Update to 10.7.4 (Software Update)
  • Using DSDT from TonyMac DSDT Database
  • Drivers from MultiBeast

MultiBeast Lion

  • EasyBeast: NO - UserDSDT: YES - System Utilities: YES
  • Audio: ALC8xxHDA: YES - AppleHDA Rollback: YES
  • Disk: just selected all
  • Graphics: Graphics enabler
  • Miscellaneous: USB 3.0
  • Network: Lnx2Mac´s Ethernet driver
Tick.png Tick.png
GA-P31-DS3L (F10a) INTEL P31 (ICH7) System Configuration:
  • CPU: Core 2 Duo - 2.4 GHz
  • GPU: Nvidia 8800GT
  • RAM: 4GB DDR2 800MHz (2 x 2GB)
  • Mac OS X Lion 10.7.4 (11E53)

Component Status:

  • All working

MultiBeast Lion

  • EasyBeast: NO - UserDSDT: YES - System Utilities: YES
  • Audio: ALC8xxHDA: YES - AppleHDA Rollback: YES
  • Disk: None
  • Graphics: GraphicsEnabler=Yes
  • Miscellaneous: Installed PCI fix after encountering black screen during 10.7.2 update - not sure if strictly required
  • Network: Lnx2Mac´s Ethernet driver

Notes:

  • Install method: UniBeast 1.30 + Lion (AppStore)
  • Update to 10.7.4 (Combo Update to allow re-run of Multibeast before reboot)
  • Using hand edited DSDT - required Zolky(Zoliky?) DSDT patch to cure black screen after 10.7.2 update - Snow Leo partition proved invaluable!
  • Drivers from MultiBeast
Tick.png Tick.png

Intel

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
Intel DG31PR Intel G31 System configuration:
  • Intel Core 2 Duo E7400
  • Chipset Intel G31
  • NVIDIA GeForce GT240 1GB GDDR5 (GraphicsEnabler)
  • Audio ALC888 (ALC8xxHDA + NonDSDT HDEnabler)
  • RTL8111GR integrated Gigabit Ethernet (Lnx2Mac)
Installation method:
  • Lion 10.7 (iATKOS L2)
  • Combo Update to 10.7.4
  • Used FakeSMC, Alc8xxHDA, Chameleon and GraphicsEnabler, as well as AppleACPIPS2Nub.kext and ApplePS2Controller.kext, in order to make PS/2 keyboards and mice work.

Working:

  • Shutdown/Reboot
  • Mac App Store
  • Graphics acceleration (2D/3D)
  • Most applications including Adobe Premiere (as using graphics kexts seems to crash the latter)
  • Peripherals such as printers (namely an Epson L100 and an HP Deskjet all-in-one) work normally

NOT Working:

  • Sleep mode powers down the system rather than putting it to sleep as intended.
Tick.png Tick.png

MSI

Hardware Name Chipset Notes Patches Used 32/64bit working with patches
P55-GD65 P55 System Configuration:
  • CPU: Intel Core i5 - 750 - 2,66 GHz
  • GPU: Gainward 560Ti 1024MB
  • Dual Display
  • RAM: 12GB (2x2GB, 2x4GB)
  • WiFi: TP-LINK TL WDN4800
  • MAC OS X 10.7.4 (11E53)

Component Status:

Looks like everything works here

WiFi recognized as a Airport Extreme just plug and play :)

Notes:

  • Install method - iAtkos L2 10.7.2
  • than 10.7.4 Update + MultiBeast 4.4.1

Installation:

- iAtkos L2:

  • Voodoo 2.7.3 for Audio
  • Voodoo for PS/2
  • AHCI SATA

-MultiBeast 4.4.1:

  • Nvidia 4xx/5xx Support
Tick.png Tick.png
945GM3 V3 945G System Configuration:
  • CPU: Intel Core2 Duo E6300 1.86GHz
  • GPU: XFX 9600GSO 1024MB
  • RAM: 2x 1GB Super Talent 667 MHz
  • Bluetooth: IOGEAR GBU221WM (works OOB)

Installation:
Started with 10.7.0 from APP Store


MyHack 2.2 Chameleon Flags:
npci=0x3000
Graphics Enabler = Yes
EthernetBuiltIn = Yes
arch=i386 (for audio)


Multibeast 4.3.1
Realtek Gigabit Ethernet

Also downloaded Realtek_ALC883_Audio.DMG from OSx86.net

System update all the way to 10.7.4 with no problems

Used same method for another PC with 7600 GS graphics card.
I was also able to move entire hard drive and run on a MSI G31M3-F V2 which I could not get MyHack 2.2 to run on. No additional patches or kext needed.


Tick.png Tick.png

Graphics Cards

Please specify if your card is AGP, Integrated, PCI or PCI-E.
Also, place chip and board manufacturer in their respective column.

PCI-E

Integrated Graphics

Model Board-Manufacturer Notes QE Output Dual Display 32/64bit
Intel HD graphics 3000 Works OOB with GraphicsEnabler=Yes Tick.png VGA/DVI/ (HDMI not tested) Not Tested Not Tested Not Tested

AMD/ATI

Model Board-Manufacturer Notes QE Output Dual Display 32/64bit
Radeon HD4870 512MB DDR3 Gainward Works OOB and with GraphicsEnabler=Yes Tick.png Tick.png DVI, DVI Yes Tick.png Tick.png
XFX Radeon HD 5770 1GB DDR5 (577X-ZHLC) XFX Works OOB and with GraphicsEnabler=Yes Tick.png Tick.png DVI, DVI, miniHDMI. Works with DVI to HDMI cable too. Yes Tick.png Tick.png
Radeon 6870 ZNFC XFX See this post.METHOD 1 (easier): Org.Chameleon needs the following: AtiPorts=5 AtiConfig=Gibba GraphicsEnabler=Yes in your /Extra folder along with edited Ati6000controller.kext made by BillDlv installed in S/L/E. I used the following links for my research 1 2 3 Method 2 (hard mode): Add graphics to DSDT using code copied and pasted from here. Follow this to get HDMI audio. Max monitors usable is 4 because the HDMI port is linked to the exact same pixel pipeline as one of the DVI ports via hardware. It is a physical limitation even Windows won't fix. Tick.png Tick.png DVI, DVI, HDMI, mDP, mDP Yes Tick.png Tick.png

NVIDIA

Model Board-Manufacturer Notes QE Output Dual display 32/64bit
GeForce 9500 GT 1GB Asus Works OOB with GraphicsEnabler=Yes Tick.png DVI Tested Tick.png Tick.png Tick.png
GeForce GT 430 2048 MB NVIDIA USING TonyMac Multibeast 4.0
  • FOR GeForce GT430, Graphics>NVIDIA 4XX/5XX Support
  • ONLY recognizes 1024 Ram

works perfectly with graphics enabler 10.7.0-3. only tested in 32bit

Cross.png VGA/DVI/ (HDMI not tested yet) Tick.png Tick.png Tick.png
GeForce GT 220 1024 MB Pegatron/Dell/Asus-Offbrand USING Chameleon/Chimera GraphicsEnabler=Yes VBIOS=Yes NvidiaBios=Yes with bios.rom dumped from windows using NVFLASH. Rename bios to XXXX_XXXX.rom using the first XXXX as VendorID and the second XXXX as DeviceID. Tick.png VGA/DVI/ HDMI Tick.png Tick.png Tick.png
GT240 512MB DDR3 XFX Work with retail. GraphicsEnabler=Yes, PCI Configuration Fix (npci=0x2000. No patches. Work fine. Tested on a monitor 22" 1920x1080 full hd Tick.png DVI/VGA/HDMI Tick.png Tick.png Tick.png
GeForce GTX 480 (1536 Mb) (EVGA) NVIDIA TonyMac Multibeast 4.0
  • Worked "Out of the box". No additional kext needed.
  • Recognizes 1536 Mb
  • GraphicsEnabler = Yes
  • Cuda working
Tick.png VGA/DVI/ (HDMI not tested yet) Tick.png Tick.png Tick.png
GeForce 560 Ti 1024 MB Gainward Multibeast 4.4.1
  • Graphics>NVIDIA 4XX/5XX Support
DVI/DVI/ (HDMI not tested ) Tick.png Tick.png Tick.png
GeForce 550 Ti 1024 MB Asus Multibeast 4.5.1
  • Graphics>OpenCl Enabler
  • GraphicsEnabler = Yes
  • Computer say 1536Mb but everything work fine Photoshop, Minecraft, Diablo III
Tick.png DVI/DVI/ HDMI Tick.png Tick.png Tick.png
GeForce 8400 GS 512MB DDR3 EVGA Add 0x10c310de&0xffe0ffff to the list of devices in IOPCIPrimaryMatch in NVDANV50Hal.kext Tick.png Dual with VGA+DVI w / VGA Adapter Tick.png Tick.png Tick.png
GeForce 8400 GS 1GB EVGA aplicar un NVEneabler Tick.png DVI Funciona (VGA No Funciona) Cross.png Tick.png Tick.png
GeForce 8500 GT 256 MB Nvidia iAtkos NVenabler Tick.png DVI HDMI Tick.png Tick.png Tick.png
GeForce GTX 560 1 GB Zotac MultiBeast: Graphics: NVidia 4xx/5xx 10.7.2+ Combo OpenCL Tick.png DVI/DVI/HDMI/Display Port Tick.png Tick.png Tick.png

Network Cards

Wireless

Interface Standard Device Manufacturer Chipset Notes 32/64bit working with patch
PCIE b/g/n150 TL-WN781N (Lite) TP-Link Atheros 9285 TESTED WORKING on 3.39 GHz Intel Core i5, Mac OS X Lion 10.7.4 (11E53), appears as "AirPort Extreme (0x168C, 0x30A1)".
  • Download this KEXT
  • Kext wizard to install
  • Kext Wizard or Kext Utility to repair permissions
  • After install, may have to create "WiFi" location in System Prefrences > Network.
Tick.png Tick.png
USB N150 TL-WN725N TP-Link Realtek 8188CU Tested and working on 10.7.4
  • Need to download the software from Realtek RTL8188CUS [2]
  • The Wireless Network Utility will mange the wireless connection, its included with the package
Tick.png Tick.png
USB IEEE 802.11 b/g/n NWD2205 ZyXEL drivers released on Zyxel site Tick.png Tick.png
USB IEEE 802.11 b/g/n NWD2105 ZyXEL drivers released on Zyxel site Tick.png Tick.png

Wired (Ethernet)

Interface Standard Device Manufacturer Chipset Notes 32/64bit working with patch
PCI 10/100/1000 Gigabit TG-3269C TP-Link RTL8169 Install KEXT from [3]
  • Use kext wizard to install
  • Repair permissions
  • Reboot
Tick.png Tick.png
Powered by MediaWiki © 2021 OSx86 Project  |   InsanelyMac  |   Forum  |   OSx86 Wiki   |   Privacy policy   |   About OSx86   |   Disclaimers